Answered

sonos one SL disappearing from app

  • 26 January 2023
  • 6 replies
  • 128 views

I got a new sonos one and it connects to the app fine. Then all of the sudden when I exit out of the app then open it back up the sonos one is not listed in my system. It happens on everyone’s somos app in the house and I thought it was a product problem so I exchanged it. But it is still happening. I tried to turn off my router and then set up all systems again and it is still not working. So every time I want to use it which is a lot I have to factory reset it and set it up again.

icon

Best answer by Corry P 31 January 2023, 15:22

View original

6 replies

Do you have other SONOS players? 

Do you have other SONOS players? 

Yes I have a Sonos move and a Sonos roam and they both stay connected and visible on the app.

Userlevel 7
Badge +18

Hi @Zekeydog731 

Welcome to the Sonos Community!

Do you have more than one Access Point for connecting to your WiFi? If so, is the speaker in question in a position where it is likely to connect to a different AP than the rest of the speakers? If both of these are true, the additional AP may be the problem.

It could also help to reserve static IP addresses for your devices in your router’s settings - if another device were assigned the same IP as this problem speaker, then the result would be exactly what you see.

I hope this helps.

 

 

I have a similar problem.  I have an ARC and two One SLs.  Starting a week or so ago, one or the other would intermittently fail to show up in the App.  I could power cycle them and they would work again.  Yesterday they quit working and do not reconnect after power cycle.

I have a Deco router, with multiple access points, but I can see that all three products, and my phone, are using the same access point.  They also all have dedicated IP addresses.

 

I tried deleting and reinstalling the app, didn’t work.

 

I tried factory reset and reinstall them.  The app says they are connected, but they do not show up in the system screen.  Another power cycle done and still not there.

 

Any ideas what I can do?

Userlevel 7
Badge +22

Quit Factory Resetting them, it rarely solves issues and often makes things worse. Sonos suggests calling Support before doing it.

What happens if you unplug all APs but the main router, power ALL the Sonos down and then back up and let the Sonos connect to just it?

Stanley_4

Thanks for the advice.  I did what you said and it worked as long as the OneSL’s were located by the primary router.  When I moved them back to the room where I needed them, they disappeared from the app.  Fortunately they are not too far away to connect to the primary router.  I was able to configure the network to force connection to the primary router and that seems to have fixed things!

Thanks again!

Reply