Sonos One - Both speakers not connecting to network (wired and wireless)

I bought a pair of Sonos Ones in September 2020 and they have been on a shelf, working flawlessly, until a few days ago.  I opened the Sonos app on my Apple iPhone to play some music and the app reported that it could not find the speakers. There had been no network changes to the WiFi network they connected to and other devices (including the iPhone) were still connecting to the WiFi network fine.


Following the prompts on the iPhone app to reconnect the speakers to the network (using a Bluetooth connection between the phone and the speakers) progressed well until after the WiFi network password was entered, after which the iPhone app immediately reported that the Sonos One failed to connect the network.  Both speakers behaved exactly the same.  I tried factory reset (holding down the connect button while powering on the speaker), but the result is the same.


I moved both speakers off the shelf to my desk where I have wired ethernet and tried using a wired connection on one of the speakers. This also failed to connect the speaker to my home network and I can’t see any evidence of the speaker acquiring an IP via DHCP from my router.  The ethernet cable functions perfectly when plugged into my laptop, so there is no problem with the cabled connection to my router.


I seem to remember that the speakers where set up to automatically apply firmware/software updates and I did allow them access to the internet on my router’s firewall.  I am wondering if they automatically downloaded an update which failed in some way and broke network connectivity?


How do I troubleshoot this issue?  Any help hugely appreciated.  I am missing my music. 😢

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

I’m not exactly sure about the current state of your system. Have you Factory Reset one or both of the units? Are these two the only SONOS units on your network? Are you using the S2 (gold icon) SONOS controller?

I’m suspicious that there is a hardware issue with one of the speakers, however, this is not yet proven because the other speaker should be visible, but annoyed if this was a stereo pair and only one unit has been Factory Reset.

Refrain from any additional Factory Resets until we get a better handle on the situation.

Have you reserved IP addresses for regular network clients?

Hi Buzz,


I think I factory reset both of them already.  There are only these 2 Sonos speakers on my network. I am using the gold icon SONOS S2 app and have tried reinstalling the app on the iPhone, but that made no difference.

The speakers were in a stereo pair configuration.

If it is a hardware issue, it would be strange that both are affected at the same time, unless both were exposed to a damaging power surge. It would also be strange if both the internal wireless WiFi adapter and the internal ethernet adapter were affected by a power surge, but other functionality, like Bluetooth connection to the SONOS app on the iPhone and being able to progress to the point of entering a WiFi password while following the reconnect wizard on the app, is still working.


I wish there was a way to log on to these devices and look at logs.


I have reserved IPs outside of the DHCP dynamic pool for the MAC addresses of the WiFi adapters of both speakers.


What do you think I should try next?  Thanks.

Does anyone know when the most recent firmware update was sent to Sonos One systems that were set to automatically update firmware?  I’m wondering if that could be involved?  There have been a lot of power outages in my are for the past few months, so it’s not impossible that a firmware update could have been interrupted by a power outage.  That could affect both speakers.  Really guessing now, though.  Would be good to systematically diagnose the problem rather than guess wildly.

I don’t recommend attempting to assign an IP addresses outside of the DHCP range because SONOS will ask the DHCP server for an address. The router might return a status of “not my client”. There is no way of assigning an IP address using SONOS resources, it’s DHCP only.

Userlevel 7
Badge +22

Buzz, some routers require you to adjust the DHCP pool size to have addresses available on the LAN in the DHCP range, but outside the dynamic pool in order to use them as reserved IP addresses.

So for this your LAN’s router would be 192.168.01, the pool would be set to to giving you to 192.168.254, outside the dynamic assignment pool but still inside the DHCP scope, for reserved IP addresses. You can fiddle the 199/200 split as needed or even move it to the low end at 2/20 if you prefer.

My DHCP setup is as @Stanley_4 described.


Specifically, the DHCP server will assign and to the Sonos One speakers, identifying them based on the MAC addresses of their WiFi adapters.  The dynamic range for unrecognized MAC addresses is to

Good news from my side is that it seems that the speakers are, fundamentally, working! 😃  I moved them right next to the wireless router that they most likely were connecting to from their normal location, connected them to the 5G SSID (one required factory reset to join the network), linked them as a stereo pair and played some music!


Moving them back to their normal location causes the same problem again, though (not able to connect to WiFi), but now I’m starting to suspect the wireless router (Ubiquity UniFi LR).  I will post an update if I make more progress.

Sometimes Ubiquiti updates can introduce unfortunate “features”.

Userlevel 7
Badge +22

I moved to SonosNet to get my Sonos off my Ubiquity WiFi, didn’t want to have to downgrade my Ubiquity settings to be compatible with sonos needs.

Try wiring a speaker (not sub/surround) to your main Ethernet hub and see how that works.

Strangely, I cannot get the speakers to work wired directly to the Ethernet switch of my home LAN. Sonos S2 app reports unable to connect the speaker to the network.


I’m wondering if my Ubiquiti EdgeRouter, which is the DHCP server for my entire LAN, is not playing nicely with the Sonos speakers?  I did update the firmware on the Ubiquity EdgeRouter 3 weeks ago, which could roughly coincide with the start of the issues with the speakers.  I had not tried playing any music for a while before discovering the problem, so I’m not exactly sure when it started.  I’m not aware of any other devices on my home LAN having problems with DHCP since the update, but maybe it’s a Ubiquiti-Sonos clash?


I will continue trying to solve the issue and post updates, as time allows.