Answered

Locking Sonos to 5GHz

  • 24 December 2022
  • 12 replies
  • 1114 views

Is it possible to force Sonos to use the 5 GHz band and thus avoid microwave interference?

I have recently replaced some old Sonos devices with new S2 capable devices, so I have a mixture of Sonos Five, Sonos Port (all new) and Play:3 (older, not replaced). Three of them are hard-wired to the LAN, the rest rely upon wireless.

My home WiFi network supports both 2.4GHz and 5GHz (same SSID) with two WAPs to provide good 5GHz signal throughout my house.

My problem is that when I use my microwave a number of the devices lose the music stream (which is coming from a NAS hard-wired to the LAN).  

This suggests Sonos is using 2.4GHz.  Is there anyway I can have the Sonos devices just use 5GHz all the time to avoid this issue?

 

 

icon

Best answer by Airgetlam 24 December 2022, 22:00

View original

12 replies

Unless your access points offer this sort of feature, you would need to use different SSID’s.

I really don't want to use different SSIDs.   Although that is a possibility, it brings a lot more complications.  (I used to use split SSIDs but moved away from that.).  Besides, I am not sure how that helps since the Sonos devices use their own wireless mesh (Sonosnet) anyway as I understand it.

Can I disable Sonosnet and rely upon them connecting to my home LAN?  Even if I do, can I force them to use 5GHZ?

SSID is the only way to control the band. In some cases, such as a direct, private wireless connection to surround speakers SONOS will use 5GHz.

SonosNet will do it’s own thing, ignoring WiFi. WiFi will ignore SonosNet. Unfortunately, both use the same band and can cause interference. You may have some success using a different SonosNet channel. 

Is this “microwave” a kitchen appliance or some sort of nearby industrial emission? If this is a kitchen microwave, moving the nearby player might help.

SonosNet, to my knowledge, is only 2.4Ghz, for both better wall penetration, and signal range. For streaming music, there just isn’t the need for larger and faster bandwidth. 

Yes, many people have chosen to use an unwired network, but if you’re unwilling to run two different SSIDs, there is no way to ‘lock down’ Sonos to use the 5Ghz signal, unless that is the only signal available. And the very oldest Sonos devices (like the PLAY:5 gen 1) don’t have a 5Ghz antenna. 

Thanks for the responses.

The microwave is a simple kitchen appliance.  Not industrial.  Moving the Sonos Five is not an option (plus, using the microwave impacts other units elsewhere in the house, although that may just be because of the way the mesh had been established).

I was not aware Sonosnet was only 2.4GHz.  I do understand the logic on better distance and wall penetration, but the home microwave undermines that.  I am aware that older devices (such as the Gen 1 Play:5's I just retired) only have a 2.4GHz antenna but I was hoping that if I had all new devices I could insist upon 5GHz.  

Microwave oven emissions vary. Years ago I had a SONOS CR200 almost a foot away from a GE oven and a CONNECT:AMP about three feet from a microwave oven and we did not have issues. I have friends with a pair of MOVE’s on the other side of their kitchen and there are no issues

Is your oven using a grounded outlet?

I’m aware that some people have significant issues.

For the record, which Microwave are you using? I’m not sure what model my friends are using.

I replaced a microwave at one point, as it was leaking RF interference. It was an older model, so it wasn’t a big issue for me to do so, the newer model had more features, and it didn’t cause any interference on the Sonos speakers in my kitchen. 

The microwave is a Neff microwave and is only a couple of months old.  It's predecessor (20 year old Panasonic) also caused interference (albeit with the old Play:5 that was in use at the time).   The kitchen layout is not helpful (microwave plus ovens and fridge all on one wall, which is the inner wall of the house and this interferes with wireless signals to the rest of the downstairs.  That is why I have my second WAP (BT Disc) placed above the kitchen.

I also have a laptop in the kitchen near the Sonos Five which was badly impacted by the microwave being used until I set it to prioritise the 5GHz band.  So switching frequency to 5GHz is definitely a good option if I could force Sonos to do that.  I would have thought that was a pretty simple thing for the firmware to support if Sonos choose to do so but it seems they have not.

 

Userlevel 7
Badge +18

@iandom Have you tried changing the WiFi channel? Sonos should be on 1 or 6 or 11. It it e.g. now is on 1, try 6 or 11 and see if the problem persists.

I have tried that, albeit with little expectation of success.  In my case channel 1 is the obvious choice because there are no other local WiFi networks using channel 1.  However, all of those channels are in the 2.4GHz band (2401 to 2484 MHz) which is what microwaves interfere with whereas the 5GHz band avoids the problem completely.

Userlevel 5
Badge +2

I recently upgraded to S2 and removed all legacy devices that could not be updated to the S2 platform. I only have (4) Play 1 devices using Sonosnet via the Boost, everything else is hard-wired. I unplugged (ac power) the Boost and Play 1’s then powered the Play 1’s up again but not the Boost, effectively forcing a WiFi connection and removing Sonosnet. My Play 1’s all reconnected to my Orbi Router (mesh system) at 5ghz.

Note that RF interference is not exclusive to Wi-Fi (radio) signals only, it can affect/penetrate cables as well, depending on a wide variety of factors. Cabling your Sonos can help in most cases, but it’s not a silver bullet. 

Reply