Sticky

grouping 5hz and 2.4 hz

  • 22 November 2023
  • 32 replies
  • 401 views

Userlevel 2
Badge +3

Hi all

I’ve had the current set for a while now but recently I’ve experienced more connection issues than ever, despite no changes to my set up.  These are especially bad when grouping pairs of speakers with other ones.

I’m on BT smart Hub 2 and I have to use the BT disks to get wifi around the house.

Although I know these are not recommended , as above, it seems to have got worse recently.

I’ve been digging through my wifi app and can see that some of my products connect using the 5hz band and others on the 2.4hz.

Will that make a difference with the grouping and is it possible to make them all use the same?; I’ve read on here that 2.4 is better at reducing interference.

Many thanks in advance

David


32 replies

Yes it may help - seperate the bands in your router configuration pages and give the 5Ghz band a slightly different name, for example if the network SSID is currently called ‘MyBTNetwork22’ then leave that name for the 2.4Ghz band to use and add "-5G” to the 5Ghz SSID eg. ‘MyBTNetwork22-5G’ and all will then use the 2.4Ghz band (recommended). Put other non-Sonos wireless networked devices onto the 5Ghz band out the way, if they are capable and within reach.

Set the 2.4Ghz band to ‘fixed’ Channel 1, 6 or 11 (non-overlapping) and set a channel-width of 20Mhz only and see if that improves things.. leave your mobile controller device cinnected to that band too.

Userlevel 2
Badge +3

Thanks Ken

It is unfortunate that the two worst places for wifi coverage are both stereo pairs and the two rooms that we group the most!

We do have a lot of issues with the S2 app on the mobile; often the players don;t show up, even when they are playing; again seems to have got worse over the last 6 months.  I also use my laptop as a controller.  Would you recommend keeping that on 5hz or also moving that to 2.4hz?  I need it for work zoom calls etc, not really for streaming

thanks

David

Userlevel 7
Badge +22

Keeping everything Sonos on one band is the least likely to cause issues. If your router isn’t misbehaving having the controller on 5 and the speakers on 2 should work reasonably well.

Some visibility glitches are reduced if you set static/reserved IP addresses for your Sonos using the rotuer’s DCCP settings page. Follow that with a power-down for all Sonos and a full router (amd disks) reboot.

Userlevel 2
Badge +3

Ok thanks Stanley - I’ll give that a go too

Many thanks

David

Just to briefly mention aswell @DavidJS that the BT Smart Hub 2 is not a very well-regarded router in this community and many users have had some difficulties with it - if you search you will see that some past firmware updates have caused some users to do what you’re looking to do here and put all Sonos devices on the 2.4Ghz band - some have even (temporarily) switched off the 5Ghz band altogether (not recommended).

So I think if you put everything Sonos related (controllers too) onto 2.4Ghz band and other wireless products on the 5Ghz band (where practicable) you should see things improve.

Userlevel 2
Badge +3

Thanks Ken

Yes, I had seen that. 

It is ironic though that through the BT disks I do have very reliable wifi in all of the far flung corners of the property, so actually very happy with all other aspects of the BT wifi!

Thanks again for the advice

David

Thanks Ken

Yes, I had seen that. 

It is ironic though that through the BT disks I do have very reliable wifi in all of the far flung corners of the property, so actually very happy with all other aspects of the BT wifi!

Thanks again for the advice

David

Yeah it’s not a WiFi connection issue per-se, it’s more about a multicast ‘device discovery’ issue between the Sonos controller App and the speakers - the SSDP (part of the UPnP protocol) multicast ’discovery’ packets transversing the BT Hub network were/are not always successfully passing between its various network segments. So putting all on the same WiFi band and channel can help with this. At least that’s my understanding.

Userlevel 2
Badge +3

I don’t fully understand all of the technical bits, but it makes sense as I have found that toggling the wifi on my mobile on and off (when the speakers have gone awol) often sorts things out and magiclly they reappear!

And interestingly, the desktop app is much more reliable; not 100% but much better than the mobile app

Some things on a mobile phone may not help this issue of ‘device discovery’ too. 

On my iPhone for example, I personally choose to do the following to try to assist with ‘device discovery’…

  • Switch off ‘Private Address’ (MAC spoofing) in the local network connection property settings
  • Switch off ‘WiFi Calling’ in Settings/Mobile Service or ‘Settings/Phone’
  • Switch off ‘Mobile Data’ access for the Sonos App - to make the App always use a WiFi only connection.
  • Switch off VPN client and other security software on the mobile device

On a separate note, I also choose to reserve the Sonos IP addresses in the routers DHCP reservation table.

Userlevel 2
Badge +3

On a separate note, I also choose to reserve the Sonos IP addresses in the routers DHCP reservation table.

Presume this is done on the router admin screens?

On a separate note, I also choose to reserve the Sonos IP addresses in the routers DHCP reservation table.

Presume this is done on the router admin screens?

Yes correct. I’m not sure if this may help you, but it’s a YT video I found in relation to setting static IP addresses for devices on the BT Smart Hub v6. I haven’t watched it, but it maybe similar software to your router and perhaps ‘may’ help you…

 

Userlevel 2
Badge +3

cool, thanks - Looking at the screen (too late to attempt it now), it does look like I can configure each Sonos to use static.  I’ll work through each bit in turn, starting with the split SSIDs

Thanks again

You can't split the bands on the Smart Hub 2.

Userlevel 2
Badge +3

Ah - Yes, just seen that!

So, now what?

It does look like the IP addresses for the players are set to static

Userlevel 2
Badge +3

I do have a play 1 near the router - I have been advised by Sonos in the past to use wifi rather than connect this play 1 to the router

But then, I’ve also read that connecting to the router will create the Sonos mesh network

Any ideas if that will be better?

Try wiring the Play:1. Wait 5-10 mins then look in Settings/System/About My System. All should show WM:0, apart from the Move. If any units (other than the Move) still show WM:1 reboot them by unplugging for 30 secs.

See how that goes. If there are still problems try different SonosNet channels, then if that doesn’t help post a screenshot of the Network Matrix from http://x.x.x.x:1400/support/review where x.x.x.x is the IP of any player (obtained from About..).

 

I briefly tried Sonos on the BT Whole Home WiFi and quickly gave up. The discovery packets sent out by the controller were apparently blocked between the bands (and BT WHW can’t split the bands either). The same was true for discovery by the IKEA Home Smart app.

Is there any MAC Address blacklisting options for the 5Ghz band on the BT router? - I also seems to recall in a previous thread involving that hub, that some users switched off their 5Ghz band, perhaps that’s an option to try (if that feature is available)🤔?

Personally, I would get rid of it and use a different router/mesh setup.

It’s a non-representative sample, but the only WiFi I’ve encountered that had per-band access control is ASUS. 

The 5GHz can be switched off -- mainly to help connect 2.4GHz IoT devices one assumes -- but one clearly wouldn’t want to do so permanently as it would leave only the slow, congested, 2.4GHz band.

Userlevel 2
Badge +3

It’s a non-representative sample, but the only WiFi I’ve encountered that had per-band access control is ASUS. 

The 5GHz can be switched off -- mainly to help connect 2.4GHz IoT devices one assumes -- but one wouldn’t clearly want to do so permanently as it would leave only the slow, congested, 2.4GHz band.

Yeah, I don’t really want to turn 5hz off permanently

FWIW I have a friend that has this same BT Hub and they have run things slightly better on SonosNet with one device wired to the router, but he still has had the issue of their Move (gen1) not showing up in the App from time to time. 

He is currently considering either getting his own router, or switching to Virgin Media, but has not made up his mind yet. He did bring the Move around to my Home and I had it on test for a weekend on a Virgin Media Hub v5 to make sure it wasn’t a fault with the speaker and it worked perfectly fine with that router.

Unfortunately all these ISP-supplied boxes/systems are built down to a price. I run nothing Sonos-wise off my BT Smart Hub 1.

Userlevel 2
Badge +3

I’ve read a bit on the BT community and someone has suggested using a second BT router (I actually have 2 previous routers; they never asked for them back), turn off the 5hz band on that and then connect Sonos to that network.

They suggested ensuring it used a different IP address to avoid clashes with the existing network.

Any thoughts on that proposed solution and how to I change the IP address of a router?

 

As a second question - I often check the matrix map, and I notice that if changes throughout the day.  Take this morning for example, first thing everything was green and now I have a red flag for the left surround speaker of the playbar - Why would this happen when nothing else is changing in that room?

Userlevel 2
Badge +3

Don’t if it is related, but I went on my router settings and tried to rename the player and got this message

???

I’ve read a bit on the BT community and someone has suggested using a second BT router (I actually have 2 previous routers; they never asked for them back), turn off the 5hz band on that and then connect Sonos to that network.

They suggested ensuring it used a different IP address to avoid clashes with the existing network.

Any thoughts on that proposed solution and how to I change the IP address of a router?

It depends what you envisage.

You could stack (cascade) a second router behind the main one, so long as you move everything onto the second router’s subnet. This is known as ‘double-NAT’. To do that you’d need to change the second router’s subnet prefix to something different, such as 192.168.2.x. 

If you just want to use the second router as an access point you’d need to disable its DHCP server, change its internal address to, say, 192.168.1.253 (i.e. something other than .254), and wire it via a LAN port. This may help: https://www.cnet.com/home/internet/how-to-turn-an-old-wi-fi-router-into-an-access-point/

 

As a second question - I often check the matrix map, and I notice that if changes throughout the day.  Take this morning for example, first thing everything was green and now I have a red flag for the left surround speaker of the playbar - Why would this happen when nothing else is changing in that room?

The Playbar’s satellites idle on 2.4GHz. That’s just a bit of ambient noise. You can ignore it, since they move to 5GHz when operational.

Don’t if it is related, but I went on my router settings and tried to rename the player and got this message

???

It looks like you tried to reserve a fixed IP that was already in use.

Reply