Error message reads Sonos is on a different network


Badge
  • Contributor I
  • 5 replies

Trying to install (2) One SL and (3) Roam speakers in a new office (stand alone building). The Sonos App locates all 5 speakers, and with each speaker it gives me a message saying that my phone is on a different network and to finish the setup in the systems tab. I have contacted Sonos support, sent multiple diagnostic reports, factory reset all speakers, the app, plugged speakers directly into the router and contacted the network provider that provides support for my wifi. I turned off the 5g to force everything onto 2.4. I tried a different phone and bought a new tablet. The Sonos App will not hook to any speakers. I have all Andriod products. From what I have read this seems to be a common problem with Sonos. Has anyone found a fix or work around? 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Userlevel 7

You mentioned in your post the following statement...”contacted the network provider that provides support for my wifi”. Is your network some type of business account? Typically in those arrangements there are two networks

  • Primary
  • Guest

Unless one has permission (by whatever means permission is given) to join the Primary that person; as well as any unauthorized hardware, is automatically placed on the Guest network. Your Sonos may be hitting the Guest network and not the Primary therefore the message you are getting. 🤔

Badge

I do have a business class managed network. The firewall, router and switches are all managed by Spectrum Business Class. I spoke to a Sonos Technical Support representative and we discussed the hardware and possible issues to look into. Then I contacted Spectrum and explained to them I was trying to setup Sonos. I had them disable the firewall first. Then I had them disable the 5G wifi. I confirmed we do not have a guest network and none shows up on a wifi scan of the office. We have 2 wireless access point antennas, I unplugged one. Each step in the process I factory reset the speakers and reset the Sonos App and reset the router. I have plugged the One SL speakers directly into the router, one at a time) I have talked to Sonos on 2 separate days and my network manager 4 days. I've personally been on the phone for more than 12 hours. I have used my phone (a 3 month old Samsung S23 Ultra), I used a spare phone (1 year old S22 Ultra) and purchased a new Galaxy Pro tablet with zero personal software on it. 

Maybe this applies to you.

Badge

I would like to mention that during this entire process the Account, System and Services & Voice tabs in the Sonos App were subdued and would not allow access. I called Sonos support about this and asked if I should start a separate account with another email address. (I have a very large multiple room system operated by Sonos in my home) the Sonos App kept looking for the "missing equipment". The three functions I mentioned were subdued on the first Sonos App. I created a new account with a different email address and entered the new wifi and password in the second app. The same 3 functions of the Sonos App were subdued. Then I stopped using my phone and tried 2 other devices. 

Badge

I did plug both One SL speakers (one at a time) directly into the router, ran a diagnostic report, while I was on the phone with Sonos Support and they confirmed seeing the speaker on the network. The Sonos App was still subdued and would not allow access to the systems tab. 

Userlevel 7

Thanks for the reply. I suggest you disable the access points and try setting up Sonos. The access points are the only reason I can think of that is causing the message that your phone and Sonos are not on the same network.

There is one more possibility…Is there a managed switch involved?

Badge

Yes, there is a managed Switch and the WAP's are plugged into it. I plugged into the switch and then I plugged directly into the router. 

Userlevel 7

OK...I suggest you try by-passing the managed switch as they can cause problems for Sonos. You only need to plug one Sonos speaker (or a Sonos Boost) directly into your main router to create the SonosNet. By creating the SonosNet the office Wi-Fi is a non-issue

Userlevel 7

Correction: I reread one of your previous posts where you said you plugged a Sonos speaker directly into your router. Therefore doing so again would not change anything.

However, regarding the managed switch. The switch should be set so that it does not generate IP Addresses. That can be a problem for Sonos. 

Badge

Thank you for the help, I really appreciate it. If/when I figure this out, I'll post the results that worked for future reference. 

I'm sorry to hear that you're experiencing difficulties with setting up your Sonos speakers. The "Sonos is on a different network" error message typically occurs when the Sonos app and the speakers are connected to different subnets or have trouble communicating with each other.

Here are a few troubleshooting steps you can try:

1. Ensure all devices are on the same network: Double-check that your phone, speakers, and any other Sonos devices are connected to the same Wi-Fi network. Sometimes, certain router settings or network configurations can cause devices to be on different subnets, leading to communication issues.

2. Restart your network equipment: Power cycle your router, modem, and any other network devices. Unplug them from the power source, wait for about 30 seconds, and then plug them back in. This can help refresh the network connection and resolve any temporary network issues.

3. Disable guest networks and network isolation features: Some routers have guest network or network isolation features that can prevent Sonos devices from communicating properly. Make sure these features are disabled or configure your router to allow communication between devices on the network.

4. Check router settings: Verify that your router's settings, such as wireless isolation or access control, are not blocking the Sonos devices from connecting to each other. Refer to your router's documentation or contact your network provider for assistance in configuring these settings.

5. Create a dedicated 2.4GHz Wi-Fi network: Sonos speakers use the 2.4GHz frequency band for communication. If possible, create a separate Wi-Fi network on the 2.4GHz band and connect all your Sonos devices to that network. This can help avoid potential interference or compatibility issues with other devices on the network.

If you've already tried these steps without success, I recommend reaching out to Sonos support again. They will have more in-depth knowledge of the specific issue and can provide further assistance in troubleshooting the problem.

 

Regards;

David Johnson.