Answered

Constant connection issues with two speakers

  • 21 December 2023
  • 16 replies
  • 323 views

Userlevel 2
Badge +2

My system has started exhibiting near constant connection issues on two speakers in particular. A (I think) first gen Play:3 and first gen Playbar are the problems for the most part. Started about 6 months ago maybe. At night I play rain sounds from my music library on 3 different rooms in my home. A Play:1, a Play:3 (the problem one) and the Playbar that’s part of a surround setup with the Sub and two Play:1’s. The Play:3 will only function for a few nights before it starts cutting out again. If unplug it and restart the speaker it seems to fix it for a few more days.  Same with the Playbar, though it can also exhibit similar issues with TV programming. When I play this audio from my library, each room is playing it independently, mainly because playing grouping across multiple rooms usually gives me problems as well. So like I said, rebooting the guilty speaker seems to fix things for a few days. It’s almost as if they are encountering so many errors they freeze up or something. 
 

My network is a Google Nest mesh wifi. I’ve had if for a couple years, and nothing about my network has changed recently. Can someone take a look at my diagnostics and see if anything stands out?  The doagnostic is 281607275. 

icon

Best answer by Corry P 27 December 2023, 11:54

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

16 replies

To get your Sonos diagnostic report looked at you need to contact Sonos Support Staff via this link:

https://support.sonos.com/s/contact

There are Staff here in the community, but they may not get to see every report/post here.

As you’re using a Google mesh WiFi network you may perhaps find this Staff thread helpful too:

https://en.community.sonos.com/speakers-229128/troubleshooting-sonos-on-wifi-6856334?postid=16520976#post16520976

Hope that assists. 👍

Userlevel 2
Badge +2

To get your Sonos diagnostic report looked at you need to contact Sonos Support Staff via this link:

https://support.sonos.com/s/contact

There are Staff here in the community, but they may not get to see every report/post here.

As you’re using a Google mesh WiFi network you may perhaps find this Staff thread helpful too:

https://en.community.sonos.com/speakers-229128/troubleshooting-sonos-on-wifi-6856334?postid=16520976#post16520976

Hope that assists. 👍

Thanks for the tips. I’ll check those out. Hopefully a staff member will chime in here, as there seems to be no email option at the contact link, and I don’t have the free time this time of year to sit on the chat and wait. 

Userlevel 7
Badge +18

Hi @BrentD 

Thanks for your post!

The Play:3 is missing from the diagnostics, so I can’t relay to you anything it’s saying, but the Boost is reporting a 10% error rate when communicating with it in the past, roughly, suggesting that the Play:3 may have a less than ideal signal strength, or a little too much interference near it. Moving the speaker a little may improve the signal strength, but if there are any radio/WiFi-enabled devices near it, I recommend moving them away. Keep in mind any devices that may be on the other side of a wall that the Play:3 may be up against.

The Playbar is reporting interference and by it’s nature it cannot be moved, and this is likely the same for devices near it, but if there are any devices near it that can be moved, moving them may help. Especially if it’s a mesh node.

What concerns me the most, however, is the Boost being somewhat flooded with multicast packets that are not intended for any Sonos devices. Reducing these should clear up the Boost’s network interface so that it can focus on delivering to your speakers. Generally, the best way to clear this up is to activate IGMP Snooping/Filtering on your router, if it has that option (a quick search suggests that Google Mesh systems do not have this option, but if your Google Mesh is in AP/Bridge mode, maybe your other router does?). If the option is not available, I suggest fitting a IGMP-capable network switch between the main Google mesh node and the Sonos Boost - you should be able to get one of these for around £$€40. Alternatively, use packet sniffing software to find the source of the multicast flooding and configure that device/service to stop doing it (you’d need to Google how to do this).

Feel free to submit another support diagnostic when you are sure the Play:3 is shown in the app and I’ll take another look (but please let me know the number given).

I hope this helps.

 

Userlevel 2
Badge +2

Hi @BrentD 

Thanks for your post!

The Play:3 is missing from the diagnostics, so I can’t relay to you anything it’s saying, but the Boost is reporting a 10% error rate when communicating with it in the past, roughly, suggesting that the Play:3 may have a less than ideal signal strength, or a little too much interference near it. Moving the speaker a little may improve the signal strength, but if there are any radio/WiFi-enabled devices near it, I recommend moving them away. Keep in mind any devices that may be on the other side of a wall that the Play:3 may be up against.

The Playbar is reporting interference and by it’s nature it cannot be moved, and this is likely the same for devices near it, but if there are any devices near it that can be moved, moving them may help. Especially if it’s a mesh node.

What concerns me the most, however, is the Boost being somewhat flooded with multicast packets that are not intended for any Sonos devices. Reducing these should clear up the Boost’s network interface so that it can focus on delivering to your speakers. Generally, the best way to clear this up is to activate IGMP Snooping/Filtering on your router, if it has that option (a quick search suggests that Google Mesh systems do not have this option, but if your Google Mesh is in AP/Bridge mode, maybe your other router does?). If the option is not available, I suggest fitting a IGMP-capable network switch between the main Google mesh node and the Sonos Boost - you should be able to get one of these for around £$€40. Alternatively, use packet sniffing software to find the source of the multicast flooding and configure that device/service to stop doing it (you’d need to Google how to do this).

Feel free to submit another support diagnostic when you are sure the Play:3 is shown in the app and I’ll take another look (but please let me know the number given).

I hope this helps.

 

Thanks Corry. I didn’t realize the Play:3 was offline when I created the diagnostic report. It may have been rebooting still, as the dropouts on that device are what caused me to think to write this post to start with. There are no wireless devices near that speaker, but there is an Apple MagSafe charger. Could the magnetic/electronic field coming from that possibly mess with that speaker? 
 

The Playbar does have a WiFi mesh point about 2 feet from it, but the only time I have had any issue with the Playbar has been when the Play:3 was concurrently having issues. And 90% of the usage of the surround setup is when it is being fed by an optical cable directly from the TV, so it seems odd that it would happen then. As far as interference from the mesh point, the issue there is the only other power sources I could move the mesh point to already have the Play:1’s used as rear speakers plugged into them. 
 

My Google Nest WiFi mesh’s main point is plugged directly into my cable modem. From the main point it feeds a TP-Link TL-SG116 unmanaged 16 port switch. The Boost is one of the items plugged into that switch. According to the product details page for the switch, it does have IGMP snooping capabilities, so I’ll have to look into that when I am home again this evening. I will also get a new diagnostic and post the number here. Thanks so much for the direction in investigating this. 

Userlevel 7
Badge +18

Hi @BrentD 

Thanks Corry. I didn’t realize the Play:3 was offline when I created the diagnostic report. It may have been rebooting still, as the dropouts on that device are what caused me to think to write this post to start with. There are no wireless devices near that speaker, but there is an Apple MagSafe charger. Could the magnetic/electronic field coming from that possibly mess with that speaker? 

I wouldn't think so, no.

The Playbar does have a WiFi mesh point about 2 feet from it, but the only time I have had any issue with the Playbar has been when the Play:3 was concurrently having issues. And 90% of the usage of the surround setup is when it is being fed by an optical cable directly from the TV, so it seems odd that it would happen then. As far as interference from the mesh point, the issue there is the only other power sources I could move the mesh point to already have the Play:1’s used as rear speakers plugged into them. 

Interference would not affect the Playbar when playing TV audio via the optical link, but it could affect the surrounds - I would say 2 feet is 1 foot too close. For music playback, interference could be an issue. If Playbar is in group with Play:3, and Play:3 was selected first (so it’s at the top of the list of grouped rooms and therefore in charge of fetching music and distributing it to other rooms, interference either at the Playbar or at the Play:3 could affect Playbar. Interference at Boost would also affect both, but I don’t see that in the diagnostic.

My Google Nest WiFi mesh’s main point is plugged directly into my cable modem. From the main point it feeds a TP-Link TL-SG116 unmanaged 16 port switch. The Boost is one of the items plugged into that switch. According to the product details page for the switch, it does have IGMP snooping capabilities, so I’ll have to look into that when I am home again this evening. I will also get a new diagnostic and post the number here. Thanks so much for the direction in investigating this. 

For an unmanaged, IGMP-capable switch, the filtering should be happening without any configuration needed (or, indeed, possible), so I don’t know why this is not working for you - all I can say is that multicast packets not intended for Sonos are arriving at the Boost’s interface. Perhaps using a packet sniffer to find the source of the flooding is the best solution after all.

You are most welcome, and I hope this helps.

Userlevel 2
Badge +2

Hi @BrentD 

Thanks Corry. I didn’t realize the Play:3 was offline when I created the diagnostic report. It may have been rebooting still, as the dropouts on that device are what caused me to think to write this post to start with. There are no wireless devices near that speaker, but there is an Apple MagSafe charger. Could the magnetic/electronic field coming from that possibly mess with that speaker? 

I wouldn't think so, no.

The Playbar does have a WiFi mesh point about 2 feet from it, but the only time I have had any issue with the Playbar has been when the Play:3 was concurrently having issues. And 90% of the usage of the surround setup is when it is being fed by an optical cable directly from the TV, so it seems odd that it would happen then. As far as interference from the mesh point, the issue there is the only other power sources I could move the mesh point to already have the Play:1’s used as rear speakers plugged into them. 

Interference would not affect the Playbar when playing TV audio via the optical link, but it could affect the surrounds - I would say 2 feet is 1 foot too close. For music playback, interference could be an issue. If Playbar is in group with Play:3, and Play:3 was selected first (so it’s at the top of the list of grouped rooms and therefore in charge of fetching music and distributing it to other rooms, interference either at the Playbar or at the Play:3 could affect Playbar. Interference at Boost would also affect both, but I don’t see that in the diagnostic.

My Google Nest WiFi mesh’s main point is plugged directly into my cable modem. From the main point it feeds a TP-Link TL-SG116 unmanaged 16 port switch. The Boost is one of the items plugged into that switch. According to the product details page for the switch, it does have IGMP snooping capabilities, so I’ll have to look into that when I am home again this evening. I will also get a new diagnostic and post the number here. Thanks so much for the direction in investigating this. 

For an unmanaged, IGMP-capable switch, the filtering should be happening without any configuration needed (or, indeed, possible), so I don’t know why this is not working for you - all I can say is that multicast packets not intended for Sonos are arriving at the Boost’s interface. Perhaps using a packet sniffer to find the source of the flooding is the best solution after all.

You are most welcome, and I hope this helps.

Corry,

Here is the new diagnostic number: 1874278100

All of my speakers were showing in the app when I generated the report. 

I suspect it will be several days before @Corry P can respond. Most often, he doesn’t seem to work weekends, and of course next Monday is a holiday. Just to temper your expectations….

Userlevel 7
Badge +18

Hi @BrentD 

Thanks for the new diagnostics - they indicate that the Boost’s signal to the Play:3 is more than sufficient, and that there isn’t a troubling amount of interference near the Play:3, or at least there hadn’t been in the 15 minutes prior to the submission of the diagnostic. It’s also not reporting any playback errors, so I can’t correlate what goes wrong to anything specific. This does lead me to believe that if you can cure the multicast flooding issue at the Boost, you will probably fix the Play:3’s issues. Note that although Boost reports a 10% transmission error rate (that I reported before), it reports similar levels with other speakers, so this probably isn’t the answer we’re looking for.

Alternatively, you could try putting your Sonos system on to WiFi instead of SonosNet - go to Settings » System » Network » Manage Networks » Update Networks and follow the on-screen instructions to connect your system to WiFi. When the app tells you to disconnect the ethernet cable, just unplug Boost from power and wait a couple of minutes. If, after testing, things don’t work as well as they currently do now, just power the Boost back on to revert. Please ensure all speakers are online when you setup for WiFi.

I hope this helps.

Userlevel 2
Badge +2

Hi @BrentD 

Thanks for the new diagnostics - they indicate that the Boost’s signal to the Play:3 is more than sufficient, and that there isn’t a troubling amount of interference near the Play:3, or at least there hadn’t been in the 15 minutes prior to the submission of the diagnostic. It’s also not reporting any playback errors, so I can’t correlate what goes wrong to anything specific. This does lead me to believe that if you can cure the multicast flooding issue at the Boost, you will probably fix the Play:3’s issues. Note that although Boost reports a 10% transmission error rate (that I reported before), it reports similar levels with other speakers, so this probably isn’t the answer we’re looking for.

Alternatively, you could try putting your Sonos system on to WiFi instead of SonosNet - go to Settings » System » Network » Manage Networks » Update Networks and follow the on-screen instructions to connect your system to WiFi. When the app tells you to disconnect the ethernet cable, just unplug Boost from power and wait a couple of minutes. If, after testing, things don’t work as well as they currently do now, just power the Boost back on to revert. Please ensure all speakers are online when you setup for WiFi.

I hope this helps.

Hmm. Followed the steps to put my system on WiFi. It told me my WiFi network has been added to the system as a trusted network. Never said anything about unplugging the Ethernet cable from the Boost. Under networks it still lists the SonosNet channel. If I tap Manage Networks it shows my WiFi network there. So do I just unplug the Boost now or…?

 

For what it’s worth, here’s a new diagnostic after I did the above steps. 770778963

 

EDIT A BIT LATER: So I found another thread referring to some diagnostic info that is accessible via IP address of any of my speakers. Looked at that info and could see on the Network Matrix where there were interference issues. Master Bedroom (where the Play:3 issue was persistent) was red for interference. Removed a baby monitor and the wireless charger I mentioned before and it had zero effect on interference readings. Boost interference wasn’t as bad as the master bedroom, but was still in the orange. So I decided to move it further from the router and other equipment in that room. As I unplugged it I noticed my speakers coming back online without it, so I’m guessing something in the network config steps changed and it never told me to unplug it when I actually could have. So I let the speakers all come back online and checked the network matrix again. Wouldn’t you know my OFDM ANI interference level for my master bedroom was now back to 0 and green. My Playbar and Sub were orange (6) and yellow (4) respectively, which isn’t super surprising as one of the WiFi mesh points sits between them about 2 ft from either one. The real head scratcher, though is that now my Guest Bathroom is red and reading 9. It’s a bathroom, so there is literally nothing else wireless in the room other than the speaker. 
 

Just for kicks, here’s the diagnostic after the Boost was removed: 254067969

Userlevel 2
Badge +2

I suspect it will be several days before @Corry P can respond. Most often, he doesn’t seem to work weekends, and of course next Monday is a holiday. Just to temper your expectations….

I somehow missed your reply on here. I wasn’t expecting anything quick given the timing of my last diagnostic, but thank you for chiming in either way!

Just didn’t want you to fret. The forum moderators seem to be excellent folks, but they’re neither 24 nor 7, and with the holiday, even more so ;)

Userlevel 7
Badge +18

Hi @BrentD 

OFDM ANI in Network Matrix indicates the 5GHz interference levels - as you were on 2.4GHz SonosNet, this interference probably wasn’t the interference causing the problems, but the baby monitor might have been (the change wouldn’t have shown in the OFDM ANI readings). On your latest diagnostics, all speakers other than Playbar are using 5GHz, so those readings in Network Matrix are now relevant. Playbar will only ever connect to 2.4GHz.

I recommend you relocate the WiFi access point to another location in the same room, away from other devices - not only will this improve things for those devices, but anything trying to connect to that AP too. The only playback error I see in the diagnostics now was on the Playbar, and moving the AP should fix that.

The Guest Bathroom is a bit of a puzzle. Is the speaker very close to a glass/metal/tile surface? If so, it may be interfering with itself, if you’ll excuse the expression - radio reflecting off the surface back at the speaker would be interpreted (and act) as interference.

I also noticed that every speaker can “see” 4 access points with sufficient signal strength to connect to any one of them - it may just be that you have one or two more access points than you really need, and this may be costing you reliable connections. Conceivably, not definitely.

The one thing missing from your last post is a report of things are now behaving, which is the important thing. Has it been an improvement?

I hope this helps.

 

Userlevel 2
Badge +2

@Corry P 

Not long after posting the edit to my last comments I watched the guest bathroom speaker interference drop to 0 as I refreshed the matrix several times. The interference at the sub also dropped to 0. The Playbar has remained orange at 6, which seems odd given its proximity to the sub that now has zero issues, but I suppose that’s due to the 2.4 vs 5 GHz you mentioned. I didn’t notice any issues yet, but I made these changes at 10pm last night and it is only now morning. Not sure where you are located, but I’m in the eastern time zone of the US. Had no issues with the rain storm sounds we play every night throughout the  night that I noticed. 
 

Here is a new diagnostic that is current. 1510097733
 

I do have 4 WiFi point in our single story home. One of them covers out doors that was added later, but the rest have been around since 2020, and the issues I had were new. If the Playbar gives me any more issues I may remove the one next to it and see how it affects our WiFi signal strength and speed. But for now with everything green other than the Playbar (which is largely used just by optical connection), I don’t foresee much issue with how it is. 
 

My only concern now is that after switching to WiFi rather than SonosNet, the controller app takes significantly more time to populate all of my speakers when opening it. We largely use our phones to control content on our TVs, so when changing to another provider or piece of content where the volume is drastically different, it makes scrambling to turn it down take a good bit longer. 

Userlevel 7
Badge +18

Hi @BrentD 

I see a bit of interference on the solo speakers (except Play:3), but if there are no audible interruptions, this doesn’t concern me too much.

Playbar is still reporting transmission issues to Sub which I don’t see for the rear surrounds. This may be due to interference near the Sub, or it may be because you’ve not been playing a surround sound feed and therefore the Playbar wasn’t attempting to transmit to them. If the Sub is in close proximity to the Playbar, I recommend relocating it - the speakers can interfere with each other, after all.

My only concern now is that after switching to WiFi rather than SonosNet, the controller app takes significantly more time to populate all of my speakers when opening it. We largely use our phones to control content on our TVs, so when changing to another provider or piece of content where the volume is drastically different, it makes scrambling to turn it down take a good bit longer. 

This comes as a surprise to me. Not only does 5GHz have more bandwidth, but that bandwidth increase comes with a decrease in latency. The Sonos app, if anything, should be more responsive with your system now on 5GHz. That you see the opposite may be due to failed packet transmissions being swapped between the various APs and the main Google hub, which I would not see in the diagnostics. Please ensure that each AP is well within the range of the hub, and that each AP and the hub are separate from possible sources of interference. Routers can typically have printers, smart-home hubs or cordless telephone base units near them, so if you have any of these near (within 1m of) your main router hub, I recommend you move them away.

I don’t know how (what method) you are controlling your TV with your phones, but if you use the TV’s app and remote, does it improve the Sonos app’s responsiveness any? If so, it may be a bandwidth issue - AirPlay, for example, requires your phone to fetch the feed over the network - unless it’s a local file on the phone - and retransmit it over the network to your TV, which means the local AP is handling 3 video feed “transmits”.

I hope this helps.

 

Userlevel 2
Badge +2

@Corry P 

I still had the rain sounds playing through the surround setup when I took the diagnostic this morning. I have the surround setup configured to play music equally through all the speakers in that setup. I’m not terribly concerned about that setup at this point since the majority of my connection issues seem to be solved now. 
 

The slow loading of the speakers in the app occurred in the far end of my home. Once in the living room in the center of the house the speed was much improved. So it may very well be an issue with the mesh WiFi system handoff from one AP hop to the next. 
 

When I referred to controlling content from our phones, I’m really only referring to using the phone as a remote for the AppleTV box or to control the TV’s native Roku functions. We rarely use physical remotes for anything (the AppleTV’s physical remote is set up to control volume on the Playbar via IR, but is rarely used). 
 

Anyway, I appreciate all the help working through this. Seems the root issue was using the Boost instead of WiFi, and the other issues I can work through with some wireless network optimization. Thanks again. 

Userlevel 7
Badge +18

Hi @BrentD 

I’m glad to hear there’s been significant improvement! And, you are most welcome!

Incidentally, now that the speakers have been scanning for WiFi (they don’t when on SonosNet), I can see that your APs are split between channels 1, 6 and 11. These are the channels you want to be using, but SonosNet was on channel 1, so it’s possible that the cause of the initial problems you reported were down to this sharing of channels. Should you ever decide to go back to using the Boost for whatever reason, I recommend that you move your Google mesh off of channel 1 beforehand. I think sticking with the current setup will be best though.

For now though, just enjoy some tunes! You’ve earned it!