Question

connection issue Sonos stop and play back again

  • 21 November 2022
  • 8 replies
  • 50 views

Hello,

i use sonos from almost 10 years and since a few weeks the music stops and plays again back after a few minutes after skipping a lot of songs. It stops again and plays again back….

Nothing were changed in my system : same router, no new speaker. It suddenly happens !

i only use Apple Music, internet radio and Spotify

Thank for your help and sorry for my bad English. I’m french speaking 


8 replies

Userlevel 7
Badge +18

Hi @VincentBxl 

Welcome to the Sonos Community!

Although nothing in your system has changed, it may be that a neighbour has changed their router or reconfigured their network in some way that results in interference with yours. Or, you may have added a (not necessarily WiFi-enabled) device somewhere near the router.

The best way to resolve this is to ask the speakers what they think. Please submit a support diagnostic and reply here with the number given and I’ll see what I can see.

Please note that the forum software may flag your post containing a diagnostic number as spam - it thinks the number is a telephone number. If this happens, don’t worry as I’ll see it and un-flag the post.

Thanks for your answer.

Here is the diagnostic number 526196688

Meanwhile I noticed that google assistant didn’t answer anymore on my Sonos One localised in the bed room.

I made a reset … and I listen to Sonos from 1h without any interruption !

I made the diagnostic after the reset

Is it possible the issue was this Sonos One ?

Thanks a lot

Userlevel 7
Badge +18

Hi @VincentBxl 

Thanks for the diagnostics.

I think part of the problem you’re having is due to your choice of Group Coordinator. The GC is the Sonos device that is placed in charge of a group - which is to say, it’s the room first selected when creating a group. As music must reach the GC and then be distributed to other rooms from there, the choice of which room to be in charge can be an important one.

However, in looking to find the best room to be in charge of the group, it seems all the speakers have a fairly high signal strength, while also having a fairly high transmission error rate. I think, therefore, that you must have a device situated near your router that is interfering with it. Please isolate your router from other devices by at least 1m.

If this doesn’t help, then I recommend trying another connection method. All you’ll need to do is re-enable the WiFi interface on your Beam (Settings » System » Salon TV » Beam » Enable WiFi) and wait about 1 minute. Because the Beam has an ethernet connection, it will then transmit a private WiFi for your other Sonos devices to use. They’ll prefer to use it over your WiFi and jump over to the newly available connection type. As long as the router and the Beam are not too close, it should be fine. With the Beam’s WiFi radio re-enabled, you’ll also have the option of bonding your 2x SLs as surrounds for your Beam, should you wish.

Setting up surround sound with Sonos home theater speakers

Note that with the Beam hard-wired and with it’s radio now on, it will be the best room to put in charge of a group.

I cannot say anything about the state of a speaker prior to a reset, after the reset. I think it more likely that the GC happened to change when you reset that speaker. We do not recommend you ever reset a speaker without being advised to by us, unless selling it. A reboot should have sufficed.

I hope this helps.

 

Hi Corry P,

I learned a lot of things (GC, reset play one) ! Thanks for that.

 I have 3 devices close my routeur :

  • Sonos Beam (wired)
  • Network Disk (WD)
  • Bridge for the connected lights 

I will move the router first. If it doesn’t work I will re-enable the wifi interface on the Beam

BR

If the Beam is wired, you really should turn on the Wi-Fi on it, otherwise it can’t serve as a hub for a SonosNet signal, or talk to any surround speakers you have.

Userlevel 7
Badge +18

Hi @VincentBxl 

As the Beam had it’s WiFi disabled, it wasn’t responsible for interference. I presume your WD NAS is ethernet-wired, so that leaves the lights’ bridge as the most likely culprit, though I don’t imagine it broadcasts a lot of data and the failure rate did seem consistent.

Another possible source of interference is metal or glass surfaces in close proximity - radio waves can reflect back at the broadcasting device and interfere. Please also be aware of devices that might be on the other side of a wall, including those belonging to a neighbour.

I hope this helps.

Hi,

Thank you both for your advice, Ì will follow them.

First of all I turned my brain on wifi enabled, because my NAS is wired, my lights bridge is wired too and I have no neighbours ! 

Have a nice week-end

Vincent

 

Userlevel 7
Badge +18

Hi @VincentBxl 

Although your light’s bridge is wired, it probably transmits on 2.4GHz and should therefore be at least 1m from your router.

I hope this helps.

Reply