Answered

Audio drops for Home Theater + multiple Play1s setup

  • 26 January 2023
  • 9 replies
  • 137 views

I just had long talk with Nick in support. I have TV connected to Playbar and a home theater group (subwoofer + L & R Play1s). Playbar has ethernet. I also have multiple Play1s around the house. I group them all to playbar to hear TV (via audio Optical into playbar). None of the Play1s have ethernet and all are on the same network (via Eero mesh). 

 

Problem is with TV playing or anything coming in via playbar’s optical audio (Roku, via TV, etc.) sound often drops (interruption) sporadically from the separate playbars. Not all speakers at once. One speaker drops, now then another speaker drops after but prior is back, etc. So, I can’t hear the TV sound (news) consistently if I leave the living room! Isn’t music (sound) throughout the house Sonos’ concept!?!!

 

It does NOT seem to be a problem if I’m streaming music through the soundbar from Spotify, etc. Soundbar/theater and all Play1s have audio dependably. Perhaps this issue is limited to audio signals passing into the Soundbar from external (TV). I’ve changed the audio cable 3 times so it’s not the cable.

 

According to Nick at Sonos, this problem is a design flaw/bug. He explained that sound comes into bar from TV, goes to the Theater group, back to the bar, then out to the closest Play 1, and then to next Play 1, and next, etc. The other Play1s not in the home theater are “not a priority” for the Playbar, so this causes a sound buffer/gap/break. Also, for a workaround, there’s no way for me to play TV through playbar AND also select TV sound through any/all other Play1s.

 

Nick had one suggestion, and he admitted this will only REDUCE the drops and NOT eliminate them. He said to wiring the playbar nearest the soundbar, and then wire another one in the next 5 playbars down the chain. So that’s not a fix AND requires me to wire multiple Play1s. A year ago I tried wiring one further in chain (downstream, more distant from Playbar) and it didn’t make sound more reliable for TV.

Though glad to finally get the true story from Sonos, tech, I’m very unhappy about this unadvertised design limitation.

So, does anyone have any other suggestions on how to fix this -OR- that can vouch for me doing the wiring work to get some Play1s connected (before I spend all that time and don’t see much improvement)???

icon

Best answer by Ken_Griffiths 27 January 2023, 18:56

View original

9 replies

@PaulZak 

indudnt notice you mention it, so just to clarify, have you set the Playbars ‘Group Audio Delay’ feature to its max 2 second audio buffer, to see if that might help to resolve your issue?

Also, is the Playbar wired to the Primary eero Hub (thats assuming you are using the mesh setup in router mode and that any other router is ‘bridged’ with its WiFi adapters disabled). Your exact network setup is not clear from your initial post.

Is the Playbar your only wired Sonos device? If it is, have you considered wiring a different (standalone) Sonos device to the router Hub as the root-bridge for the Sonos setup instead, or aswell as? Note any wired device must be positioned at least one metre away from your primary eero router and you must not wire any Sonos products to the eero satellites - all wired devices should be linked back direct to the router, or to a ‘switch’ connected directly to the router/primary hub.

I’m not familiar with the eero mesh settings, but if it’s possible, set the hubs to each use the same fixed non-overlapping 2.4Ghz channel 1, 6 or 11 and set the channel-width to 20Mhz only and set the SonosNet channel in the Sonos App so that it is at least 5 channels away from that eero channel, or at least set SonosNet to a channel not in use by the eero hubs (if practicable).

I would also reserve all the Sonos IP addresses in the DHCP reservation table.

Then see if those things improve the connectivity for the Sonos grouped room configuration and TV audio playback.

Ken, thanks for the reply.

Here are some answers:

  1. Setting Playbars ‘Group Audio Delay’ feature to its max 2 second audio buffer: I tried this and as setting’s description implies, the sound from Play1 was then out of sync (delayed) with Playbar/home theater… and still skipped. The issue isn’t syncing sound, it’s drop outs. So no success there.
  2. Playbar wired to the Primary Eero Hub: Yes, it is into the Eero base station. And, all Sonos devices also show wifi into same Eero base (I guess via connection to soundbar). 
  3. Is the Playbar your only wired Sonos device? Currently, yes only Playbar is wired/ethernet. No Sonos products are wired to the Eero satellites
  4. Set the hubs to each use the same fixed non-overlapping 2.4Ghz channel 1, 6 or 11 and set the channel-width to 20Mhz only and set the SonosNet channel in the Sonos App so that it is at least 5 channels away from that Eero channel: Eero does not allow me to set a particular channel for its mesh. I’ve tried changing the SonosNet channel but this didn’t help.
  5. Reserve all the Sonos IP addresses in the DHCP reservation table: I’ll have to look into this. I’m not a network guru so may need to research how to do this with my network.

It seems odd that the Sonos tech was clear that my setup isn’t handled well by Sonos. I would expect fairly commons that someone has the home theater setup in one room and also a separate Play1 in the adjacent kitchen to hear the TV news playing while making a meal. 

Remember, there is no drop issue when streaming MUSIC directly from Sonos (via app and Soundbar’s ethernet connection). The problem only exists with any sound coming into the Soundbar via the optical audio cable, such as TV or Roku. And I’ve tried several cables to rule out the cable, kinks, etc. So I believe the Sonos tech that it’s a Sonos design issue; it cannot distribute audio well coming into the Soundbar out to home theater setup + multiple Play1s. At the Sonos price point, it should do that successfully.

All, 

I’ll add that when I first bought the system years ago and talked to Sonos about the sound dropping, they said sound into the soundbar needs from our Verizon STB must be set as L-PCM (vs. Dolby) and the problem is with Verizon's coding of Dolby 3.1 sound signals, which don't meet industry standard or some such issue. Thus Sonos cannot process then audio signals smoothly, hence the drops. But I changed the STB settings and drops continued.

Recently, we replaced our TV, we canceled Verizon and use HD TV (over the air) but the problem remains. In both the original and current setups, audio comes from the TV into the Soundbar. So that’s why I feel confident the problem is within the Soundbar’s tech and thus it’s a failure by Sonos and this product.

@PaulZak,
I’m really surprised the 2 second ‘Group Audio Delay’ buffer doesn’t work and causes dropouts, but yes the speakers will play out of sync, but that usually is not an issue if the ‘grouped’ speakers are located in other rooms - but dropouts with that buffer size is quite unusual and ‘for me’ that would point to a network interference issue, hence my suggestion to use a 20Mhz channel-width for the eero 2.4Ghz WiFi band and a SonosNet channel that is not in use by any of the eero hubs. 

Another route you could consider going down, is to reinstate the main router (usually that’s a device provided by the ISP) and ‘bridge’ the eero hubs instead of the router, so that they all run in wireless access point (AP) mode - which might allow you to then fix their channels - but see the eero user manual to see if that’s a possibility. It can sometimes work better than having the mesh system operating as the main router in some cases but you will likely find some eero features are then set aside. 

I sometimes use this mode with my own WiFi mesh setup (Plume WiFi 6 hubs) and it works well in my case - I don’t have any issues playing TV audio to a good many Sonos Rooms even with a smaller audio buffer of 75ms but I run my setup on WiFi rather than SonosNet in that case. 

I certainly wouldn’t give up here, as perhaps one of the network configurations may just sort your issue once and for all.

All, 

I’ll add that when I first bought the system years ago and talked to Sonos about the sound dropping, they said sound into the soundbar needs from our Verizon STB must be set as L-PCM (vs. Dolby) and the problem is with Verizon's coding of Dolby 3.1 sound signals, which don't meet industry standard or some such issue. Thus Sonos cannot process then audio signals smoothly, hence the drops. But I changed the STB settings and drops continued.

Recently, we replaced our TV, we canceled Verizon and use HD TV (over the air) but the problem remains. In both the original and current setups, audio comes from the TV into the Soundbar. So that’s why I feel confident the problem is within the Soundbar’s tech and thus it’s a failure by Sonos and this product.

Some issues may arise with Mc LPCM audio compared to Dolby Digital as the former is an uncompressed codec and requires HDMI eARC support to the soundbar compared to most compressed Dolby formats (apart from Dolby TrueHD/MAT) which are compressed and will happily work over Optical and HDMI-ARC, but the best TV audio format to use will be the default stereo PCM - so you can always try that. Grouped rooms usually play the audio in 2 channel stereo anyway so it’s not like you will notice any difference from the grouped rooms.

Just to also say TV audio is often more demanding than music audio across a wired/wireless network anyway - over a 2.4Ghz WiFi connection there will be a 75ms (minimum) audio delay to the Sonos ‘grouped’ rooms - for HT audio buffering.

There is another feature in the Sonos App aswell, that’s called ‘TV Dialog Sync’ which is in the HT room settings and it is a slider-control to also buffer the TV audio and delay the output on the HT room, which ‘may’ help to sync the playing HT audio to the (delayed) group rooms - so that’s worth considering here too… but note whilst this may result in all audio across the entire group to play in sync, you may likely encounter a lip-sync issue with the video on the TV screen (which usually does not matter if  you are listening to the audio in a different physical room, or viewing from a distance) - but you can perhaps consider that as a further option to buffer the audio too and it ‘may’ help to reduce the audio dropouts across the players.

Ken:

With your multiple Play1s working well, do you ALSO have the home theater grouping as I do, built from the Sonos Soundbar and grouped to the multiple Play1s? AND, are your playing audio through optical input (not audio from Sonos app directly, like via Spotify)?

Also…

I get your point about the delay not being a problem if other Play1s are in other rooms away from home theater. We have a fairly open floor plan here so I can still hear several of those other speakers while in sitting front of the tv... so an audio delay won’t work for me.

I’ll look into reconfiguring & reinstating the main router. Currently, we have one from Verizon. Its Wifi is completely disabled, and it connects only into the Eero base via ethernet. So everything (devices) should be on the same wifi network. I may call Eero support to chat about this. They have been helpful in the past.

Lastly, today I uncoupled the home theater using the Sonos app. Now the Playbar does not have 2 adjacent Play1s nested. Afterwards, the other separate Play1s throughout the house don’t seem to be dropping audio. This confirms what Nick at Sonos confessed… it’s a Sonos’ design limitation when having both:

(a) Home Theater (HT) setup, and

(b) multiple additional speakers included in the HT group

(c) and, when playing audio into playbar via optical audio in. 

 

@PaulZak,
Admittedly I’m not using the older Playbar and now have an Arc HT in the Living room, a Beam (gen2) HT in the Dining room and a Ray HT setup in the Kitchen/Diner - so it’s difficult to compare like-for like here, but I have Ones and Fives in most rooms around the Home and they all play nicely, even when playing TV audio from the smaller Ray which uses an optical connection. I’m not referring to music audio, just to clarify that point here too.

I haven’t found that I have needed to delay the audio for the playing grouped TV audio, so all HT’s are currently set at their default 75ms ‘Group Audio Delay’ (GAD), but a full 2 second buffer, I would have thought should sort things for most network issues, bearing in mind that a Sonos system is able to support up-to 32 Sonos devices in ideal network conditions.

However, an audio delay of 75ms, or more, to the entire playing Sonos group is inevitable and as mentioned it can be increased to as much as 2 seconds - I don’t see any way around that, although using the ‘TV Dialog Sync’ slider too can improve audio sync, but that can/will introduce lip-sync issues with the TV video seen on screen.

The default TV PCM stereo is perhaps the best codec to use for such group TV audio playback too rather than one of the surround sound codecs (ie DD 5.1 or DTS 5.1)

I was just a little surprised that you still experience ‘dropouts’ with a 2 second GAD buffer, which (for me) would make me wonder if there was perhaps a network issue that was causing some of the problems, rather than it being a Sonos limitation. So that’s what I was trying to highlight in my posts earlier.

I have not ever personally expected the ‘more demanding’ TV audio to play to multiple Sonos rooms without some buffering delay, but (also personally speaking) I would expect a 2 second GAD audio buffer to work in many/most cases, that’s if the local wired/wireless network was in a reasonably good state and not encountering any form of significant interference.

Ken,

I think things are working better now and I’m very grateful for you time and guidance on this!

 As mentioned above, Sonos originally focused on changing our old STB’s audio codec setting, which didn’t fix things back then. Now, w/o the STB (we’re getting OTA TV signals now), I realized that we also changed TVs (now an LG, had a Sony) so I needed to double check the audio out format on the TV.

After digging a bit in LG’s menu, I found the “Digital Signal Out” set to “Auto” so I switched it to PCM as you requested (The third choice was “Pass Through”). I then re-established the HT (Bar, subwoofer, and 2 Play1s) using the Sonos app. Now, after a very brief test period, the farther Play1s, grouped to HT, are not dropping audio. But I’ll be more confident in a few weeks or months.

 

I was reluctant to change the network config because there were no (or very few) audio drops through all my speakers when streaming music via Ethernet into the soundbar. But as you explained, TV audio is more dense (“demanding”) than internet music.

Fingers crossed.

If this works, I’ll be a Sonos fan once again.

 

 

Reply