Answered

Arc - pop then no sound on Atmos

  • 12 November 2022
  • 3 replies
  • 444 views

Really frustrating issue. Set up is Apple TV 4K to Sony Bravia TV, with eARC to Sonos arc. Every time I listen to something with Dolby Atmos, ~30s in there’s a loud pop and then no audio until I reboot everything. Anyone else with a similar setup and no issues want to share their settings?
 

Based on how long this issue goes back it seems like something Sonos would really want to fix. I’ve had multiple couples/friends that were about to pull the trigger and buy a Sonos system after seeing how well it plays music throughout the house that ultimately decided to go with something else after sitting through a movie cycle of start movie with atmos, get 30s in, startling pop, then no audio, turn off and repeat x3, give up and watch something else. 

icon

Best answer by JeroenVR 12 November 2022, 21:41

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 4
Badge +5

I got a Bravia TV, Apple TV 4K 2nd gen and an Arc with no issues at all. 
 

Settings on the ATV in sound are “change structure: Off” and “Dolby Atmos:On”

Settings on Bravia TV are “A/V sync: On”, “eARC-modus:Auto”, “Digital Audio-output::Auto 1”, “Dolby digital plus-output: Dolby Digital Plus” and “pass trough: Auto”.

 

Did you also try a reboot for the TV? Hold down power button on the tv remote until a pop-up comes, where you can select reboot.
Reboot ATV: Hold down the “arrow left” + “home button” on ATV remote. Those are the 2 buttons next to each other under the cursor control. 
 

If that doesn’t help, generate a diagnostic code within 15 minutes when the error occurred, write it down and call Sonos support. 

Hope this information can help you solve the problem 🤞

Userlevel 6
Badge +5

This is a long-running, unresolved, well-documented issue. Come join us in the main thread dedicated to this problem!

 

 

Userlevel 2
Badge

Please go to the post “Sonos Arc loud pop then audio loss” and add you story/experince there. So we have everything at one place. Sonos needs to fix this.,