HomeKit & Sonos One - unable to add


Hi all,

I just bought Sonos One and it works perfectly. Did add Apple Music service, works with Air Play, ... So far, so good.

Then I tried to add it to my Home via ...

  • Add Accessory
  • Don't Have a Code or Can't Scan?

... but my device didn't appear there even after couple of minutes.

I was searching this forum and I've found that I have to disable Group Non-AirPlay Speakers. The problem is that this option is there (control app), but it's greyed out (can't disable it). Trying to disable it in the Settings - AirPlay.



Sonos Control app version 9.2 (build 46357271), Sonos One speaker 9.2 (build 46357250), iOS 12.1.

How can I disable the Group Non-AirPlay Speakers to make it working with HomeKit?

Thanks,
Robert

P.S. I tried to disable Home in iOS, reboot Sonos One, etc. Nothing helps. This is the only thing that doesn't work for me. Rest works like a charm.

11 replies

Userlevel 7
Badge +3
Firstly, I don’t think the 'Group non-Airplay Speakers' is going to be the answer here, but if you want to try it, then goto the Sonos App Settings/Airplay and toggle off the switch there.

If it doesn’t work, then post back here with an update.
Ken_Griffiths wrote:

Firstly, I don’t think the 'Group non-Airplay Speakers' is going to be the answer here, but if you want to try it, then goto the Sonos App Settings/Airplay and toggle off the switch there.

If it doesn’t work, then post back here with an update.



As stated in the initial post (and visible in the attached image), this toggle button is greyed out = control disabled = can't do this.
Zrzka wrote:

As stated in the initial post (and visible in the attached image), this toggle button is greyed out = control disabled = can't do this.


Could you post a screenshot of "About my Sonos System"?
Sure thing. Attached.
Sure thing. Attached.
Sorry for the double post. Page said I have to post it again, because it failed. Seems it didn't.
'Group non-Airplay Speakers' is grayed out because the ONE is your only Sonos speaker.

Could you also post screenshots from the Home app?
Userlevel 7
Badge +3
Sorry I missed the fact the OP's screenshot was from their own system, I assumed it was copied from another thread.

A few things to add ..

1. It is best to have the mobile device in use on the 2,4ghz band. It’s also helpful to stand nearby the actual speaker being registered as an accessory.
2. It is sometimes useful to reboot both the router and speaker.
3. The device being used for registering the HomeKit accessory should be the one that was actuallly used to setup the Home itself.
4. The AirPlay Speakers should be authorised to play on the local network in the Settings of the HomeKit App, accessible from the icon top left corner of the main Homepage.
5. You cannot register a Sonos Speaker that has already been registered in another HomeKit Home, without factory resetting that speaker or removing it from the previous Home (A reset is currently the only option, if the previous Home has been deleted).
Ken_Griffiths wrote:

3. The device being used for registering the HomeKit accessory should be the one that was actuallly used to setup the Home itself.



Wow, I’m sure glad I still have my old iPhone 6 so I could add my 5.1 Beam setup to HomeKit!!
I read other articles that stated you had to sign in with the same account that made the home, but this was the first that stated it had to be the literal same device. Thanks Ken_Griffiths!

So does this mean I can never get rid of this iPhone 6 if I want to add future Sonos speakers to my HomeKit setup?! Hmm...
Userlevel 7
Badge +3
whistlingfool,

Yes you must keep it forever ! .. ha ha
Only joking, you can always remove the speaker and then delete/demolish your Home and create it again on another device, but I suspect that Apple will have resolved this issue by then in some future update, fingers-x'd.
Badge +1
Hi, just figured to throw in my two cents since I bought a One and had the exact same issue you're describing. I don't know if you've done this already, but all I needed to do was to reboot my phone. Home was able to detect the One after that.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings