Apple homekit! Couldn't add Accessory

  • 9 November 2019
  • 8 replies



I am unable to add 2 x Sonos one to Apple Home,


I get the following error:

Couldn’t add Accessory

Home couldn’t connect to this accessory


I have tried the following, deleted the home app, started a new home, uninstall the sonos controller from my iphone, restarted the sonos one multiple times. Wifi signal is excellent, I have unifi wifi network, tried asus router, nothing has worked.


I can see both speakers show up under the home app but they error out when I select to add them.


I can play on both speakers using airplay from music app but unable to add them to the homekit.



This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Best answer by trf688

Ok so I’ve solved it by simply resetting my Sonos One to factory default and reinstalling it onto my system. This was done by unplugging the device, holding down the connect button and plugging it back in whilst still depressed. Hold until flashes orange/white and then reinstall as usual through Sonos app. Took about 3 minutes. It now appears on the Apple HomeKit App, AirPlay 2 and on Sonos meaning I can speak to Siri and Alexa or use Airplay flawlessly. Happy days 😃

View original


Now I have another issue, when using Siri on the phone to play music on the Sonos one, the music starts but I receive the following message on the phone screen.


“Controls unavailable for this device”

so I am unable to use the the 

Previous --- Play/pause -- Forward buttons


Userlevel 2

I have the exact same issue - “Controls unavailable for this device”

I have the same issue: “Controls unavailable for this device”. How to solve this?

Same issue “Controls unavailable for this device”.

Having the same issue.  Sonos One (Gen 2) all set up and working fine in that I can group it, play music to it via the Sonos app, and send music to it via AirPlay 2 from my iPhone.  When I go to the Home app though, the controls for the speaker are greyed out.


After a bit of messing around, it seems the controls are enabled only once an AirPlay 2 source is directed to the speaker.  It still seems a bit odd as, if I ask Siri to start playing some music, the controls pad that appears still says “controls unavailable for this device”, but if I now go to the Home app, the controls are enabled.

If I start music using the Sonos app, the controls remain unavailable in the Home app - I assume this is because Sonos is not using AirPlay, but it just comes across as really unintuitive.


Indeed it looks like using the Sonos app disables the controls in Apple Home Kit, and/or vice versa. However I noticed that I can still use Siri to play music on Sonos (even if it says controls unavailable in home kit).

I suspect this is because Siri is connecting a source to the speaker as part of the process.  

“Hey Siri, play Coldplay” will effectively AirPlay anything by Coldplay from your phone to the speaker.  Once this happens the controls will then be available in the Home app.