Answered

Sonos Roam - Can't connect to WIFI

  • 8 April 2024
  • 3 replies
  • 199 views

*** Update - its connected ***

 

Hello,

I have been experiencing continuous drop outs when trying to listen to my Sonos Roam. I read that I needed to connect to 2.4 instead of 5g. So I reset it while I temporarily disabled the 5g band.

How do I now reconnect it to my WIFI? I’ve reconnected my iPhone to WIFI so it's (presumably on 2.4). Opened the SONOS app which helpfully tells me that the roam is not found and to ensure it's connected to WIFI. But that is what I am trying to do.

How do I get the thing back onto my WIFI?

The LED on the Roam is flashing green.

icon

Best answer by Corry P 10 April 2024, 10:05

View original

3 replies

Userlevel 7
Badge +18

Hi @steveof2620 

Welcome to the Sonos Community!

Sorry to hear of the issues you’ve had with stable playback on your Roam.

While I am glad to hear that you got it connected to your WiFi once more, I feel I should caution you against factory resetting your Sonos speakers - changes to your network can be made without resetting, and are more likely to fix the issue than the reset itself.

Should this issue come back, I’d encourage you to get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

For what it’s worth, Roam would be perfectly happy on 5GHz WiFi, and the app may well be more responsive while on it. Audio interruptions are likely to be caused by interference or other network conditions, and our team can help identify these for you.

I hope this helps.

Thanks for that. Good to know it works on 5GHz WIFI. I am still experiencing drop out though. The WIFI signal strength at its location is excellent (full bars on the iPhone) and my other speakers… Apple HomePods are working just fine. The other issue I am having is that the battery runs down to zero periodically even though it is on a wireless charging pad (and it does the same when directly connected via a socket into the device). I have noticed that I need to disconnect the speaker from the charging device and re-connect to get it charging again. Hasn’t been working well for me at all unfortunately. 

Userlevel 7
Badge +18

Hi @steveof2620 

I’m sorry to hear that! Roam should definitely not be discharging while on a charger, though it does have minimum requirements for the charger - see our Power adapter requirements for charging Sonos Roam help page for details. If the charger does meet requirements, and for the playback issues you mentioned, I recommend you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports. 

Before getting in touch, if you can recreate all the issues and submit a support diagnostic prior to calling in, that will speed up the troubleshooting process quite a bit. Just relay the given number to the agent you speak to.

I hope this helps.

Reply