Answered

Move 2 grouping any better?

  • 31 October 2023
  • 12 replies
  • 395 views

Badge +2

Hello All,

I have an Arc/One SL/Sub surround sound in my living room, a One SL in the dining room, and a Move in the kitchen to cover my main floor. When I try to group the speakers on that floor with the surround sound being the source (connected to a Vizio TV with the actual source being an Apple TV), the dining room plays fine, but the Move in the kitchen is glitchy if it plays at all. It does get better if i change the delay on the surround, but then the dining room, which was playing fine before, is obviously out of sync with the living room, and I can’t just blast the music if the delay is increased. I did some reading in the forum and it sounds like the Move just isn’t built to handle grouping well. I was wondering if there was any improvement with the Move 2? I like the Move in the kitchen because I can grab it and take it to the deck outside the kitchen, but I’m still limited to starting music directly to it. Anybody know if grouping is better on a Move 2?

icon

Best answer by Ken_Griffiths 31 October 2023, 22:12

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

I would first try changing the WiFi band that your Move is using. So, just as an example, if the Move is using the 5Ghz WiFi band on your router, then switch it to use the 2.4Ghz band and set that band to a ‘fixed’ non-overlapping channel (1, 6 or 11) and set the channel-width to 20Mhz only and see if that improves things for you.

It sounds much more like you have been experiencing a network bandwidth/interference issue, rather than a problem with your Move (gen 1) speaker, which works fine grouped with our Arc Home Theatre and a few more Sonos rooms/speakers besides, in our Home, including Fives, Era 100s etc.

Badge +2

I would first try changing the WiFi band that your Move is using. So, just as an example, if the Move is using the 5Ghz WiFi band on your router, then switch it to use the 2.4Ghz band and set that band to a ‘fixed’ non-overlapping channel (1, 6 or 11) and set the channel-width to 20Mhz only and see if that improves things for you.

It sounds much more like you have been experiencing a network bandwidth/interference issue, rather than a problem with your Move (gen 1) speaker, which works fine grouped with our Arc Home Theatre and a few more Sonos rooms/speakers besides, in our Home, including Fives, Era 100s etc.

I was under the impression that One/One SL could only connect to 2.4GHz? I have an Arc, Sub (Gen 3), 5 One SL, a Move, and a Roam. Can I switch to the 5GHz network?

I should have also mentioned that a One SL in the same spot in the kitchen works fine, and give a little more detail on the network. I have a main wifi router and a second wifi router set up as an access point. Both have the same name for the networks, but different channels (for 2.4GHz, one is using Channel 1, the other Channel 11), and both are using 20MHz channel width.

I will look into if I can switch to 5GHz and report back.

Your Arc will need the 2.4Ghz WiFi or a wired connection, as it’s 5ghz adapter is used for the ad-hoc wireless signal between itself and the ‘bonded’ surrounds. Any speaker that can be used as a surround has a 5Ghz adapter, so that includes a One SL speaker. The Move/Roam can both use the 2.4Ghz or 5Ghz WiFi, but neither of those portable devices can be bonded as a surround, nor can they use SonosNet FYI.

I assume that your second router, acting as an access point, is wired directly back to your main router (hopefully) - I would certainly set its WiFi channels and band channel-width to exactly the same as your main router. All ‘ideally’ should match.

Badge +2

Your Arc will need the 2.4Ghz WiFi or a wired connection, as it’s 5ghz adapter is used for the ad-hoc wireless signal between itself and the ‘bonded’ surrounds. Any speaker that can be used as a surround has a 5Ghz adapter, so that includes a One SL speaker. The Move/Roam can both use the 2.4Ghz or 5Ghz WiFi, but neither of those portable devices can be bonded as a surround, nor can they use SonosNet FYI.

I assume that your second router, acting as an access point, is wired directly back to your main router (hopefully) - I would certainly set its WiFi channels and band channel-width to exactly the same as your main router. All ‘ideally’ should match.

I was under the impression that I didn’t want the channels from both routers to be the same (overlapping channel interference maybe?), but it was so long ago that I could have made that up. I’m running a couple routers with Advanced Tomato, and yes they are connected via wire. I’ll give it a try. I did try switching the Move to the 5GHz network but it kept failing. What are the recommended 5GHz settings?

I was under the impression that I didn’t want the channels from both routers to be the same (overlapping channel interference maybe?), but it was so long ago that I could have made that up. I’m running a couple routers with Advanced Tomato, and yes they are connected via wire. I’ll give it a try. I did try switching the Move to the 5GHz network but it kept failing. What are the recommended 5GHz settings?

As you are extending the same network subnet with an access point (hopefully wired directly back to your main router), you are best to keep all/both on the same WiFi channels and channel-widths.

The 5Ghz is faster. but less penetrating than the 2.4Ghz band, so if either of the two WiFi AP’s are situated in the same physical room as your ‘Move’ then the 5Ghz band should be fine to use, particularly with all operating on the same fixed channel, such as Ch36 or 48 or even use a DFS channel, with a channel-width of either 40MHz or 80Mhz - that should be fine. If either of the WiFi AP’s are not in the same room as the Move, then I would use the 2.4Ghz band instead.

Badge +2

I made the changes (both routers set to 2.4GHz on Ch 11 & 20MHz, and the 5GHz on Ch 48 & 80MHz) and that combined with the group audio delay set to medium has made it tolerable, but still not great. Setting the group audio delay to high was good but too much of a delay for my ears. I unfortunately still can’t set the non surround speakers to use the 5GHz network. I get a “There was a problem connecting your Sonos Move to <network>.” I copied the password out of the router config interface and pasted it into Sonos to be sure I did not mistype it. If I try a couple of times, it will claim to have succeeded, then the device will disappear from the list of devices for a while, then eventually reappear back on the 2.4GHz network. The 5GHz network does appear in my list of networks in the app now though. Any thoughts on why that might be happening? Not sure if this matters, but my network name for the 5GHz network has an underscore in it and the password is 20 chars with an exclamation point in it…

Yes, it might be the underscore, but I can’t be sure, but maybe consider removing it at a later point in time - I would think the Move is happy on your 2.4Ghz band perhaps because the 5Ghz signal is weak at its location. What is your Moves current SNR reading in its room settings… see these two support links (to assist):

https://support.sonos.com/en-us/article/improve-your-sonos-products-wifi-connection

https://support.sonos.com/en-us/article/understanding-the-network-details-section-in-the-sonos-app

You ideally need an SNR level of 45 or higher.🤞

Badge +2

Yes, it might be the underscore, but I can’t be sure, but maybe consider removing it at a later point in time - I would think the Move is happy on your 2.4Ghz band perhaps because the 5Ghz signal is weak at its location. What is your Moves current SNR reading in its room settings… see these two support links (to assist):

https://support.sonos.com/en-us/article/improve-your-sonos-products-wifi-connection

https://support.sonos.com/en-us/article/understanding-the-network-details-section-in-the-sonos-app

You ideally need an SNR level of 45 or higher.🤞

Move is reporting from 42 - 44 dB. I will try moving it closer to the router and see if there’s any difference.

Okay - the ‘Move’ I have here is using the 2.4Ghz band (channel 11) 20Mhz only. I’ve not got any issues with it and it’s SNR is 56dB just for your info - the Arc HT I often group it with, is on the same band/channel, but is a metre a away from a WiFi AP and has a SNR level of 90dB - I have the Group Audio Delay set to its default  Low (75ms) and I never see any huge delay and certainly no audio dropouts. 

If your issue persists, then one further suggestion is to blacklist your devices so they all use the same WiFi access point and see if that perhaps then improves things even further for you.

Badge +2

Thanks @Ken_Griffiths for your time and patience! I will probably post one more update after this, but I think I have some work to do on my end. I moved the Move to a spot in the kitchen where it is getting 50 dB or higher consistently. With the group audio delay set to medium still, it is much better than before, but still hiccups occasionally. What I noticed is that the video and audio on the Apple TV also hiccups, though not at the same time and [obviously] affects all the grouped speakers when it happens, whereas the Move hiccups just affect itself. Looking into the network overview on the two routers, the bandwidth rates for the wifi networks on my main router (which is the closest to the Move and the Apple TV) fluctuate wildly. The bandwidth rates on my access point (same hardware and third party OS) are near the maximums for the particular band and stay consistent. So I guess I have some interference near the main router and/or the router may be going bad. I’ll mess with that this weekend and see if I can figure that out. I’ll post again once I change the 5GHz network name and password to not have any special characters and see if that helps with connecting the non surround speakers to the 5GHz network. Thanks again!

Badge +2

The Sonos app in fact does not like that my 5GHz network has an underscore in the SSID. Removing the underscore allowed my devices to connect to that band. Seems like a programming oversight, but at least now I know. Is there a list of acceptable characters in an SSID for a Sonos device listed somewhere?

Now to tackle the issue with my main router. Thanks again @Ken_Griffiths!

I don’t know the answer to your question with regards to Sonos compatibility, but certainly looking briefly online, some special characters are excluded for SSID names (it seems to vary by router brand too). I can only guess that for Sonos devices, it includes the underscore (I guess), but maybe see if the Staff here, or someone else, may comment on the matter. I tend to use general alphanumeric characters personally, and so have not ever encountered the issue.