Answered

Wireless Range Extender message mesh network

  • 13 December 2020
  • 7 replies
  • 2172 views

Hi, I’m hoping someone can help me with my issue.

I have a Play 5, 2 One SLs, a Play 1, and a Move which were all working well with my Netgear Orbi Mesh network. Unfortunately, the Orbi died and I replaced it with an Asus Zen Wifi CT8 mesh router. I have the Play 5 directly wired to the router. Of course, the Move is connected via Wifi. All of the speakers appear in the app and function, but whenever I try to group the Move with another speaker, I get a pop-up saying:

“Wireless range extender. Some Sonos products are using the WiFi from a range extender device. If you include one of these in a room group, you won’t be able to play music in that group. To ensure playback in all grouped rooms, you’ll need to permanently wire a Sonos product to the router.”

Of course, I already have Sonos permanently connected to the router, and all of the speakers show WM:0 (except Move), indicating they’re using the SonosNet dedicated mesh system. I don’t have a range extender.

The Move will function fine if I use it on its own, but when I group it, I get the pop up and silence. I’ve tried changing the Sonos channel to ensure it doesn’t conflict with the 2.4 GHz router channel to no avail. I have factory reset the Move, unplugged the system from the wired network, and changed the location of the Move. Nothing has worked. Please help!

Thank you.

 

 

icon

Best answer by mvbrumm 1 January 2021, 05:55

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Hi mvbrumm

I’ve got exactly the same issue.  I have a range of Sonos devices running on SonosNet via a Boost unit (2x Play 5, Sub, 2x Play 3, Play 1 and Port). They all work fine and groups etc are all happy in this arrangement.
I swapped to an Asus ZenWifi AC3000 wireless mesh network with 1 main router and 3 node units (prioir to this I was using 5x BT homehub mesh network) a few months ago and it is since the swap that I get the wireless range extender message when my Sonos Move is also connected to the network (via wifi of course).

I did see a comment on a forum where it could be that the 2.4 wifi channel is fixed by the Asus due to the auto allocation when in smart connect mode (meaning the 2.4 and 5GHz channels are co-joined and not seperately visible).  I don’t want to have seperate channels if I can avoid it for simplicity for other users at home.

If swith the Move off the range extender message does not appear.  So it is clearly a clash related to wired/wireless and therefore most likely to be the channel issue - but I’ve not yet found a clear explanation or indeed solution to resolve.

I don’t have any other network issues and have eliminated any dual DNS issues by using a Vigor router in modem only bridge mode into the Asus router.

Hopefully someone here can provide some clarity and guidance on a solution.

Thanks

MM

It possibly depends on whether the WiFi mesh appears to be a series of discrete access points linked by a wireless backhaul, or as a number of extender/repeater nodes. There is a difference at a networking level.

In the former case each Sonos device should appear with its own MAC and IP addresses as usual. In the latter, the extender node’s MAC address could be showing with multiple IPs: its own and the wireless clients behind it.

Since Sonos can presumably detect the difference, and takes offence to extenders, it pops an error message. Sometimes if you press ahead the group play will work anyway.

Thanks for your reply. I’m glad I’m not alone with this problem. I thought that the Asus “Smart Connect” might be causing a problem, so I disabled it and separated the 2.4 and 5 GHz bands into different SSIDs. I connected the Move with the 2.4 band and the problem was fixed...for an hour or so. Then it was back to its usual antics. I don’t usually group the Move with other speakers, so it’s not a major problem, but it’s annoying and I wish I could find a solution.

 

Hi mvbrumm

I’ve got exactly the same issue.  I have a range of Sonos devices running on SonosNet via a Boost unit (2x Play 5, Sub, 2x Play 3, Play 1 and Port). They all work fine and groups etc are all happy in this arrangement.
I swapped to an Asus ZenWifi AC3000 wireless mesh network with 1 main router and 3 node units (prioir to this I was using 5x BT homehub mesh network) a few months ago and it is since the swap that I get the wireless range extender message when my Sonos Move is also connected to the network (via wifi of course).

I did see a comment on a forum where it could be that the 2.4 wifi channel is fixed by the Asus due to the auto allocation when in smart connect mode (meaning the 2.4 and 5GHz channels are co-joined and not seperately visible).  I don’t want to have seperate channels if I can avoid it for simplicity for other users at home.

If swith the Move off the range extender message does not appear.  So it is clearly a clash related to wired/wireless and therefore most likely to be the channel issue - but I’ve not yet found a clear explanation or indeed solution to resolve.

I don’t have any other network issues and have eliminated any dual DNS issues by using a Vigor router in modem only bridge mode into the Asus router.

Hopefully someone here can provide some clarity and guidance on a solution.

Thanks

MM

 

It possibly depends on whether the WiFi mesh appears to be a series of discrete access points linked by a wireless backhaul, or as a number of extender/repeater nodes. There is a difference at a networking level.

In the former case each Sonos device should appear with its own MAC and IP addresses as usual. In the latter, the extender node’s MAC address could be showing with multiple IPs: its own and the wireless clients behind it.

Since Sonos can presumably detect the difference, and takes offence to extenders, it pops an error message. Sometimes if you press ahead the group play will work anyway.

Thanks for the reply. All of the Sonos speakers are listed separately with their own MAC and IP addresses. All are listed as hard-wired except for the Move, so they are using SonosNet. Strangely, the Move is listed as connected to the 5 GHz WiFi band, which I thought it couldn’t do. It even appeared this way when I separated the 2.4 and 5 GHz and specifically connected it to the 2.4. I also brought the Move near the primary router (instead of the backhaul-connected satellite), and it didn’t make a difference. As you said, sometimes I dismiss the error message and the Move works anyway, but sometimes not. The Move always seems to work when it is ungrouped. 

Move is able to connect to 5GHz, so long as it’s configured with the correct details. If the WiFI mesh has the same SSID/password for both the 2.4 and 5GHz bands it’s quite conceivable that it might be able to steer the Move onto 5GHz.

Bringing the Move near to the primary node might not have any immediate effect, in terms of where it connects. There would be a minimum threshold for the signal from the original satellite before it would flip. You should be able to force a reconnection by rebooting the Move.

Userlevel 1

Just chiming in because I just got this message.  My setup involves a Netgear r7000 in wired mode and a Netgear Orbi AC3000 for wifi in AP mode.  No extender is being used.

I have a Beam directly connected to the router (r7000). This is noted in My System.  The rest of my Sonos products appear to be using SonosNet correctly.

Why am I seeing this warning?

I believe the issue is related to the Move connecting to the mesh satellite instead of the primary router. When I disabled the satellite and rebooted the Move, the message stopped appearing and the Move was able to be grouped normally. Of course, disabling the satellite defeats the purpose of having a mesh network for all of my other wireless devices, so it’s not a good long-term solution. Fortunately, as ratty mentioned above, the Move will often allow itself to be grouped after a couple tries even when the message pops up.