Trouble Setting up Roam with existing Sonos

  • 27 April 2021
  • 9 replies

Trying to set up my new Roam via my ipad mini. I only want to connect via bluetooth. During set up process I upgraded to Sonos S2 app. I connected to my internet service via theapp but it tells me the system includes products not compatible with Sonos S2. I suspect that is because I have a Bridge dircectly plugged into the router. When I go to Sonos 1 app the Roam is not showing. What do I do now? Thanks for your support. Steve Day


Best answer by Corry P 30 April 2021, 14:23

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Get rid of the Bridge.

Userlevel 7

The easy fix is to remove the Bridge and replace with a Sonos Boost Module or wire a Sonos component to your router. The Roam is not S1 compatible.

For the record using Bluetooth for streaming via a compatible device has nothing to do with the setup of your Sonos.  Bluetooth Low Energy (BLE) is used by Sonos for ease of setup but cannot be used for streaming.

If you have no intention of ever using Roam for anything other than a bluetooth speaker, then you could just leave your existing system on S1, setup the Roam on S2.  You would not be able to group speakers from S1 and S2 (your Roam), but if the Roam is always in bluetooth mode, it doesn’t really matter.

Thanks for your speedy reply melvimbe. The problem is the S2 would not let me proceed with the Roam set up while the bridge was there. I’ve now disconnected the bridge. The Roam is now on S2 and plays through the app. The problem I have now is that the Roam does not show up on devices available on bluetooth via my ipad mini when I get the pairing tone . I’ve tried switching off the wifi on the ipad but still no luck. Any ideas?

Did you put the Roam in Bluetooth pairing mode?  You need to press the power button on the back of the Roam until the light in the front turns blue.  It may then take a few seconds fro your ipad to see the Roam as available for pairing.

Hi Danny. You’re being very patient with me. Many thanks. I’ve tried pushing the power button at the back as you suggested. The red light appears briefly at the bottom, then the flashing white light at the top. Then a solid white light. Then nothing more. I’m holding for more than a few seconds but no blue light of any description. If I take my finger off and press and hold again it switches the speaker off. Very frustrating. The bluetooth feature was the main reason for my purchase.

Userlevel 7
Badge +18

Hi @Steve Day 

Welcome to the Sonos Community!

Are you still having this Bluetooth problem? If so, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to what’s happening on your Sonos system - plus, it helps to be able to hear the tones coming from the Roam. Bluetooth pairing starts on the third tone (the high-pitched one) you hear after holding the power button.

In addition, as you have a Play:1 and a Roam, there is no need for you to continue using the Bridge or S1 app - your Play:1 will work along with your Roam on S2. There are two options here. If you don’t have any My Sonos favourites or playlists created within the Sonos S1 app that you want preserved please follow these steps (anything in S2’s My Sonos section will be preserved):

  1. uninstall the S1 app from all controllers
  2. disconnect the Bridge from power and network
  3. factory reset your Play:1
  4. open the S2 app - once connected to the Roam it will automatically detect, within a minute or so, the reset Play:1 and start the process of adding it
  5. once the update has finished, you’ll now have an S2 system with both your Roam and Play:1 working together on your WiFi

If you wish you preserve the contents of My Sonos on S1, it’s a longer process:

  1. open S1 app and get connected to the Play:1 (if the Bridge has already been removed during the previous update attempt, you may need to connect the Play:1 to ethernet for now)
  2. select Settings » System » Network » Networks
  3. if your WiFi credentials are already stored, skip to step 6
  4. if your WiFi credentials are not stored, go back one page in the app
  5. select Wireless Setup and go through the steps on the screen. If successful, the app will tell you to remove the ethernet cable
  6. remove the Bridge from power and ethernet. It is no longer needed
  7. make sure you are still connected to the Play:1 in the S1 app - if not, try rebooting the speaker. If still not connected, connect the Play:1 to ethernet and continue. Once finished these steps, contact technical support
  8. open the S2 app 
  9. select Settings » App Settings » Reset App » Reset
  10. close the S2 app down but don’t re-open it yet
  11. factory reset the Roam
  12. open the S1 app again
  13. select Settings » System » System Tool » System Compatibility Check to start the process up updating the Play:1 to S2
  14. the app may still mention that the Bridge is incompatible - if so, opt to remove the device
  15. the S2 app will be opened and you can now go ahead with the update
  16. when the update is complete, the S2 app will soon offer to add the Roam (make sure it is still on and flashing green)
  17. once the Roam is added, you’ll now have an S2 system with both your Roam and Play:1 working together on your WiFi

The important part to remember is that if you want to preserve playlists and favourites, do not factory reset the Play:1.

If the process doesn’t go well, it’s best to contact our technical support team so they can establish the exact state of your Sonos households before continuing and leading you though it.


Hi @Corry P 

Many thanks for your detailed and very clear instructions. You’re a star!

I’m happy to report that I have now got my S1 connected to the S2 app and playing perfectly.

Best wishes


Steve Day

Userlevel 7
Badge +18

Hi @Steve Day 

Thank God for that - I remember writing that reply and it took some thinking! :grinning:

Glad to hear it - enjoy!