Sonos speakers keeps disapearing

  • 22 September 2021
  • 13 replies


I have two Sonos One speakers, and a Sonos Beam. 

They all work wirelessly, and have been working for about one year with not a hickup. 

Now they periodically disapear, and cannot be controlled from AirPlay, and cannot be found in the app. Sometimes I can connect them again by power-cycling them. 

I read a few of the forum posts here, and they all mention IP address problems, so I pulled up the client list on my router, but all of them have seperate IPs, and no other connection to the router share the IP. 

I also read about switching from one Access Point to another Access Point, but they all go through the same AP. 

Factory reset did not work either. 

I am about to give up on ever using the speakers again, after several days of troubleshooting. And Yes. I have power cycled the router, switches and AP, as well as the speakers in the correct order. 



Any good ideas? 



This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

13 replies

Userlevel 7

What router are you using? Are you able to wire one of the speakers directly to the main router with an ethernet cable?

Hi! I am using a Ubiquity system, with a UI controller, and two APs, also from Ubiquity. 

I can temporarily wire one speaker, but would prefer not to keep it that way, if possible. 

I have this router:

And these APs:

Userlevel 7

Many UniFi/Ubiquity users have experienced problems with Sonos. If you can keep a speaker wired to the main router, I think it will be the best option. But here are a couple of threads that might be useful:

Thanks alot for your answer. 

I see that the combination of Sonos and Ubiquity is quite a challenge. I wish they would have put that on the box before a considerable investment. 

I am trying out some of the solutions already, but to no avail. The cabled approach seems to be the best option, at least in the short term, but to be honest, I would have to drill a hole in my ceiling, or completely reposition my speakers. 

Right now I am just amazed that a set of premium speakers does not play well with enterprise grade network equipment. This seems fixable from Sonos side, and not by hobyists having to develop a deeper understanding of network settings and RTSP settings deep into the advanced settings of a router. Tighten up, sonos. 

If wiring a speaker is not a long term solution, you could consider a Boost:

Hi Claus, Thank you for replying. I must say I am hesitant to purchase a network device from a company that cannot make three speakers talk to each other on a very large network providers hardware. 

The device looks sleek, though, but I would not trust it´s stability. 

I am just trying out the RSTP to RTP solution. Something I did not think I had to learn to run a consumer product.


Again, I appreciate the community trying to help! Thanks, all. 


I don’t recommend SONOS Factory Reset without further consult. As you have discovered, this does not cure fundamental network issues and the reset destroys diagnostic information. You can submit a diagnostic for SONOS Staff comment. Be sure to include the confirmation number.

Cloud key is a controller, not a router. 

If the ONE’s are bonded to BEAM as surrounds, they will use a private 5GHz connection to BEAM. Sometimes the bonded ONE’s will not be visible in the UBIQUITI controller because they will not be using the UBIQUITI network.

RSTP is the UBIQUITI default. If you are using UBIQUITI network switches and have more than one wired SONOS unit, then you need to set the UBIQUITY switch(s) to STP.

Has Cloud Key logged any events associated with the SONOS units?

I suggest that you reserve IP addresses for all resident devices. As a test, use the same 2.4GHz channel for your two AP’s.

Personally, I prefer using SonosNet, rather than WiFi. If you don’t want to wire any SONOS units, add a BOOST.

While I have not personally encountered any issues, I hear rumors about UBIQUITI Airtime Fairness issues and UBIQUITI is tweaking things. Make sure that you are using the latest UBIQUITI firmware. Some users prefer to disable Airtime Fairness.

Finally, check for new sources of interference on both 2.4 and 5GHz.


Hi Buzz, thanks for your reply. 

I have tinkered for days with settings. So far with no luck at all. Here is my current “progress”. ​​​​​​Sonos Beam and the two sonos speakers are all seperate, and not bonded. 

So I have: 

  1. Created a separate WIFI for SONOS only, using only the 2.4 GHZ band, and existing on only one AP that is closest to the three speakers
  2. Set the two switches to STP, and 4096 prioirity
  3. Updated all Ubiquity devices to latest firmware
  4. Factory reset all three Sonos devices
  5. Enabled IGMP

AND. That leaves me in another pickle. I can start the setup of the speakers from the app. My phone is connected to the new WIFI. After the chiming thing happens, I give the password to the new WIFI through the app, and the speakers do not connect to the WIFI. It just spins its little circle for a long time, and afterwards prompts me to finish the install in the “Systems” tab of the app. The systems tab cant find the speaker, and we are back full circle. 

The only way to break out of the circle is to factory reset and start over, but that is repeating the circle. 

All of my other devices connect, and can use, the new WIFI. 

I am leaning towards returning the speakers, as there is no explanation for the sudden failure of the speaker system. Nothing in my setup changed leading up to the failures that I control. (So no firmware updates to Ubiquity) 

I suspect that the Sonos speakers have firmware updated in the background, and that the update has effectively bricked the speakers. 

...And can I add that I have made several changes to my home network, which I have no real understanding of.

Since you have Factory Reset the SONOS units. I suggest that you wire one or both of the ONE’s to the network. Once all of the units are setup, we can start diagnosing the UBIQUITI WiFi setup.

Which router are you using?

Hi Buzz, 

I can confirm that the system works when one speaker is wired. 

I tried, after setting up the system, to go to “system->network->manage network” and add the WIFI network to the BEAM. It failed to connect to it. 

My router is this:

What info do you need? And how do I get it? 


Best settings would be:

Disable: Airtime Fairness

Disable: Multicast and Broadcast Filtering

Enable: IGMP Snooping

Enable: STP, not RSTP

Disable: Jumbo frames

Priority: 4096

Reserve IP addresses for all permanent network clients, especially the SONOS units.

Set both AP’s to the same 2.4GHz channel and 20MHz channel width. Don’t use “AUTO” WiFi channel selection, use only channel 1, 6, or 11.

There was a SONOS firmware update this week

In the UBIQUITI Community there are reports of unstable firmware issues, particularly for some of the switches. The general consensus is that v5.43.36 is the most stable. Other than the configuration settings above, I did not see any SONOS specific issues.

If you add a BOOST, SONOS will ignore the UBIQUITI WiFi. I recommend setting UBIQUITI and SONOS to different WiFi channels (1, 6, or 11). Your experience with a wired ONE shows that adding BOOST will stabilize the network.

Have you submitted a diagnostic to SONOS?