Answered

Sonos Roam not showing up on Sonos 2 App

  • 21 April 2021
  • 17 replies
  • 14726 views

Hello

My Sonos Play 5 device is already registered and shows up properly on the Sonos 2 App (iOS).

I recently picked up the Sonos Roam and had all sorts of issues with connecting to it via the App.  The NFC wasn’t working and it kept on getting stuck during adding it.

I finally did get the Sonos (iOS) app to connect and add Roam to my account.  However after Roam got added, now my Sonos 2 app doesn’t see the Play5 device.

My ipad can still control the Play5 device on the sonos app but can’t find the Roam device.

 

icon

Best answer by Ken_Griffiths 21 April 2021, 22:11

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

17 replies

I’m a little confused by what devices and apps you’re using.  By ‘Sonos 2’ app, do you mean ‘S2’ (the icon is just labeled Sonos)?  There is also a S1 app (icon is labeled Sonos S1.  Do you have both apps or just one?  

And it sounds like you’re using both an iphone and an ipad?

I’m a little confused by what devices and apps you’re using.  By ‘Sonos 2’ app, do you mean ‘S2’ (the icon is just labeled Sonos)?  There is also a S1 app (icon is labeled Sonos S1.  Do you have both apps or just one?  

And it sounds like you’re using both an iphone and an ipad?

I am using the S2 iOS app only, for both iPad and iPhone.

And you see the play:5 on one  device and the Roam on the other?  Do you have extenders or access points on your WiFi network?  Perhaps you setup the Roam under a brand new account, rather than your existing account?

 

 

And you see the play:5 on one  device and the Roam on the other?  Do you have extenders or access points on your WiFi network?  Perhaps you setup the Roam under a brand new account, rather than your existing account?

 

 

nope just 1 wifi network.  and after adding Roam it asked me to login to my Sonos account which i only have 1.  

I even went and reset my Roam device 2-3 times.  When i remove the Roam device, my Play5 device shows up on S2 app.  i rebooted my iphone and continue to see Play5 device on S2...i started the pairing with Roam...and once Roam gets added, the Play5 device is gone.

 

I cannot do the initial pairing to Roam from my iPad, as it says use mobile device to do it...so i have not tried pairing Roam with my iPad.  

The good thing is my wife’s iPhone which has S2 app too and uses the same login...has the Play5 device also but at least she can play music/podcast via Airplay to the Roam.  The S2 app on her device only shows Play5 device in System...it does not show the Roam device either.

Your play:5 is connected wirelessly, correct?  No wire connected to your router?  I bet if you wired it up temporarily, you would see both play:5 and Roam together.  Not a solution, I know, but might narrow down the problem a bit.

 

Your play:5 is connected wirelessly, correct?  No wire connected to your router?  I bet if you wired it up temporarily, you would see both play:5 and Roam together.  Not a solution, I know, but might narrow down the problem a bit.

 

yah the play5 is connected via wireless

Weird.

So I reset my Roam again.  This time on my wife’s iPhone via S2 app i did the initial Roam setup.  I made sure my Play5 device and login is connected and completed the Roam initial setup.  It said to power off Roam then turn it back on to complete.  

I did that, and bam now on my wife’s iPhone i see Roam on her S2 app.  However the Play5 device is gone.

On my iphone I see the play5 device but no Roam, and same for my iPad only see the play5 device, no roam.  Same logins as i only have one.

However i can airplay music from my device to Roam.

so now it’s -

S2 on wife’s iphone = Roam only

ipad and my iphone = Play5 device ONLY

It sounds as though you are creating two separate S2 Sonos Households under your account login. Perhaps try this...

Open the S2 App on your own device (iPad or iPhone) and ensure that you can see and play to your Play:5.

Factory reset the Roam (see steps below) and when the status light is flashing green goto "Settings/System/Add Product” in the App and follow the setup instructions.

Roam Factory Reset Process

  1. Unplug the power cable/remove from Qi charger and power off the device by holding down the rear power button for 5+ seconds. Then wait 15 seconds.
  2. Press and hold the Play/Pause button while reconnecting the power cable, or you can press the power button, ‘release’ and very quickly ‘hold’ the Play/Pause button.
  3. Continue holding the Play/Pause button until the status light flashes amber. (Let go button).
  4. The light will go onto change colour and flash green when the process is complete and the product is then ready to be set up.

It sounds as though you are creating two separate S2 Sonos Households under your account login. Perhaps try this...

Open the S2 App on your own device (iPad or iPhone) and ensure that you can see and play to your Play:5.

Factory reset the Roam (see steps below) and when the status light is flashing green goto "Settings/System/Add Product” in the App and follow the setup instructions.

Roam Factory Reset Process

  1. Unplug the power cable/remove from Qi charger and power off the device by holding down the rear power button for 5+ seconds. Then wait 15 seconds.
  2. Press and hold the Play/Pause button while reconnecting the power cable, or you can press the power button, ‘release’ and very quickly ‘hold’ the Play/Pause button.
  3. Continue holding the Play/Pause button until the status light flashes amber. (Let go button).
  4. The light will go onto change colour and flash green when the process is complete and the product is then ready to be set up.

thats exactly what i did and do not see the Roam device.

Do you perhaps have ‘Airtime Fairness’ enabled on your router, if so, then switch off that feature.

Two other things that may cause this issue is ‘AP isolation’ where the 5ghz band is isolated from the 2.4ghz band or vice-versa, or having two DHCP servers on the same network. So check the router for isolation and if unsure, simply try switching off the 5ghz radio, just as a test.

Do you perhaps have ‘Airtime Fairness’ enabled on your router, if so, then switch off that feature.

this was on and i turned it off!

 

I don’t have AP isolation on, i do have a Unifi AP unit and it looks like theres some articles regarding Unifi and Sonos.

I looked and i do see that Play5 device is connected via 2.4ghz and the Roam device is on 5GHZ.

 

I think i’m on the right track...let me see what i can find.  Thank you!!

Two other things that may cause this issue is ‘AP isolation’ where the 5ghz band is isolated from the 2.4ghz band or vice-versa, or having two DHCP servers on the same network. So check the router for isolation and if unsure, simply try switching off the 5ghz radio, just as a test.

Since it’s so easy to reset and setup the roam, i did it and viola! Roam now appears in S2 app with my Play5.

Thank you for your help!!

Two other things that may cause this issue is ‘AP isolation’ where the 5ghz band is isolated from the 2.4ghz band or vice-versa, or having two DHCP servers on the same network. So check the router for isolation and if unsure, simply try switching off the 5ghz radio, just as a test.

Since it’s so easy to reset and setup the roam, i did it and viola! Roam now appears in S2 app with my Play5.

Thank you for your help!!

Glad to hear you got it sorted. 👍

Hi, at risk of sounding a complete newb but having the same issue. How do I check my router for IP isolation??? Tried everything else a few times already.

Hi, at risk of sounding a complete newb but having the same issue. How do I check my router for IP isolation??? Tried everything else a few times already.

The settings vary by router make / model, so look through your router  configuration pages to see what settings are available/enabled that apply to your network setup.

If you search for your router model here, on YouTube video, or via a Google search, you perhaps may find information, that may assist too.