sonos roam - caravan wifi


Help. I have a Sonos Roam - works brilliantly at home on home wifi, and I can Bluetooth my tv in my caravan.

but I can’t get the roam to connect to my caravan WiFi - I have a tp link router in my caravan 

it would be preferable to use WiFi (connection, sync, quality)


Best answer by Ken_Griffiths 18 June 2022, 02:08

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Is it practicable to have your home WiFi and the caravan WiFi (routers) in close proximity to each other, so that the Roam and your mobile Sonos controller device can see/connect to either WiFi network?

If it is practicable to bring the two routers together, then start by first powering ‘off’ the caravan WiFi router.

Connect your mobile Sonos controller and the Roam to your Home WiFi network - now power on the caravan WiFi network nearby and let it connect to the internet and settle.

Now follow these instructions to add a ‘trusted’ WiFi Network to your Controller App/Sonos Roam…

Once you can see the caravan WiFi network availability in your mobile network settings, ensure that the mobile does not connect to the caravan WiFi network. It needs to remain connected the Home WiFi.

In the Sonos App goto ‘Settings/System/Network/Manage Networks’ and select ‘Update Networks’ …follow the instructions on screen to scan/find your current Sonos system.

After the scan, select the Roam you plan to use on the caravan WiFi from the resulting device list (swipe left/right to see each Sonos Room).. select the Roam and choose to add the trusted nearby WiFi network .. it will first find your Home WiFi network, but on the same screen (see screenshot) it will invite you to change the discovered WiFi network.. choose that option and go onto add the caravan WiFi network/credentials to your Sonos Roam… the network(s) you add will then appear in the Sonos App (see screenshot).

Once complete, power off your Roam and close the Sonos App.

To test the setup has worked correctly .. power off your Home WiFi, just as a temporary measure, power on your Sonos Roam and it should now auto-connect to your Caravan WiFi. 

Next connect your mobile to the caravan WiFi network and open the Sonos controller App and all being well, the App should see your Roam and you should be able to now control it on that new WiFi network.

Hope that works for you.


That’s fab - yes I can get them together