Roam Dead

  • 7 June 2023
  • 7 replies

Pre-ordered the Roam for what I now realize may have been an excessive price of $230. Now I can’t get the thing to turn on. No matter where I plug in the wireless charger, I get no light. If I plug USBC directly, I get an orange charging light, but I’m still not able to power on after several hours of charging. Do I have any claim to warranty or am I out of luck? Thanks all.


Best answer by Corry P 12 June 2023, 15:01

View original

7 replies

What did Sonos support say when you called them? What charger are you using when you plug in the USB C directly, is it the Sonos charger, or another? 

Try this reset:

After the unit has been charging for a while, remove from charger, press and hold the power button for 15 seconds. If your finger slips off the button, restart the interval. If the unit starts, I suggest that you continue charging to 100%. You can listen to music while you charge.

Note that this is not a Factory Reset. No settings will be lost.

@Airgetlam I have not yet called their support number. I had been using the wireless charging pad that came with the speaker. When plugging in via USBC, I’m using a big, fat Anker brick and a good Anker, braided cable.


@buzz Thanks for the suggestion. I tried it a couple of times, but no noticeable changes unfortunately. 

When having charging issues, I try to stay away from Qi charging. What power ratings (voltage and amperage) on that Anker brick? Physical size has little to due with capability. 

Up to 100W

Odd that they don’t quote amperage, but yea, I’d agree, that should be sufficient. 

For now, stay away from the Qi charging until you can get it figured out. And I’d recommend following the posts made by @buzz closely. 

Userlevel 7
Badge +18

Hi @Sneake 

Welcome to the Sonos Community!

If @buzz’s suggestion did not help, I recommend you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports - you may simply have a faulty Roam, in which case we will look into your replacement options.

I hope this helps.