Question

iTunes 12 playlists copied to NAS- playlists available but all tracks report "unable to play...the share does not exist"

  • 15 February 2020
  • 6 replies
  • 62 views

The problem I am having is very similar to a previous thread that is now closed (iTunes 12 playlists issue with NAS - playlists available but all tracks report 'Unable to play' 'cannot be found'). The solutions suggested in the closed thread did not solve my problem.

My iTunes (v. 12.9.5.5) library is hosted on my laptop that is running Mojave (v. 10.14.6). I copied the Music folder on my laptop to the NAS server (i.e. a perfect copy) then updated the music library in the Sonos app. I am able to play all the tracks in my Sonos music library so Sonos is able to locate the copied music folder. However, when I select a playlist from the “imported playlists” menu I get the message “unable to play ‘name of song’- the share ‘//ip address/public’ does not exist.” The “public” folder is at the root level of the server whereas the correct path for the playlist is “public/shared music/music/itunes.” This is the same path as on my laptop, and the playlist works fine when played from iTunes on my laptop.

Solutions I have tried without success:

  1. I regenerated the iTunes library.xml file in iTunes, confirmed that the new .xml file was copied to the correct folder on the server and reindexed in Sonos.
  2. Although a long shot, I moved the .xml file to the “public” folder then updated the music library in Sonos. As expected, I get the same message “… the share ‘//ip address/public’ does not exist.”
  3.  I pointed the music library in Sonos to index to “\\ip address\Public\Shared Music\Music\iTunes.” This is the actual folder in which the .xml file resides. Still no joy.
  4. I noticed that there was a “previous iTunes libraries” folder at the same level as the .xml file so I deleted this folder, regenerated the .xml file in iTunes and reindexed the music library. Not happening.
  5. I indexed to “\\192.168.5.3\Public\Shared Music\Music\iTunes’ then tried indexing to “\\192.168.5.3\Public\Shared Music\Music” and finally “\\192.168.5.3\Public\Shared Music.” No matter what the index destination, I am able to play all tracks in the music library but the playlists do not work (same error message as above).

Not sure where to go next….


6 replies

Does your NAS have SMB v1 turned on? In order for the Sonos to be able to ‘see’ it, it must be on. 

Thanks for the rapid reply!

I’m not sure where that setting is on the NAS (MyCloudEX2Ultra). However, I am able to mount the server on my desktop using smb and am able to play music stored on the NAS, so I assume SMB v1 is turned on.

Any other ideas?

Check the documentation for the NAS. Sonos uses a very old and archaic version of SMB, due to the Linux kernel they’re restricted on currently. Most devices these days use SMB v3 (or higher?) and SMB v1 is turned off by default. Your Mac being able to ‘see’ the share unfortunately doesn’t mean the app running on the speakers can. 

My SMB protocol was set to SMB3. I reset to SMB1, replaced the iTunes library.xml file on the server  and re-indexed. Unfortunately I still have the same problem

Interesting. I’m out of ideas as to why the Sonos system running on the speakers can’t see the NAS, unless there is some sort of VPN or firewall blocking access. At this point, I would recommend that you submit a system diagnostic within 10 minutes of experiencing this issue, and contact Sonos Support to discuss it.

I usually suggest the phone folks, they have more tools available, but are available Monday through Friday during business hours. Twitter support folks are available 24/7.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.  

It is a long time since I went near iTunes, but I seem to recall that it contained a ‘consolidate’ option to bring all music files into the iTunes library.  I am not aware that it does anything to playlists but it might do?

If you look in the xml using Notepad are there any clues as to the filepaths it is using?

(I have to admit that neither of these fits well with the error message you are getting, but you never know…..)

Finally, I note that the slashes in the filepath in my Sonos library are forward slashes, whereas yours are backslashes.  Again, if that were an issue I would expect it to affect playing your iTunes files, not just the playlists.  But maybe worth the 2 minutes it needs to test, just to eliminate it? 

 

 

 

 

 

Reply