Answered

Sub Gen 3 won't connect to ARC

  • 8 August 2021
  • 10 replies
  • 11406 views

I just got the ARC and Gen 3 Sub. The ARC is set up and working fine with my TV. The Sub will not connect to the ARC for the life of me. Using a hard wire connection is not an option. I specifically purchased these units because they can use a wireless setup. I was able to get the sub to connect to the ARC but only for a second. I don’t even know if any bass came out of the sub during that second. My wireless router is right on the other side of the wall from my living room, no more than 10 feet from the ARC and the Sub so signal strength is not an issue. Does anyone know how to make these two work together? Thank you.

icon

Best answer by Lude2Envy 9 August 2021, 07:44

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

The connection between the Arc and the Sub is not via the router - it’s an ad-hoc 5Ghz wireless connection between the two Sonos products, so my thoughts are to perhaps first try a reboot of the Arc and Sub, then try the ‘bonding’ process again after that.

Perhaps also see if this Sonos Support document assists:

https://support.sonos.com/s/article/4805

The connection between the Arc and the Sub is not via the router - it’s an ad-hoc 5Ghz wireless connection between the two Sonos products, so my thoughts are to perhaps first try a reboot of the Arc and Sub, then try the ‘bonding’ process again after that.

Perhaps also see if this Sonos Support document assists:

https://support.sonos.com/s/article/4805

 

Tried all of this already. I set up the ARC first and it connected to my 2.4GHz network, updated itself, and worked fine with my TV. I then went to add the Sub. It wanted to connect to the same 5GHz network that my phone is connected to. I tried connecting it to both the 5GHz network the first time and the 2.4GHz network that the ARC is connected to the second time. Neither worked.

Ah I see, I thought you had the Sub added to the Sonos App and was simply trying to ‘bond’ the devices together, but I see now that’s not the case and that you are having difficulty actually adding it to your Household.

I assume you only have the two Sonos products, is that correct?

Also what router (make/model) is it and are there any other wireless access points?

One further thing, what phone are you using and what version of the OS is in use on that controller device?

Ah I see, I thought you had the Sub added to the Sonos App and was simply trying to ‘bond’ the devices together, but I see now that’s not the case and that you are having difficulty actually adding it to your Household.

I assume you only have the two Sonos products, is that correct?

Also what router (make/model) is it and are there any other wireless access points?

 

I was trying to bond the devices together. They both seem to connect to Wifi but the sub won’t pair with the ARC. I have an ASUS RT-AC5300 router. No other access points. I was using my iPhone 11 but I switched to an iPad Mini 5 so I could put all 3 on my 2.4GHz network. I didn’t want my iPhone on the 2.4Ghz network just for these.

Goto the ASUS router configuration pages and look to see if either ‘Airtime Fairness’ or QOS are enabled and if so, switch off those features and perhaps try the Sub setup again. See if that resolves the matter.

Goto the ASUS router configuration pages and look to see if either ‘Airtime Fairness’ or QOS are enabled and if so, switch off those features and perhaps try the Sub setup again. See if that resolves the matter.


Just chatted with support for the past several hours and they were worthless. I turned QoS off on my router but it still isn’t working. I can see that the sub is connected to the wifi in the router’s clients list, but it’s not showing up in the app. When it does show up in the app it can’t connect to the ARC. The only way to get it working is to hardwire the sub to the router but like I said earlier, that’s not an option.

It’s not a particularly good idea to wire a slave device, like a Sub or a Surround anyway. 👍

I’m quite surprised switching off QOS didn’t resolve the matter - I’m just reading through some old threads here from last year and one post says this in relation to your router model:

"navigate to Wireless > Professional and disable the Airtime Fairness feature”.

Can you perhaps just ‘kindly’ double check that info/path in case you missed the Airtime Fairness setting, unless a firmware update has perhaps removed that feature.

edit: this is the thread:

https://nl.community.sonos.com/alles-over-sonos-229107/sonos-conflicting-with-new-asus-rt-ac5300-router-6738737

Thanks for your help Ken, but I took it back to the store and exchanged it for a new one. The new one is working fine.