Answered

Sounds dropouts and glitches on Beam gen2

  • 7 January 2023
  • 5 replies
  • 85 views

Badge

I have very recently added a Sonos Beam gen2 to my Sonos setup - I also have a Sub and two Ones which i’ve had for years and have been very happy with.

My problem is that the Beam keeps dropping / glitching audio whilst watching TV - it’s not a complete dropout, but very noticeable particularly on louder sections. It happens regularly every 5-10 minutes or so, but if I rewind what I’m watching it never happens at the same point in the program.

I was previously using a Sony Blu-ray/home cinema system with the same Panasonic TV and that never demonstrated this problem.

The other relevant info is that the Sonos will not work with the HDMI-ARC output on my TV - I’ve had to use the optical HDMI adaptor. (and I know the TV ARC output works as that’s how I’ve been using my Sony system for many years)

It happens regularly enough that I’m thinking of returning the Beam whilst in the returns window.

TV is Panasonic Viera 58DX750 

 

 

icon

Best answer by displayname 23 January 2023, 13:07

View original

5 replies

Userlevel 7
Badge +18

Hi @displayname 

Welcome to the Sonos Community!

Regarding the audio dropouts, I recommend you try rebooting your TV by unplugging it from power for at least a couple of minutes. However, if you opt to try HDMI again, you’ll do this soon anyway.

As for the HDMI-ARC issue, I suspect a HDMI-CEC conflict (Consumer Electronics Control). Please try disconnecting all HDMI devices from the TV and unplug the TV from power for 2 minutes. Turn on the TV, then in the Sonos app, go to Settings » System » [Room with Beam] » TV Setup. Only connect the Beam to the TV when the app instructs you to do so.

If this works, reconnect one device at a time to the TV, testing audio on the Beam each time. Once you find the conflicting device, see if you can disable any CEC options on it (Sony call this feature Bravia Sync) - they usually relate to volume, power and input switching. If there are no settings, a CEC-less adaptor may be needed on the device’s HDMI cable.

Each (major) TV manufacturer has their own version of CEC, and when you connect a device of the same brand as the TV, the CEC feature set is often an expanded one. I suspect the TV and Blu-Ray might be having a conversation that the Beam is not privy to, though the issue could be caused by another device entirely.

If you’re still using your Sony device for playing Blu-Rays, you may need to also somehow tell it that it is no longer the output audio device.

Finally, and probably worth checking first, is if you are not using the HDMI cable supplied with the Beam, please do so.

I hope this helps.

Badge

Tried all suggestions and no joy - Sonos will not connect to hdmi arc - only way if to use the optical which seems to still have the audio dropouts 

Userlevel 7
Badge +18

Hi @displayname 

I’m sorry to hear that.

I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports, and to go through some real-time troubleshooting.

Badge

Hi All - a quick update

This morning I managed to make it all work. :)

For the HDMI ARC I found a tip in another thread which seems to have made the difference

- having plugged everything in and on, then switch to AV2(ARC) on the Panasonic TV which displays some Sonos artwork from the Beam.

This seemed to kick the TV into recognising the Sonos so all works as expected!

 

For the optical dropout problems  - (I was using the Sonos optical -> HDMI adaptor before I got the ARC to work) when I was unplugging the optical connector from the back of the TV it I noticed it was a bit loose, turns out you can connect it so it seems to be working without pushing the plug in far enough, once I did that (I heard a “click”) then the sound dropouts stopped occurring.

 

So very happy with the system now 

 

thanks!

 

Userlevel 7
Badge +18

Hi @displayname 

Thanks for updating the thread, and I’m glad to hear you’ve got it fixed!

Reply