Answered

Sonos setup problem after router move


Userlevel 3
Badge +5

Hi.

I have recently had to move my router due to (minor) building work which is now complete.

 

The new router location is permanent.

 

As a result of this situation I can no longer listen to sound from my Sonos setup and have to rely on the TV speakers which, obviously, is inferior!

 

My Arc is connected to my network but the Arc, Sub and 2x One SL speakers are separated into 3 separate groups.

 

I have tried unplugging my Sonos products, waiting for a short time and plugging them all back in again and also searching for new products via Bluetooth but with no success.

 

This is what I see on the Sonos app:

 

 

Thanks in advance for any help 🍻 

icon

Best answer by MikeE67 24 November 2022, 15:34

View original

11 replies

Userlevel 3
Badge +5

By the way my Arc is connected via ethernet cable and all 4 Sonos products are listed under 'About My System'

 

 

 

 

Userlevel 7
Badge +20

Please select within the Sonos App>Settings>System and then select your Arc.

Does it show your other devices?  If Yes, please remove both your surrounds and Sub and re-add.  If No, then please select Add Sub and Surrounds.

Here’s my suggestion…

Firstly I would go into the Living Room ‘One SL’ speaker settings (Settings/System/Living Room) in the Sonos App and choose the option to remove the Sub from that speaker. (Listed last in your first-post screenshot)

I would also rename that speaker to help identify it a little better - Living Room-L or Living Room-R (as an example) depending on if it’s the left or right surround.

Rename the other One SL accordingly, in its ‘room’ settings too, just so you know which surround is which.

Then go to the Living Room (Arc) in ‘Settings/System’ and choose to ‘Add Surrounds’ and follow the onscreen instructions to add the two surrounds.

Then in the same Arc Living Room settings in ‘Settings/System’ choose to ‘Add Sub’ and follow the onscreen instructions to add the Sub to the setup and see if that resolves your issue.

When completed successfully your display will show all as one ‘Living Room’ in the App which will also show as ‘Living Room (+LS+RS+Sub)’ in ‘Settings/System’ 

Assuming you are using an Arc/eARC connection to the TV, now goto ‘Settings/System/Living Room’ and select ‘TV Setup’ and follow the onscreen instructions and in the TV settings enable HDMI CEC and set the sound-out to the HDMI-Arc/eARC TV port.

Userlevel 3
Badge +5

Thanks for your help.

As it turned out I had to reset my Panasonic TV back to factory settings as in the Sound menu, the Home Theatre option had (for some unknown reason) been ghosted out and the only option there was TV speakers which had become the default setting which explains why only the TV speakers could be heard as the Sonos system had been disabled.

 

Very weird indeed 🤔

Chances are even that ‘you’ didn’t change these settings, but a firmware update to your TV did. Same effect, just no real blame on your part ;)

Thanks for your help.

As it turned out I had to reset my Panasonic TV back to factory settings as in the Sound menu, the Home Theatre option had (for some unknown reason) been ghosted out and the only option there was TV speakers which had become the default setting which explains why only the TV speakers could be heard as the Sonos system had been disabled.

 

Very weird indeed 🤔

So have you also setup the Sonos Home Theatre too? - as your Sonos App screenshots do not show it as being setup correctly? I’m assuming you are using the two One-SL’s and Sub as part of that Home Theatre?

Userlevel 3
Badge +5

By the way this was after I carried out the advice listed above.

Thanks to you both for your help in getting my Sonos system back up and running 👍

Userlevel 3
Badge +5

Thanks for your help.

As it turned out I had to reset my Panasonic TV back to factory settings as in the Sound menu, the Home Theatre option had (for some unknown reason) been ghosted out and the only option there was TV speakers which had become the default setting which explains why only the TV speakers could be heard as the Sonos system had been disabled.

 

Very weird indeed 🤔

So have you also setup the Sonos Home Theatre too? - as your Sonos App screenshots do not show it as being setup correctly? I’m assuming you are using the two One-SL’s and Sub as part of that Home Theatre?

HI. I don't know what you mean as I have never had anything to do with Sonos Home Theatre.

 

I think I need to clarify, I was referring to the Home Theatre option in the TV settings.

 

I looked for the Home Theatre option in the Sonos app and couldn't find it assuming that is what you are referring to?

 

Edit: In response to your question, yes I am using two One SL's and a Sub as part of my setup.

I don't know if the Home Theatre option in TV settings (which allows external sound bars to be used in place of the TV speakers) is the same as what you are referring to.

🍻 

When you setup a Sonos Home Theatre, the Arc acts as the front left/right/center channels and it also will provide the height channel audio too for Atmos compatible connected TV’s etc; but it’s also a case you can ‘bond’ (not ‘group’) speakers to the Arc to use for the rear left/right TV channels and Atmos music audio too.

As an example the Two Sonos One SL speakers you have can be bonded to the Arc and so can the Sub. In the Sonos App in ‘Settings/System’ all would show as one room a little like the screenshot attached (except in my case I have bonded 2 surrounds and 2 Subs to my Living Room Arc).

I assumed (perhaps wrongly) that’s the type of setup you may have had originally, but your screenshots were not showing that Home Theatre surround sound setup. If you were not looking for that type of setup then forgive me, it’s just what many users tend to setup when they have all such speakers in the same living room.

 

So in ‘Settings/System’ in the Sonos App you should see just one room only like this:

Living Room (+LS+R/S+Sub)

I just wasn’t seeing that in your screenshots? 

So that’s why I mentioned this. 👍

Userlevel 3
Badge +5

Chances are even that ‘you’ didn’t change these settings, but a firmware update to your TV did. Same effect, just no real blame on your part ;)

Funny you should mention this as only the other day I had a firmware update for my TV (which installed okay) but the problem only manifested itself when I moved my router!

 

Anyway all sorted now 👌 

Reply