Sonos Beam - Regular TV Blackouts

  • 13 January 2022
  • 15 replies
  • 426 views

Userlevel 1
Badge

I saw another thread on this forum that exactly matched mine (see here) but it’s been closed so I’m opening a new one.

Every hour or two I get a blackout that lasts a couple of seconds, then the picture comes back but the sound is quiet, then another brief blackout, then the picture comes back.

I’m using a Sonos Beam connected to the TV (Philips 65PML9200, previously a 65OLED856) via HDMI Arc.

I’ve had the Virgin Media (STB) box replaced and Richer Sounds just replaced my entire television after months of arguing with them and Philips (the manufacturer). I’ve now got a new, different model TV and the same fault has occurred. You can’t imagine how angry I was that after all that, it seems like Sonos might be the cause.

Has anybody else had this issue? How can I diagnose?

My Sonos is out of warranty.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

15 replies

Userlevel 7

How is your tv connected to power? Is it possibly a faulty extension lead causing a temporary power loss or the actual plug socket?

Or do you also only experience this on the TV when the Beam is connected?

Userlevel 7
Badge +20

The Beam can't cause the video to black out, at best (or worse) it could turn the TV off completely. In line with comments from @Mr. T is your TV still receiving power when these black outs occur?

Have you changed your HDMI cables with your new TV and set top box?

Userlevel 1
Badge

How is your tv connected to power? Is it possibly a faulty extension lead causing a temporary power loss or the actual plug socket?

Or do you also only experience this on the TV when the Beam is connected?

 

The TV is connected directly to the socket with no extension. When the Beam is disconnected from the TV and we’re watching any source using the TV’s built-in speaker, there’s no blackouts.

Userlevel 1
Badge

The Beam can't cause the video to black out, at best (or worse) it could turn the TV off completely. In line with comments from @Mr. T is your TV still receiving power when these black outs occur?

Have you changed your HDMI cables with your new TV and set top box?

 

The TV does still recieve power during the blackouts, I can browse the TV menu etc, so there’s a source interruption. HDMI cables were indeed changed when trying to identify the cause. The Beam does send video to the TV (the wavy black & white lines on HDMI 1, in my case) so it’s possible there’s some CEC problem?

When we remove Beam from the setup, there are no issues at all.

How is your tv connected to power? Is it possibly a faulty extension lead causing a temporary power loss or the actual plug socket?

Or do you also only experience this on the TV when the Beam is connected?

 

The TV is connected directly to the socket with no extension. When the Beam is disconnected from the TV and we’re watching any source using the TV’s built-in speaker, there’s no blackouts.

I think I’ve read online about the Virgin Tivo Box having this issue. Try powering off the box using the on/off switch at rear left of box and leave it off for a minute or two. Then bring it back online and see if that fixes the issue.

Userlevel 1
Badge

How is your tv connected to power? Is it possibly a faulty extension lead causing a temporary power loss or the actual plug socket?

Or do you also only experience this on the TV when the Beam is connected?

 

The TV is connected directly to the socket with no extension. When the Beam is disconnected from the TV and we’re watching any source using the TV’s built-in speaker, there’s no blackouts.

I think I’ve read online about the Virgin Tivo Box having this issue. Try powering off the box using the on/off switch at rear left of box and leave it off for a minute or two. Then bring it back online and see if that fixes the issue.

 

Thanks Ken… we originally thought it was the Virgin box that was the problem, so VM came out and replaced it with a new one. Sadly it didn’t fix it. It could be that something within the Virgin box causes the problem maybe and therefore its a software problem at their end?!?

 

Thanks Ken… we originally thought it was the Virgin box that was the problem, so VM came out and replaced it with a new one. Sadly it didn’t fix it. It could be that something within the Virgin box causes the problem maybe and therefore its a software problem at their end?!?

Maybe try the switch off/on process, (leave it off for a couple of mins to clear the power from its circuits) and just see if it (hopefully) fixes the issue. I’m sure that’s what some VM customers were doing to fix it.

Userlevel 7

Found this online about the Virgin TiVo box, but users were still posting issues 3yrs after.

https://community.virginmedia.com/t5/Forum-Archive/Picture-dropout-Black-Screen-with-new-V6-box-amp-Samsung-TV/td-p/3410378

What other sources do you use with the tv? The blackouts occur when using those also?

Userlevel 1
Badge

Yep, blackouts also occur with my Apple TV 4K

i just had the problem and did a diagnostics report, number 930629644

Yep, blackouts also occur with my Apple TV 4K

i just had the problem and did a diagnostics report, number 930629644

You are perhaps best to now contact to Sonos Support Staff with that diagnostic report reference.. you should be able to contact/chat to them via this LINK

Hope you are able to get the issue sorted soon.

Userlevel 7

One other suggestion is around the Eco Settings for the TV.

Is there anything in there that could be causing the screen to go blank after a certain amount of time?

Some Philips televisions have the ability to turn the screen off if you’re listening to music and don’t want to view a picture.

Is the energy saving setting set to “screen off” or wording to that effect?

Hi nicjshacklock, did you manage to resolve this issue?

I basically have the same problem (Philips OLED and Sonos Beam)

This is happening with my brand new Arc 5.1 system and my new LG C1, when going through my apple tv 4k. Any suggestions on a fix?

crbalch,

Do you experience this issue when watching one of the TV’s Apps?

As a test, connect the AppleTV to another HDMI port on your TV. Another test would be to use the optical connection to ARC.

 

My setup is very similar to crbalch’s.

I have a Sonos Beam connected via HDMI to an LG C1 TV.  I use an AppleTV 4K to stream content.  I get these blackouts constantly. I tried changed HDMI ports and it doesn’t seem to matter.

 

My guess is that this comes down to a stability issue in the way the Sonos is handling the HDMI protocol. The HDMI connection uses an encryption standard that must be negotiated between all three devices when the content is being streamed by the AppleTV, the audio is being played by the Sonos, and the image is displayed by the TV. This encrypted connection is designed to protect the content from piracy is not beneficial to the consumer. It only cause these kinds of device interoperability headaches for us. 
 

Anyway, it seems like Sonos is the common denominator here.