Answered

Sonos Arc Vizio TV CEC connection problem

  • 17 February 2021
  • 5 replies
  • 2945 views

Hi,

Got a new Sonos Arc SL, complete with two One SL and a sub gen3. It is connected to Vizio tv e601i-a3 using the provided HDMI cable to the HDMI 1 slot in the tv, which is the only ARC slot available. In HDMI 2 I have a Fire TV cube. 

The problem, neither the Sonos app nor the tv recognize the CEC function. Initially, when it was fist setup everything worked and the tv recognized CEC. Now, when I try to discover CEC devices it does not discover the Sonos Arc nor the Amazon Cube, both CEC devices. At this point I'm leaning towards a problem with the TV, that is a bit old.

FYI - Everything works… Sound and surround works, comes out in Dolby, but the app does not connect to the TV (below pic of error), nor the TV recognize the CEC function; it does not matter how many times I do it. I found a work around to set up the TV remote with the app, so I can control the soundbar volume with te remotes, but other CEC functions do not work. 

Again, in functionality you cannot spot the error, it just bothers me that the CEC does not work and I have to skip pairing the TV properly. 

Let me know of a fix or if anyone has encountered this problem with this or another tv.

Thanks - H

 

 

icon

Best answer by GuitarSuperstar 17 February 2021, 20:44

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7

What other CEC functions aren’t working? Have you tried unplugging your TV, Arc, and HDMI cables and setting it back up again from the beginning?

Hi,

Thanks for your response… yes, I've unplugged the TV and ARC from the power source as well unplugged and plugged the HDMI cables and try different configurations, but the TV only has one ARC so not many configurations are possible. Yes tried to setup from the beginning but it di not work. 

The only thing I have not tried is resetting the ARC to factory settings… maybe I should try that.

Userlevel 7

You could try that.

Did you perform the TV Setup in the Sonos app?

You should also try setting the Arc up WITHOUT the Fire TV Cube connected.

Did you perform these steps setting up CEC on your TV?

To enable, disable, or adjust CEC settings:

  1. Press the MENU button on the remote. The on-screen menu is displayed.
  2. Use the Arrow buttons on the remote to highlight System and press OK. The System menu is displayed.
  3. Use the Arrow buttons on the remote to highlight CEC and press OK. The CEC menu is displayed.
  4. Use the Arrow and OK buttons to adjust each setting:
  • CEC Function - To use CEC, you must select Enable.
  • System Audio Control - When system audio control is on, you can control your device’s audio using the TV’s remote control.
  • Device Discovery - Use this function to determine if your device is connected and supports CEC.


Under “Device Discovery” what devices are listed?

Resolved, tried the setup without the Fire tv cube being plugged in and it picked up the CEC and Sonos system quick… I guess the Fire TV cube emits interference in the setup - who knew. Plug in the fire tv afterwards and everything good to go.

Thanks - H

Userlevel 7

Glad you got it working. I had to unplug my other devices too to set up my Arc.