No surround sound with Sonos Beam + Connect:AMP

Badge +1

Hello, I have a LG B9 OLED TV. Hooked up via eARC HDMI to my Sonos Beam.

I also have a Connect:AMP, set as the surround speakers of my Beam.

When I play movies via the Netflix of Disney+ app I don’t hear any surround sound via my speakers that are connected via the Connect:AMP.

I submitted a diagnose report: 177965938

  • Both the Beam and Amp are connected of LAN (wired)
  • If I disconnect the Amp from the Beam I can play music from the Amp speakers
  • TV Output is set to HDMI eARC and Passthrough (not PCM)

Best answer by jeroenvdb 4 August 2021, 09:25

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

The usual sound settings to go with on most recent LG TV’s are:

  • Simplink & Auto-Power Sync: ‘ON’
  • Sound Out: ‘HDMI ARC’
  • HDMI Input Audio Format: ‘Bitstream’
  • Digital Sound Out: ‘Pass Through’
  • eARC: ‘On’
  • DTV Audio: ‘Auto’ or ‘Dolby Digital’ (Not ‘Dolby Digital Plus’ - as that codec is not supported by the Beam)
Badge +1

Hi @Ken_Griffiths thanks for you response, I reviewed my settings, I have my TV setup exactly this way. See screenshots.


So have you perhaps tried playing a movie from say the built-in Netflix App, say the ‘6 Underground’ movie, as an example - does that give you DD 5.1 audio ?

Badge +1

Yes the Sonos app indicates “DD 5.1 audio”. But I just can’t hear any sound from the speakers. I’ve put the surround speakers volume on +15 to make sure I would be able to hear it.

To be fair: I once succeeded in the setup and the surround speakers were working but because I had audio-sync issues I started changing again 🤦‍♂️

I now want to get them back to surround again.


Perhaps put all back to default in the Sonos App (maybe with the exception of switching music audio to ‘Full’ output on the surrounds, rather than ‘Ambient’) and check you haven’t toggled off the surrounds completely  in the Beam’s surround audio settings (top right of surround audio screen) and then try it again.

Badge +1

I found the problem. My Beam was connected wired and wireless. I disabled Wifi, forcing the Beam to use the wired connection.

The surround sound is not working.

Thanks @Ken_Griffiths for thinking along.

When you turn off the wireless in the Beam, it can no longer send a signal to the surrounds via its ‘unseen’ WiFi network. As long as you have surrounds, the WiFi on the Beam should be turned on. 

Badge +1

@Airgetlam I did not know that. I turned WiFi back on for Beam and Connect:AMP. Is that somewhere in the documentation?

I guess the solution was then pulling the LAN wire out and back in. Maybe it even wasn’t connected right in the first place if I think off it 🤦‍♂️

Userlevel 7
Badge +17

@Airgetlam Since @jeroenvdb is using a Connect:amp that needs to be wired for surround (probably because it does not do 5Ghz, see and his Beam also seems to be wired, would he really need wifi to be on?

Indeed, in that situation, it is not required. I missed that in the original post as the device was referenced as both a CONNECT:AMP and an Amp. My mind fastened on the Amp reference, and ignored the fact it was a CONNECT:AMP, which would indeed need to be wired to act as a driver for surround speakers. 

No real need in that case for the WiFi to be turned on, but there isn’t much reason to turn it off either, unless there is a situation where the Sonos is generating interference of some sort.