Answered

New surround issue...

  • 25 February 2023
  • 4 replies
  • 299 views

I have an Arc, Sub & 2x One SLs that have been running just fine since I got them nearly 2 years ago. I have an LG OLED TV with eArc, and I’m running version 15.1 of the app.

Recently, on some random occasions, the voice part of the audio has started to come out of the right hand surround speaker, and not out of the Arc. It’s as if the surround has been reversed - what should be out of the Arc is coming out of the right hand surround and vice versa. The left hand surround appears to be working normally, as well as the sub. It’s weird, I’m not gonna lie. If I turn the surrounds off, the Arc works normally with the sub.

The problem persists whether I’m watching regular TV on Sky Q or apps on Apple TV. I’ve not done anything different to normal, it just happened but I can’t remember if it was after a channel change or after a pressed pause moment. I don’t know when the 15.1 update happened, and I don’t know the date the problem first happened, so I don’t know if it’s anything to do with the last update, soz.

I’ve tried disconnecting and reconnecting the HDMI cable on the Arc, and I’ve unplugged and replugged the Arc and right surround, and it doesn’t fix the issue. I did discover tonight though that if I turn my TV off for a couple of minutes, then back on again it seems to go back to normal. 

Any ideas what this could be, why it’s happening and what I can do to stop it happening again? 

icon

Best answer by GuitarSuperstar 25 February 2023, 23:57

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7

Try removing the One SLs as surrounds and swap them (left is now right, right is now left). The re-add them as surrounds and test again.

 

Also be sure to set the TV to these settings:

HDMI Input Audio Format: Bitstream

Digital Sound Output: Pass Through

eARC Support: On

I’m having a similar problem. Since the new update. The voice keep switching from the arc to the surround speakers. Never did that before and it’s very annoying 

Have you done as suggested above? Have you submitted a system diagnostic within 10 minutes of experiencing this problem, and called Sonos Support to discuss it? Which TV do you have? Which Sonos speakers? What OS are you running on those Sonos speakers? What is the TV getting its signal from?

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your network and Sonos system.

In my case, I realised that after a house renovation, I had put my speakers (two Play:1s) back in the wrong corners of the room. My confusion stemmed from having done Trueplay tuning, which does not re-situate your two stereo speakers. So left is still left after the tuning even if you had swapped them around at some point (which also means the tuning has probably settled on a bad result). 
 

Removing and then re-adding the rears, which then gives you a chance to identify which is left and which is right sorted this out for me. Then just ran tuning again. Made a huge difference.