Answered

Autoplay doesn't work when connecting turntable to Connect:Amp and Beam

  • 1 February 2021
  • 8 replies
  • 264 views

So I’ve spoken to several Sonos reps on the phone and have not been able to resolve this issue. Basically I’ve recently purchased a used Connect:Amp to be able to connect my turntable (the brand is Tone Factory with built-in pre-amp) via line-in to my Beam. Setup goes smoothly and audio comes out of the Beam no problem when I manually select the turntable in the Sonos S2 app. However, no matter what combination of settings I try, I cannot get the Autoplay feature to switch from whatever the Beam is playing (I've tried with the TV on and off, as well as streaming music through Sonos Radio and Spotify) to the Connect:Amp once I start playing a record on the turntable. One rep told me the reason is that the Beam, which already has TV autoplay, has a built-in delay and waits for a signal from the tv so I must turn off the tv and wait for 10, oh no actually, 20 minutes before autoplay will work on the Connect:Amp. But besides being extremely impractical, I don’t think it can be true because the same problem occurs when streaming audio only with the tv off. I’ve also tried a different line-in source, so the problem doesn’t seem to be coming from the turntable. I have the Source Level turned up to 10 so it’s not a question of the autoplay threshold that I’ve read about other users having trouble with.

This isn’t a huge issue for me when I’m home and have the Sonos app handy (although not exactly convenient), but there are others in the house who want to be able to play records and don’t necessarily have access to the app when I’m not around. Thoughts?

icon

Best answer by John B 10 February 2021, 13:38

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Userlevel 6
Badge +15

Hi @mauid123, welcome to the Sonos Community!

It may be worth taking another look at the Line-In settings - if you go to the Autoplay section, what room is currently selected as Autoplay Room?

If you were to group the Beam to the Connect:Amp, and then set the Connect:Amp as the Autoplay Room, with “Include Grouped Rooms" enabled, does the Beam properly start to play when the turntable is started?

Hi Xander,

Thanks for the suggestion. Unfortunately I’ve tried setting the Autoplay Room to both the Beam and the Connect:Amp (always with “Include Grouped Rooms” selected), neither works. Interestingly, when I change this setting to “None” and then change it back to either the Beam or Connect:Amp room, the autoplay works! But only the one time. Once I switch to another source and try to play a record again, the autoplay again refuses to change back. But at least this tells me that the autoplay CAN work with the turntable, there’s just something not working other times.

I’ve just submitted diagnostics after having done this exact situation, the confirmation number is: 444630444. Perhaps you can see whether the autoplay is failing the second time or not turning on at all?

Have you tested the scenario in which the Beam has TV Autoplay disabled?

What happens if the Beam is connected to the TV by optical and the adapter, rather than HDMI-ARC.  ( I am assuming currently HDMI-ARC?).

Have you tested the scenario in which the Beam has TV Autoplay disabled?

What happens if the Beam is connected to the TV by optical and the adapter, rather than HDMI-ARC.  ( I am assuming currently HDMI-ARC?).

Hi John,

Yes it’s currently connected via HDMI-ARC. Unfortunately, when I try to connect via the optical adapter a new problem arises: I can’t seem to control the volume via the TV remote. The TV is an LG 55SM8600 with Magic Remote. The Sonos app goes through the remote discovery but since the Magic Remote doesn’t use IR, the discovery process never finds it. I found an article addressing this problem (https://support.sonos.com/s/article/3479?language=en_US) but it seems to be out of date and the new LG OS doesn’t work the same way. 

Anyway, I think this point is moot because, in answer to your other question, this same problem occurs when I disable the Beam TV Autoplay. Indeed, it doesn’t work even when I have the HDMI cable removed completely from the Beam! I’ve tested it without the TV connected at all but instead streaming music through Spotify and Sonos Radio and still the Line In autoplay does not want to activate. I’m stumped...

OK taking stock..

You have tested this to destruction, in a very methodical way, and there seems to be no logical reason for the Autoplay to fail.  I have never heard of that 10 or 20 minute delay thing and agree with you that that is illogical and unconvincing.

You have it set up correctly, or you would not be able to select the line-in source manually and have it play successfully.

The only thing I can think of is some sort of communications glitch in triggering the Autoplay and getting the command to Autoplay sent, received and actioned.  This is clutching at straws.  Nevertheless, things I would try would be a complete reboot of your router and Sonos speakers.  You could also try (experimentally) wiring the C:A to your router.

I wish I could offer something more convincing!

 

Hi John,

Yeah it looks like I’m out of options. I took your suggestion and did a hard reset on both devices, then I set up the Connect:Amp first and then the Beam. But the same issue occurs. And the C:A is already wired to the router directly, so that’s not it either. Oh well, I guess it’s just a problem that I’m going to have to live with. Thanks anyway for your help!

It isn’t really a solution, but I wonder why others cannot use the turntable when you aren’t around.  Do others in the house not have access to your WiFi?  If not, that is a perfectly reasonable security decision for you to take.  But if they can connect to the WiFi, there is nothing to stop them downloading the Sonos app, connecting to your Sonos and playing music.  I could understand your not being keen on that, mind you!

It isn’t really a solution, but I wonder why others cannot use the turntable when you aren’t around.  Do others in the house not have access to your WiFi?  If not, that is a perfectly reasonable security decision for you to take.  But if they can connect to the WiFi, there is nothing to stop them downloading the Sonos app, connecting to your Sonos and playing music.  I could understand your not being keen on that, mind you!

 

Yeah in the end that’s what I’ll have them do. Just a bit frustrating when autoplay is an advertised feature with Sonos. But not the end of the world for sure. Thanks again, John!