Audio mutes before volume slider reaches zero

  • 13 January 2021
  • 5 replies

Userlevel 1

I have a Sonos Amp + Third Party Sub + 2 x One SL rear speakers.

Below a certain volume, that isn’t zero, the audio completely cuts out (screenshots below shows the lowest level that gives output). The slider still slides further along before hitting mute at the end, it just has no effect on output, as it’s already silent.

This means it isn’t possible to adjust the system to run quieter than a level that is - sometimes at night - too loud.

This issue does not affect my other rooms (Play:3 in one, Play:1 in the other), including if I group them with the Amp.

Is this expected behaviour, or a bug?


Sonos Mac App (12.2.2)
Sonos iOS App (12.2.2)

Best answer by ratty 13 January 2021, 11:43

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Are you using the Volume Limit option?

Userlevel 1

@ratty Aha thanks, yes, I am - it’s set to 25%. Just tried removing it and it does appear to solve the issue.

I guess this is a bug with how the slider recalculates the scale once a limit is set. I don’t expect the system to mute until it’s dragged right to the end (and the speaker icon shows no output).

The ‘Volume Limit’ is essentially a scaling factor. If the result of multiplying the slider percentage by the ‘limit’ factor is less than 1% you won’t hear anything, even though the Mute LED doesn’t light.

Userlevel 1

That does sound like a bug/poorly considered bit of programming though. If there is no audio below 1% it would be relatively easy to make the scale calculation for the slider omit anything between 0% and 1%, so that even with a limit adjustment the first click on the slider is always 1%, or whatever value gives the lowest volume with output.

Either way, whether it’s the ideal implementation or not, question answered. Thanks!

Actually there can be arcane situations where one wants zero output at, say, 0.8% but one doesn’t want the Mute LED to be lit.