Why is Sonos Arc having eARC issues?

I have a Sonos Arc connected to an LG CX TV and the two devices aren’t working well together when eARC is enabled.  After much, much research into the topic online it appears to be an issue with the Sonos Arc and newer Samsung TV’s too.  It appears the implementation of eARC by Sonos and the higher end TV manufacturers attempting to implement eARC is not going so well.  I would encourage Sonos to work with LG and Samsung to get this figured out as consumers are spending a lot of money on this high-end equipment and deserve a better experience.


Best answer by MakeItSo 2 August 2021, 07:14

View original

13 replies

Userlevel 7

What specific problems are you having?

Userlevel 4
Badge +10

At Sonos Arc launch I had intermittent dropouts with my LG CX, was so annoying. Luckily for me this has been fixed in a firmware, not sure if that was LG or Sonos though.

Apart from a issue with LPCM passthrough, (5.1 output as 7.1) (could just be LG misreporting 5.1 audio as 7.1) its been rock solid throughout the later half of 2020 and 2021.

AppleTV4K  sends out all 5.1 (non-Atmos) content as LPCM now which the CX/Sonos can’t seem to process correctly - very frustrating.  As an end user, I can’t tell if the CX is mucking up the pass-through, or if the Sonos just can’t process the stream correctly.  The AppleTV seems to think the CX/Sonos is capable of LPCM, so it sends it out in that format instead of DD5.1.  Interestingly enough, the CX/Sonos has no issue with Atmos content coming out of the AppleTV as Dolby Atmos in Dolby MAT, which I understand is an enhanced form of LPCM.

to summarize, if I try to play 5.1 non-Atmos content from the AppleTV4K I get no sound.  I have to go into the AppleTV settings and manually force DD5.1 to get sound.  If I switch the TV from eARC to ARC, everything works better, but all Atmos content gets downgraded to Atmos DD+.

Userlevel 7

Since the Apple TV 4K uses Dolby MAT, Dolby Digital Plus content will play as Multichannel PCM audio through the Arc. If you aren’t getting any sound from DD+ content, your TV’s audio settings might need to be changed. Can you post your current audio settings?

Sure.  Thank you.

Current settings in my LG CX:

- Firmware 03.23.15

  • Sound Out: HDMI ARC
  • HDMI Input Audio Format: Bitstream
  • Digital Sound Out: Pass Through
  • eARC: On


Is the DTV Audio setting (audio-in search order) set to ‘Auto’ aswell in the LG TV Sound Settings? If so, I have those exact same TV Settings too, including ‘pass-through’ and eARC set to ‘ON’.

My Arc is connected however to the older LG C9 OLED and an Apple TV4 HD and the audio received is working and showing in my Sonos App (About Box) as Linear ‘Multichannel PCM 5.1’, that’s with the Apple device audio just simply set at its default ‘auto’ settings. So it’s ’perhaps’ not a fault of the Arc/Sonos software.

I was just playing the movie ‘6 Underground’ from Netflix when I tested this just FYI.

Just wondering if this might be an LG CX TV firmware issue perhaps🤔?

Thank you, but I am not sure what setting you are referring to when you say “Is the DTV Audio setting (audio-in search order) set to ‘Auto’ aswell in the LG TV Sound Settings?”. I don’t see a setting like that in the CX menu.

Userlevel 7

What are your Apple TV audio settings set to?

AppleTV settings are:

  • Change Format: Off
  • Dolby Atmos: On
  • Audio Mode: Auto

Thank you

Userlevel 7

Your TV and Apple TV audio settings look correct. Make sure your TV has the latest firmware installed and try unplugging the TV and Arc from power for a couple of minutes and see if this changes anything.

Played around with the LG settings this evening and when I changed the setting Digital Sound Out from “Pass-Through” to “Auto” everything was working fine.  Non-Atmos sound now showing up as “Dolby Multichannel PCM 5.1” and Atmos content still showing as Atmos, with no DD+ downgrade.


 Thank you.

I have an LG Nano86 with Sonos Arc/2xOnes/Sub. It worked perfectly for about 6 months, after which the LG started to lose the eARC connection and revert to its internal speakers. I assume this is a result of a software “upgrade” - either LG or Sonos - as nothing else has changed.


I’ve tried switching the Digital Sound Out setting to Auto (previously Pass-Through) but the problem persists.


Hugely frustrating! I don’t know whether this is Sonos’ fault or LG’s. I am quite certain that each will blame the other. Meanwhile I have a full Sonos equipped cinema sound system but we are listening to the tinny internal speakers.


I am thrilled.

LG are sending an engineer (!?) to my home to look into this. I am sceptical (anticipating only some power cycling…) but will report back if anything of interest should be identified.