Why doesn't Sonos support DTS 4 (ie. Blu Ray DTS)?

  • 5 December 2022
  • 17 replies
  • 298 views

Userlevel 1
Badge +1

So I’ve had a longstanding issue with DTS on Sonos, where I can play DTS Blu Rays, but only if I turn off the ‘eARC’ of my TV. This is better than nothing, but frustrating as turning eARC off causes other issues with my setup.

Sonos today told me that this is due to my Blu Rays outputting a form of DTS called ‘DTS 4’ which apparently Sonos don’t support. I’ve never been aware of DTS 4, and it seems all/most Blu Rays output DTS using that.

Apparently the reason it works with eARC off is that my TV then downgrades DTS 4 to DTS, and Sonos plays it.

But I really don’t understand why this is not supported as standard if it’s the only form of DTS on Blu Rays, and why there isn’t a way to just automatically downgrade it (without turning eARC off)? Does anyone know if Sonos are likely to add support for this soon?

My setup:

TV - LG B9 OLED

Blu Ray Player - Panasonic DP-UB820

Sonos - Sonos Arc + One SLs


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

17 replies

Userlevel 1
Badge +1

I’ve not heard of DTS 4 but it could well just be DTS-HD that they’re referring to.

I’ve not heard of DTS 4 but it could well just be DTS-HD that they’re referring to.

Just switch the sending device/player to transcode the DTS audio to Mc-LPCM. Both DTS-X/HQ are not (currently) supported by Sonos.

DTS 5.1 (lossy) is supported, but also note some TV’s may not pass-through the codec.

Userlevel 1
Badge +1

I’ve not heard of DTS 4 but it could well just be DTS-HD that they’re referring to.

Just switch the sending device/player to transcode the DTS audio to Mc-LPCM. Both DTS-X/HQ are not (currently) supported by Sonos.

DTS 5.1 (lossy) is supported, but also note some TV’s may not pass-through the codec.

As I said in the other thread, doing this means that you also lose Dolby Atmos/TrueHD, so that’s more of a hassle than turning eARC off/on.

There should be a way to automatically downgrade it to a supported audio without downgrading every audio type - or better still for Sonos to support a DTS audio type that the vast majority of DTS users will be playing (ie. for Blu Rays).

Userlevel 7

I’ve not heard of DTS 4 but it could well just be DTS-HD that they’re referring to.

Just switch the sending device/player to transcode the DTS audio to Mc-LPCM. Both DTS-X/HQ are not (currently) supported by Sonos.

DTS 5.1 (lossy) is supported, but also note some TV’s may not pass-through the codec.

As I said in the other thread, doing this means that you also lose Dolby Atmos/TrueHD, so that’s more of a hassle than turning eARC off/on.

There should be a way to automatically downgrade it to a supported audio without downgrading every audio type - or better still for Sonos to support a DTS audio type that the vast majority of DTS users will be playing (ie. for Blu Rays).

How do you “lose Dolby Atmos/TrueHD” when playing a DTS-encoded disc that doesn’t have a Dolby Atmos/TrueHD audio track?

FYI… the Panasonic DP-UB820 has separate settings for Dolby and DTS audio. Set Dolby Audio to Bitstream. Set DTS/DTS-HD to PCM. And set BD-Video Secondary Audio to Off. With these settings (and with eARC enabled on the TV), anytime you play a disc with a Dolby TrueHD/Atmos track it will play the correct audio. When you play a disc with a DTS-HD Master Audio or DTS:X track, it will play as “Multichannel PCM” out of the Arc.

 

I’ve not heard of DTS 4 but it could well just be DTS-HD that they’re referring to.

Just switch the sending device/player to transcode the DTS audio to Mc-LPCM. Both DTS-X/HQ are not (currently) supported by Sonos.

DTS 5.1 (lossy) is supported, but also note some TV’s may not pass-through the codec.

As I said in the other thread, doing this means that you also lose Dolby Atmos/TrueHD, so that’s more of a hassle than turning eARC off/on.

There should be a way to automatically downgrade it to a supported audio without downgrading every audio type - or better still for Sonos to support a DTS audio type that the vast majority of DTS users will be playing (ie. for Blu Rays).

I’ve just replied to your post in the other thread - I don’t toggle eARC off at all and with it enabled on the C9, it passes through both DTS 5.1, MC-LPCM and all the Dolby codecs including Dolby TrueHD - I do not have Atmos, as I use a PlayStation, but presumably the TV would happily pass-through Dolby TrueHD (Atmos).

My C9 TV firmware is version 05.30.11, just in case that may assist you too.

Userlevel 1
Badge +1

I’ve not heard of DTS 4 but it could well just be DTS-HD that they’re referring to.

Just switch the sending device/player to transcode the DTS audio to Mc-LPCM. Both DTS-X/HQ are not (currently) supported by Sonos.

DTS 5.1 (lossy) is supported, but also note some TV’s may not pass-through the codec.

As I said in the other thread, doing this means that you also lose Dolby Atmos/TrueHD, so that’s more of a hassle than turning eARC off/on.

There should be a way to automatically downgrade it to a supported audio without downgrading every audio type - or better still for Sonos to support a DTS audio type that the vast majority of DTS users will be playing (ie. for Blu Rays).

How do you “lose Dolby Atmos/TrueHD” when playing a DTS-encoded disc that doesn’t have a Dolby Atmos/TrueHD audio track?

FYI… the Panasonic DP-UB820 has separate settings for Dolby and DTS audio. Set Dolby Audio to Bitstream. Set DTS/DTS-HD to PCM. And set BD-Video Secondary Audio to Off. With these settings (and with eARC enabled on the TV), anytime you play a disc with a Dolby TrueHD/Atmos track it will play the correct audio. When you play a disc with a DTS-HD Master Audio or DTS:X track, it will play as “Multichannel PCM” out of the Arc.

 

No, this doesn’t turn DTS into LPCM for me - this turns it into Stereo PCM (I’d love to know how you get LPCM though).

When I say I’ve ‘lost Atmos’, that’s when I’ve turned Secondary Audio to ‘On’ - I get DTS 5.1, but it also switches all Atmos content to DD 5.1 too.

Userlevel 7

@Robboadam Be sure your TV settings are set to this:

HDMI Input Audio Format: Bitstream

Digital Sound Output: Pass Through

eARC Support: On

 

If your TV is already set to these settings, then more than likely your TV is not able to pass through LPCM audio from the UB820. This has been an issue with LG and Panasonic for quite some time. But it was fixed with some of the newer model LG OLEDs about 5 months ago. Either it hasn’t been fixed on the B9 or you need to update the B9 with the latest firmware/software.

The other option is to get a different Blu-ray player.

Userlevel 1
Badge +1

@Robboadam Be sure your TV settings are set to this:

HDMI Input Audio Format: Bitstream

Digital Sound Output: Pass Through

eARC Support: On

 

If your TV is already set to these settings, then more than likely your TV is not able to pass through LPCM audio from the UB820. This has been an issue with LG and Panasonic for quite some time. But it was fixed with some of the newer model OLEDs about 5 months ago. Either it hasn’t been fixed on the B9 or you need to update the B9 with the latest firmware/software.

The other option is to get a different Blu-ray player.

Hmm, I feel like I’m back to square one with this. B9 supports DTS (which the later models don’t), so I don’t know why it can’t just downgrade DTS-HD to DTS.

Like, it’s nice to have DTS ability, but no matter what setting I put it in there seems to be an issue that goes along with playing DTS.

Which is why I don’t understand why Sonos can’t just add support for the format that is actually used most. No one uses standard DTS, it’s always DTS-HD/4

Yes, FWIW - those are my LG C9 TV settings here too, I rarely ever change them.

It’s not clear to me now @Robboadam if you have the LG B9 or C9 TV, but both do/(did?) support DTS-5.1 pass-through according to rtings.com:

B9-TV

https://www.rtings.com/tv/reviews/lg/b9-oled

C9-TV

https://www.rtings.com/tv/reviews/lg/c9-oled

…and my C9 definitely works fine here for that lossy codec with eARC enabled.

For the uncompressed DTS-X/HD codecs I just use MC-LPCM on the player.

Userlevel 1
Badge +1

It’s not clear to me now @Robboadam if you have the LG B9 or C9 TV, but both do/(did?) support DTS-5.1 pass-through according to rtings.com:

B9-TV

https://www.rtings.com/tv/reviews/lg/b9-oled

C9-TV

https://www.rtings.com/tv/reviews/lg/c9-oled

…and my C9 definitely works fine here for that lossy codec with eARC enabled.

For the uncompressed DTS-X/HD codecs I just use MC-LPCM on the player.

I have the B9. Not sure why it doesn’t work then.

Userlevel 7

It’s not clear to me now @Robboadam if you have the LG B9 or C9 TV, but both do/(did?) support DTS-5.1 pass-through according to rtings.com:

B9-TV

https://www.rtings.com/tv/reviews/lg/b9-oled

C9-TV

https://www.rtings.com/tv/reviews/lg/c9-oled

…and my C9 definitely works fine here for that lossy codec with eARC enabled.

For the uncompressed DTS-X/HD codecs I just use MC-LPCM on the player.

I have the B9. Not sure why it doesn’t work then.

It does work. You just have to change the Secondary Audio setting on the UB820 to ON, correct?

Userlevel 1
Badge +1

It’s not clear to me now @Robboadam if you have the LG B9 or C9 TV, but both do/(did?) support DTS-5.1 pass-through according to rtings.com:

B9-TV

https://www.rtings.com/tv/reviews/lg/b9-oled

C9-TV

https://www.rtings.com/tv/reviews/lg/c9-oled

…and my C9 definitely works fine here for that lossy codec with eARC enabled.

For the uncompressed DTS-X/HD codecs I just use MC-LPCM on the player.

I have the B9. Not sure why it doesn’t work then.

It does work. You just have to change the Secondary Audio setting on the UB820 to ON, correct?

But that makes everything downgraded - including Atmos downgraded to DD 5.1

I have the B9. Not sure why it doesn’t work then.

It’s slightly more difficult for me to comment, as I have the C9 TV here and it might be the case LG changed something on the B9 model, as suggested, but you would have to speak with the LG Support desk to confirm if that’s the case.

The reason I suspect the DTS-X/HD codecs are not supported by Sonos, is there is likely a licensing cost involved and there’s already lots of HT products in peoples Homes and it may not make good sense to make that change, though it has been discussed before, here in the community, that it could be catered for by a one off additional purchase, or perhaps a monthly/annual subscription.

My guess is the demand is perhaps not large enough for it to happen, as the majority of users are now using the streaming Movie services who presently use Dolby audio instead.

Userlevel 7

It’s not clear to me now @Robboadam if you have the LG B9 or C9 TV, but both do/(did?) support DTS-5.1 pass-through according to rtings.com:

B9-TV

https://www.rtings.com/tv/reviews/lg/b9-oled

C9-TV

https://www.rtings.com/tv/reviews/lg/c9-oled

…and my C9 definitely works fine here for that lossy codec with eARC enabled.

For the uncompressed DTS-X/HD codecs I just use MC-LPCM on the player.

I have the B9. Not sure why it doesn’t work then.

It does work. You just have to change the Secondary Audio setting on the UB820 to ON, correct?

But that makes everything downgraded - including Atmos downgraded to DD 5.1

It’s pretty simple… 

If you are playing a DTS-encoded Blu-ray disc, set Secondary Audio on the UB820 to ON. This will result in DTS Digital Surround audio playing out of the Arc.

If you are playing a Dolby-encoded Blu-ray disc, set Secondary Audio on the UB820 to OFF. This will result in Dolby TrueHD/Dolby Atmos audio playing out of the Arc.

The process of changing the Secondary Audio setting on the UB820 takes less than 10 seconds.

You cannot get Multichannel PCM audio from DTS-encoded Blu-rays because of the handshake issue between the UB820 and B9. If you want Multichannel PCM audio, get a different Blu-ray player that works with your TV.

Userlevel 1
Badge +1

It’s not clear to me now @Robboadam if you have the LG B9 or C9 TV, but both do/(did?) support DTS-5.1 pass-through according to rtings.com:

B9-TV

https://www.rtings.com/tv/reviews/lg/b9-oled

C9-TV

https://www.rtings.com/tv/reviews/lg/c9-oled

…and my C9 definitely works fine here for that lossy codec with eARC enabled.

For the uncompressed DTS-X/HD codecs I just use MC-LPCM on the player.

I have the B9. Not sure why it doesn’t work then.

It does work. You just have to change the Secondary Audio setting on the UB820 to ON, correct?

But that makes everything downgraded - including Atmos downgraded to DD 5.1

It’s pretty simple… 

If you are playing a DTS-encoded Blu-ray disc, set Secondary Audio on the UB820 to ON. This will result in DTS Digital Surround audio playing out of the Arc.

If you are playing a Dolby-encoded Blu-ray disc, set Secondary Audio on the UB820 to OFF. This will result in Dolby TrueHD/Dolby Atmos audio playing out of the Arc.

The process of changing the Secondary Audio setting on the UB820 takes less than 10 seconds.

You cannot get Multichannel PCM audio from DTS-encoded Blu-rays because of the handshake issue between the UB820 and B9. If you want Multichannel PCM audio, get a different Blu-ray player that works with your TV.

Except I’ve tried it with another Blu Ray player (UB300) and I have the same issue, so it can’t just be down to the 8200.

There’s a setting on the player to have ‘Secondary Audio’ to ‘Automatic’ which should surely automatically change it depending on the format - but I’ve tried that and it doesn’t work either.

Userlevel 7

It’s pretty simple… 

If you are playing a DTS-encoded Blu-ray disc, set Secondary Audio on the UB820 to ON. This will result in DTS Digital Surround audio playing out of the Arc.

If you are playing a Dolby-encoded Blu-ray disc, set Secondary Audio on the UB820 to OFF. This will result in Dolby TrueHD/Dolby Atmos audio playing out of the Arc.

The process of changing the Secondary Audio setting on the UB820 takes less than 10 seconds.

You cannot get Multichannel PCM audio from DTS-encoded Blu-rays because of the handshake issue between the UB820 and B9. If you want Multichannel PCM audio, get a different Blu-ray player that works with your TV.

Except I’ve tried it with another Blu Ray player (UB300) and I have the same issue, so it can’t just be down to the 8200.

There’s a setting on the player to have ‘Secondary Audio’ to ‘Automatic’ which should surely automatically change it depending on the format - but I’ve tried that and it doesn’t work either.

Get a non-Panasonic Blu-ray player.