Answered

Sonos Arc Samsung Frame TV eARC not working


Userlevel 3

So I just set up the Sonos Arc soundbar that supports eARC. It works with my 2020 65" Frame TV until I change the eARC setting on the Frame TV to Auto. The sound mutes and I can't get it to play until I turn eARC off. Anyone else have this issue? I’ve messed around with this for a few hours to no avail. 

icon

Best answer by Ditte 22 January 2021, 17:53

Hi all, yet another note from the dev team:

We have been working on the ongoing audio problem between the Sonos Arc and several 2020 Samsung TV models. These models support the new eARC connectivity. Samsung TVs prior to and from 2019 do not support eARC and are not seeing this particular problem. Customers will randomly experience a complete loss of audio which requires either the rebooting of the Sonos Arc and/or the rebooting of the Samsung TV. 

If you are experiencing this problem and you are willing to assist with some short term testing, please contact our customer care department at your earliest convenience.

Best,

Ditte

View original

574 replies

Yet another +1 on this topic.  I was running an older Samsung TV and an older Sonos setup.  I decided to treat myself over the holidays and upgraded both - Samsung Frame TV and Sonos Arc + 2 surrounds.  I installed the Arc and the surrounds a few weeks ago and everything worked perfect with the older Samsung TV (using eArc as well, oddly).  Then yesterday finally got around to upgrading the TV and everything went to hell.  The sound cuts out every few seconds and I’ve tried changing all the settings to no avail.  Now that I see what a widespread problem this is, it’s nuts.  I’m going to try what Nzd31155 just suggested and see if that works.

 

if the ‘check for updates’ is greyed out - quite the apps so you’re just on normal tv - that took me 20 mins to work out!

Welp, I tried this but unfortunately it didn’t work for me.  Interestingly, the TV says there are ‘no updates available’.  But, if you go on the website, you can clearly get a newer version of firmware.  So, I downloaded it and installed it into the box (pretty easy to do).  Then I plugged everything in and it worked great!  Then I cycled the TV and it went right back to the way it was - sound cutting out every other second :(

Ah man sorry to hear that. It’s ultra frustrating right. 

I’ve had the same issue with my 2020 Frame and Sonos Arc, have worked with both Sonos and Samsung, and Samsung Care has been to the house twice and will be back again on Friday. Attempted a new one box, didn’t work, bu they’re saying something similar to Nzd31155. 

The 1460 updates available on the Samsung website are not the most up-to-date updates. There is (supposedly) a newer update (only currently available through the Samsung tech dept) that fixes this issue, and Samsung Care is coming back to our house on Friday to install.

I’ll report back on how it works.

 

Fingers crossed it fixes.  Over the last week using a smart plug power cycling both the TV & Sonos in the night I’ve not had another issue on the HDMI-eArc/ HDMI switching.  Would prefer the software to work but this interim is working for the moment.

This is a work around that works for me when the Sound shut off and on every few seconds

From TV > Setting > Sound > Expert Sertings.

In this page, perform the folowing:

1. HDMI-eARC Mode > Off

2. Dolby Atmos Compatibility > Unchecked

One you are done these steps, the sound should be on. However, we are not in HDMI-eARC and Dolby Atmos.

To turn the Dolby Atmos and HDMI-eARC, follow the exact order:

From TV > Setting > Sound > Expert Sertings. 

In this page, perform the following steps

1. Dolby Atmos Compatibility > Checked

Wait for about 10 seconds

2. HDMI-eARC Mode > Auto

After complete these steps, the sound should be on with Dolby Atmos and HDMI-eARC.

This solution does not fix the issue permanently. It might come back the next day. Then you have do these steps over again. 

My system configuration

The Frame 50 Inch, Firmware 1460

ARC, Sub (3rd), One SL.Firmware: Latest

I am hoping this is true: in a Samsung forum for this same issue, a user posted that Samsung Support said a fix should be coming in the March Update.

https://eu.community.samsung.com/t5/tv/sound-cutting-out-intermittently-on-2020-frame-tv-with-connected/td-p/2302114

Quick update.  I’ve been using the Arcana HDFury for 5 days now and everything’s worked perfectly since I installed it.  If you don’t mind spending the money, it’s a good solution.  Still looking forward to the fix though.

Today my Samsung Frame auto updated to 1460.9 so I went to the samsung website and can see there is a new file posted: version 1461.0. (I may give that a try this weekend to see if it has the fix)  

Userlevel 3
Badge +2

Today my Samsung Frame auto updated to 1460.9 so I went to the samsung website and can see there is a new file posted: version 1461.0. (I may give that a try this weekend to see if it has the fix)  


Do you have a link? I just checked and don’t see it on their site

refreshing this thread and the samsung website every hour.
have the same issue with a frame 2020. only solution at the moment is restarting the arc by unplugging the power cord.
 

This is a work around that works for me when the Sound shut off and on every few seconds

From TV > Setting > Sound > Expert Sertings.

In this page, perform the folowing:

1. HDMI-eARC Mode > Off

2. Dolby Atmos Compatibility > Unchecked

One you are done these steps, the sound should be on. However, we are not in HDMI-eARC and Dolby Atmos.

To turn the Dolby Atmos and HDMI-eARC, follow the exact order:

From TV > Setting > Sound > Expert Sertings. 

In this page, perform the following steps

1. Dolby Atmos Compatibility > Checked

Wait for about 10 seconds

2. HDMI-eARC Mode > Auto

After complete these steps, the sound should be on with Dolby Atmos and HDMI-eARC.

This solution does not fix the issue permanently. It might come back the next day. Then you have do these steps over again. 

My system configuration

The Frame 50 Inch, Firmware 1460

ARC, Sub (3rd), One SL.Firmware: Latest

Ok - update from my previous post - the updates from Samsung did not work. The tech literally told me to “keep playing with it and hope that they fix the issue soon.”

I have found a workaround similar to what I’ve reposted above. 

First, I have HDMI e-arc set to off, always. 
 

Second, when the sound messes up, I check or uncheck the Dolby Atmos Capability button and the sound comes back. It doesn’t matter on my tv whether Dolby Atmos Capability is on or off. If the sound is messing up, I simply click that option, and the sound comes back. 
 

I hope this helps. 

Userlevel 1
Badge +1

A quick update: I had a phone call with a Sonos support agent.

They confirmed that:

  • It is a known issue and they are very well aware of it. Right now it has a quite high priority (but not sure to what extend).
  • They are in contact with Samsung. Sonos engineers is saying that the issue is on Samsung side: they haven’t implemented the eARC specification in compliance
  • Sonos engineering team is working on a workaround/hotfix. No timeline yet, but the agent told me that he would have some updates soon. I’ll reach back to him in 1-2 weeks and see the progress.

Please take some time to create a support ticket on Samsung side so that our issue is raised and prioritized properly.

Thanks!

 

inewsial, do you have any news from your tech guy ?

Thanks,

Hi all,

I’m having the exact same problems, own a 65” Frame (2020) and the Arc

 

sonos said there wasn’t an issue. I referred them to this thread

 

Userlevel 1
Badge +1

It seems like there will be an update for the newer Samsung TV’s (including The Frame) in late February or early March. I think Samsung (from what I can read) have acknowledged the issue is on their side as they didn’t comply with the eARC implementation.

Not sure if this is hardware or software related. I certainly hope this is only software related.

Hi all,

A quick note from our dev team:

We are aware and monitoring an issue when connecting Sonos Arc to late model Samsung TVs via eARC. We are working closely with Samsung to resolve this and will share more as available.

All the best,

Ditte

I’m still having this same issue. I’m tired of contacting customer support and going through the same troubleshooting steps. It’s obviously a problem for everyone that has this setup and very frustrating that four months later, there is still no fix

I too am having the exact same problems. I own a 65” Frame (2020) and the Arc. 

Looking forward to an update. 

Userlevel 5
Badge +9

Hi all, yet another note from the dev team:

We have been working on the ongoing audio problem between the Sonos Arc and several 2020 Samsung TV models. These models support the new eARC connectivity. Samsung TVs prior to and from 2019 do not support eARC and are not seeing this particular problem. Customers will randomly experience a complete loss of audio which requires either the rebooting of the Sonos Arc and/or the rebooting of the Samsung TV. 

If you are experiencing this problem and you are willing to assist with some short term testing, please contact our customer care department at your earliest convenience.

Best,

Ditte

Badge

Here to help. Message me for contact info. 

Just to update you on my fix in previous post on this thread.  Setting up a Kasa smart plug to power cycle the Sonos arc (every night at 2am) has worked faultlessly since.  No unplugging cables or switching settings.  

User impact = 0 which is what we are all after.  I’ve got the TV set to auto update its firmware so hopefully when a new release is pushed out we can use the plug elsewhere….

good luck!

Thanks Ditte!  Believe it or not, I just went ahead and returned my Frame TV since it was still in the return window (and they just announced the 2021 model will be half as thick).  Sorry I can’t help but appreciate Sonos’ attention on this!

Hi all, yet another note from the dev team:

We have been working on the ongoing audio problem between the Sonos Arc and several 2020 Samsung TV models. These models support the new eARC connectivity. Samsung TVs prior to and from 2019 do not support eARC and are not seeing this particular problem. Customers will randomly experience a complete loss of audio which requires either the rebooting of the Sonos Arc and/or the rebooting of the Samsung TV. 

If you are experiencing this problem and you are willing to assist with some short term testing, please contact our customer care department at your earliest convenience.

Best,

Ditte

I would love to help on this but what is the best way? Last time I reached out to customer care they were unaware of the issue. 

Happy to help as well.  Same issue with 2020 75” frame and Sonos arc.  I too have a WiFi controlled power bar to cycle power to the Sonos arc.   Power bar brand is Gosund. Allows the power cycles to be scheduled or recycled manually from iPhone app.  

Badge

Just to update you on my fix in previous post on this thread.  Setting up a Kasa smart plug to power cycle the Sonos arc (every night at 2am) has worked faultlessly since.  No unplugging cables or switching settings.  

User impact = 0 which is what we are all after.  I’ve got the TV set to auto update its firmware so hopefully when a new release is pushed out we can use the plug elsewhere….

good luck!

Thanks for the tip - I missed that one. Can you share what model you used (or does it matter) 

Happy to help also message me for contact details. 

Userlevel 1

Hi all, yet another note from the dev team:

We have been working on the ongoing audio problem between the Sonos Arc and several 2020 Samsung TV models. These models support the new eARC connectivity. Samsung TVs prior to and from 2019 do not support eARC and are not seeing this particular problem. Customers will randomly experience a complete loss of audio which requires either the rebooting of the Sonos Arc and/or the rebooting of the Samsung TV. 

If you are experiencing this problem and you are willing to assist with some short term testing, please contact our customer care department at your earliest convenience.

Best,

Ditte

Your team have put a patch on my arc already so I am now on build ending in 070, I have had no issues since the patch was uploaded last week but I am aware this is only a temporary fix , the support guy I have been dealing with (Paul) has said he would like me to be on the beta testing program, so happy to help 

There is another thread with the same topic. after the post from doug74 i talked to the sonos support (germany) and they told me, that they will submit to my arc aswell as soon as possible. so fingers crossed, that this will fix the arc issues.

its really just a hotfix and not proper firmware update. lets hope that samsung is fixing the issue on their side soon

Reply