Question

Remote Suddenly Not Working on Samsung TV


Hi,

I am aware that there are multiple Samsung remote issues on these forums, but I believe mine may be distinct. Last night, my Beam suddenly stopped working w/ the Samsung TV. After factory resetting the beam, unplugging the TV for 60 seconds, and then setting everything up anew, it is working again. However, starting tonight, my remote (similar to the one pictured here) won’t control the TV volume (though the Sonos app will). This had worked fine for months and even did last night after I redid the setup. What’s especially strange is that when I hit volume up/down/mute on the remote, the normal popup that an “HDMI” volume change is underway pops up on the screen, so it is receiving some command, the volume just never changes. Any ideas?

Thank you for your help.


13 replies

@dum_surfer Thank you for bringing your concerns to us here and welcome to the Sonos Community. If I understand what you are saying/asking is that your Samsung One remote controls the volume to the Sonos Beam but not the Samsung TV and you are still getting a TV message that volume is changing? If yes, then this is something within the TV settings you would have to go in and disable that messaging feature of the TV. You have programmed the Samsung One remote to control the Beam’s volume as you now have the TV speakers disabled to pass the audio to the Beam with the HDMI Arc port.

Due to the TV speakers being disabled you will have to correct the TV setting that puts that prompt on the TV screen as it is still seeing the remote signal going to the Beam for volume change. That messaging is not for the Beam’s volume. I would also point out for future reference to avoid doing a factory reset on Sonos products as troubleshooting steps unless directed in a phone call, email or social media reply as that typically does not fix an issue.

Have you found a solution to this? I couldn’t figure out how to get my remote working, but then realised that for some reason the remote only works to control the Sonos Arc when the tv is off. I have a 2020 Samsung with One Remote, which is RF and not IR. You can only pair the remote with the Arc when the TV is off, then when you turn the TV back on, both are rendered useless as you can’t adjust the volume. Can’t figure it out at the moment so have just turn off the IR on the Arc so at least I can control the volume of the Arc through my TV when the TV is on. Would love to be able to also control volume when I’m airplaying music etc. hopefully somebody out there has a fix.

@Realtonytones Thank you for reaching out us and welcome to the Sonos Community. I am not sure what you mean when you say if there is a solution? We only setup a with a TV remote that is Infrared (IR) and the Samsung One remote is default Bluetooth (RF). If you have tried the setup steps in our FAQ article then you will need to speak with Samsung about this. If you confirmed that nothing is interfering/blocking the IR sensor and tried another IR remote along with limiting the natural light in the room. You will need to speak with same Samsung to confirm their remote is converting to IR and then attempt the remote setup.

When it comes to seeing a left over message on the TV screen for the volume, that is a display option of the TV that needs to be adjusted. The TV is still getting a signal from the remote and displays what the TV’s volume would be if the TV’s speakers were still active.

Hi,

i have an Samsung TV, with a Remote one -universal Remote.

my Playbar suddenly stopped working w/ the Samsung TV. when I hit volume up/down/mute on the remote, the normal popup that an “Optisk” volume change is underway pops up on the screen, so it is receiving some command, the volume just never changes. Any ideas?

Thank you for your help

I had the same issue with my Samsung one source ARC not communicating with my Sonos beam after several months of working it just stopped. I could not get the audio to the sonos. I tried unplugging everything and starting from scratch as some have suggested but to no avail. I had been using the HDMI cable that came with the beam but when the sonos app updated to sonos 2 app everything stopped broadcasting from TV to sonos. I finally bought a new HDMI 4K rocketfish Premium cable and reset it and now it is working fine. So you all out there struggling just get a new HDMI 4K good quality from Best Buy and you will be all set.

try going to the sonos app and adjust the volume up or down this might reset it. You also need to finally log away from the app controlling the TV. This can be tricky.

Hi

i have 3 remotes that all control my Samsung TV. The standard Samsung remote, amazon fire tv remote and a Sky Q remote. All three previously controlled the volume on my theatre sound (beam and two ONES). Now, all of a sudden, all 3 have stopped controlling the volume on the Sonos system. 
ive tested all 3 remotes by reactivating the tv speaker and controlling the volume as they should. 
when I deactivate the tv speaker and activate audio out/optical (Sonos system) the remotes no longer work. 
When I press a volume button, it’s recognised by the tv (it shows an icon for audio out/optical) but the volume doesn’t change.

The Sonos bean is connected via the optical cable not an arc as I didn’t have enough hdmi slots available. However, it’s always been this way so I see no reason why this should have happened all of a sudden. Does anyone have an idea of how to fix this? 
 

Badge

Same problem.  Still need to use my iphone to control volume.  Always used only the one Samsung remote to control volume and everything worked fine until the app update a month ago.

If I try to setup my remote within the Sonos App, it asks me to press the volume up on the remote.  I do, and even though no light flashes on the soundbar, it recognizes me pressing the button.  It then asks me to press the volume up button 3 times but then I do, this time no light flashes on the soundbar, and then the app says I didn’t press any button (but the light flashs all 3 times when I press the up button).  There has been 2 updates within the last month, but nothing helps.   When I upgraded the app last month, the nightmares began.

 

Did you resolve your problem?

No nothing seems to have worked and I’ve not had any replies from Sonos on any of the platforms they provide. 

Badge

I called and asked for my problem to be escalated to the Sonos Technical Support Callback team.  They are scheduled to call me on 8/27 @3PM EST.

I’m still using my iphone to control the volume, or stand about 3 feet from the playbar.

Same. The app is the only option. Let me know how you get on with them. 

Badge

After our discussion, here is what Patrick from Sonos said:

“The IR commands are not hitting the Playbar from the One Remote, the range should not be a factor, however when you go to teach out device the IR commands, it fails.  If you are right on the unit (within 3 feet, it works). 

For that, I would reach out to Samsung and see if they can program the remote to output IR and have third party optical connected sound bars pick up on it.  Might also be work a try setting the home theater device to Onkyo, Pioneer, anything besides Samsung and Sonos.  Then re-learn the remote programming through Sonos.2”.

I finally got mine to work following Patrick’s advice!  On your TV’s setup, If you go to “Source”, “Universal Remote”, and select Panasonic it works after you go to the Sonos app and replace your remote setup.

I called Samsung and didn’t get anywhere.  They asked for my personal info: Name, Address, Phone, email, serial no, and then put me on hold.  She came back and said there are no reported issues.  I asked to have my issue reported into their system in hopes others will report this problem as well then perhaps they might address this problem.  She put me on hold, and after ½ Hr.  I hung up.

I believe this problem stems from the last Samsung update and hope their next update resolves this problem.

Thank you Patrick from Sonos!  He’s a tremendous asset to Sonos and our community!

 

Larry

 

That’s great Larry

Very strangely mine simply started working again, no update, no change in settings. Just randomly started working again. 
Very bizarre 

Reply