PS4 Pro outputting PCM via LG CX shows Multichannel PCM 7.1 for Sonos Arc, but rear surrounds have no audio

  • 14 November 2020
  • 45 replies
  • 5984 views

Userlevel 2
Badge

I have the Arc, Sub, and Sonos 1 in a surround setup, connected to an LG CX via eArc. Previously I had the PS4 outputting Bitstream (Dolby), and Sonos reported Dolby Digital 5.1.

The fix that added LPCM to Sonos Arc recently went live, so I updated PS4 Pro to output PCM, and the HDMI input on the TV to PCM. (The output remained Passthrough). After doing this, the System Status page for Sonos shows Multichannel PCM 7.1.

However, I now get no rear surround audio in games like Assassin’s Creed Valhalla. (It’s not faint, there’s really none.) I get the full surround experience if I change it back to getting Dolby Digital 5.1. On the PS4 Home screen, I do get sound from the rears in PCM 7.1, albeit very faintly, compared to Dolby Digital 5.1.

Does Sonos not downmix the extra channels properly? It’s kinda bad that a higher fidelity signal sounds worse.


45 replies

Userlevel 2
Badge

So, it looks like this might be the reason: https://en.community.sonos.com/home-theater-228993/lpcm-eta-for-arc-6842558?postid=16488286#post16488286

 

TL:DR, it looks like LPCM 7.1 is downmixed incorrectly with side channels coming out the rear and rear channels not coming out at all. Back to Dolby Bitstream it is. (And back to having to switch modes between Atmos and non-Atmos on Apple TV 4k too.) Sigh.

 

I know Sonos doesn’t do ETAs, but can we at least get an official acknowledgement of this problem?

Userlevel 1
Badge +1

Yeah, something is definitely wrong with the channels on Multichannel PCM. Sound coming out the wrong channels or not at all.

Userlevel 4
Badge +6

So, it looks like this might be the reason: https://en.community.sonos.com/home-theater-228993/lpcm-eta-for-arc-6842558?postid=16488286#post16488286

 

TL:DR, it looks like LPCM 7.1 is downmixed incorrectly with side channels coming out the rear and rear channels not coming out at all. Back to Dolby Bitstream it is. (And back to having to switch modes between Atmos and non-Atmos on Apple TV 4k too.) Sigh.

 

I know Sonos doesn’t do ETAs, but can we at least get an official acknowledgement of this problem?


can you make the PS4 output lpcm 5.? 


When I first started the ps5 it was set to “TV sound” lpcm 7.1 and while the number of channels can be changed it was greyed out. I changed the output type to “AV Receiver” and then it let me change the channel to 5.1. After doing that I confirmed in the Sonos app that the Arc was getting “Multichannel 5.1”. After doing this the sound output is correct.

 

Unfortunately i no longer have a PS4 to test but hopefully it has the same options.

 

Ive also got a PC and Nintendo Switch. The Switch asked me if I'd like 5.1 or 7.1 so I selected 5.1. The PC was a little tricky, on the PC I can output Lpcm or Atmos but it was defaulting to 7.1.2 or 7.1 for both - I found an option in Windows that let me disabled the SR and LR channel so now the PC outputs 5.1.2 or 5.1 only 

I am having this same issue on the PS5.  I tried selecting the PS5 option of connecting to an AV receiver and using a 5.1 setup but I am still missing audio channels.  Anyone know what the exact issue is?

Userlevel 4
Badge +6

For those having issues with the LG CX outputting MultiChannel 7.1 to the Sonos ARC, have you tried changing the sound output to Auto instead of passthrough? This fixed the issue and changed it to Multichannel 5.1 for me.

Userlevel 4
Badge +6

I have the Arc, Sub, and Sonos 1 in a surround setup, connected to an LG CX via eArc. Previously I had the PS4 outputting Bitstream (Dolby), and Sonos reported Dolby Digital 5.1.

The fix that added LPCM to Sonos Arc recently went live, so I updated PS4 Pro to output PCM, and the HDMI input on the TV to PCM. (The output remained Passthrough). After doing this, the System Status page for Sonos shows Multichannel PCM 7.1.

However, I now get no rear surround audio in games like Assassin’s Creed Valhalla. (It’s not faint, there’s really none.) I get the full surround experience if I change it back to getting Dolby Digital 5.1. On the PS4 Home screen, I do get sound from the rears in PCM 7.1, albeit very faintly, compared to Dolby Digital 5.1.

Does Sonos not downmix the extra channels properly? It’s kinda bad that a higher fidelity signal sounds worse.

It’s counterintuitive but leave the PS4 Pro/PS5 on PCM and change the HDMI Input on the TV to bitstream and the output to Auto. This fixed the issue for me.

Userlevel 1
Badge +1

For those having issues with the LG CX outputting MultiChannel 7.1 to the Sonos ARC, have you tried changing the sound output to Auto instead of passthrough? This fixed the issue and changed it to Multichannel 5.1 for me.

Changing it to Auto changes the output to Dolby Multi-channel PCM 5.1, which is not the same as Multichannel PCM (LPCM)  as far as I know.

Userlevel 4
Badge +6

For those having issues with the LG CX outputting MultiChannel 7.1 to the Sonos ARC, have you tried changing the sound output to Auto instead of passthrough? This fixed the issue and changed it to Multichannel 5.1 for me.

Changing it to Auto changes the output to Dolby Multi-channel PCM 5.1, which is not the same as Multichannel PCM (LPCM)  as far as I know.

 

It shows in the Sonos App as Multichannel PCM 5.1 when playing Dolby 5.1 content and shows as Dolby Atmos when playing Atmos content (Not DD+ Atmos). From my understanding this is what you would expect to see, since Sonos doesn’t do 7.1.

Userlevel 1
Badge +1

For those having issues with the LG CX outputting MultiChannel 7.1 to the Sonos ARC, have you tried changing the sound output to Auto instead of passthrough? This fixed the issue and changed it to Multichannel 5.1 for me.

Changing it to Auto changes the output to Dolby Multi-channel PCM 5.1, which is not the same as Multichannel PCM (LPCM)  as far as I know.

 

It shows in the Sonos App as Multichannel PCM 5.1 when playing Dolby 5.1 content and shows as Dolby Atmos when playing Atmos content (Not DD+ Atmos). From my understanding this is what you would expect to see, since Sonos doesn’t do 7.1.

Ok that is nice, unfortunately not in my case. I’m using an Apple TV 4K and not a PS4 so perhaps there is a difference there. Have to do some more experimenting. 

Userlevel 4
Badge +6

For those having issues with the LG CX outputting MultiChannel 7.1 to the Sonos ARC, have you tried changing the sound output to Auto instead of passthrough? This fixed the issue and changed it to Multichannel 5.1 for me.

Changing it to Auto changes the output to Dolby Multi-channel PCM 5.1, which is not the same as Multichannel PCM (LPCM)  as far as I know.

 

It shows in the Sonos App as Multichannel PCM 5.1 when playing Dolby 5.1 content and shows as Dolby Atmos when playing Atmos content (Not DD+ Atmos). From my understanding this is what you would expect to see, since Sonos doesn’t do 7.1.

Ok that is nice, unfortunately not in my case. I’m using an Apple TV 4K and not a PS4 so perhaps there is a difference there. Have to do some more experimenting. 

I’m using an Apple TV 4K as well at the moment on an LG CX and getting these results. I’ve left the Apple TV on Auto, Atmos Available for Audio and I have set HDMI Input Audio on the TV to Bitstream and Audio Output to Auto. It’s really weird how so many of us are getting different results.

Userlevel 1
Badge +1

For those having issues with the LG CX outputting MultiChannel 7.1 to the Sonos ARC, have you tried changing the sound output to Auto instead of passthrough? This fixed the issue and changed it to Multichannel 5.1 for me.

Changing it to Auto changes the output to Dolby Multi-channel PCM 5.1, which is not the same as Multichannel PCM (LPCM)  as far as I know.

 

It shows in the Sonos App as Multichannel PCM 5.1 when playing Dolby 5.1 content and shows as Dolby Atmos when playing Atmos content (Not DD+ Atmos). From my understanding this is what you would expect to see, since Sonos doesn’t do 7.1.

Ok that is nice, unfortunately not in my case. I’m using an Apple TV 4K and not a PS4 so perhaps there is a difference there. Have to do some more experimenting. 

I’m using an Apple TV 4K as well at the moment on an LG CX and getting these results. I’ve left the Apple TV on Auto, Atmos Available for Audio and I have set HDMI Input Audio on the TV to Bitstream and Audio Output to Auto. It’s really weird how so many of us are getting different results.

Yes extremely weird. What is your source? I’m playing a blu-ray rip with DTS-HD 5.1 with Infuse. But I get the same with all Non-Atmos content from Netflix. I get Atmos with Netflix Atmos content. Below is what I get with audio output on Auto

 

 

Userlevel 4
Badge +6

I am having this same issue on the PS5.  I tried selecting the PS5 option of connecting to an AV receiver and using a 5.1 setup but I am still missing audio channels.  Anyone know what the exact issue is?

 

Strange, I need to double check my settings but off the top of my head my LG OLED is set to passthrough and PS5 set to Output Type: AV Amplifier, Audio Type: LPCM, Channel setup: 5.1

Userlevel 2
Badge

So, it looks like this might be the reason: https://en.community.sonos.com/home-theater-228993/lpcm-eta-for-arc-6842558?postid=16488286#post16488286

 

TL:DR, it looks like LPCM 7.1 is downmixed incorrectly with side channels coming out the rear and rear channels not coming out at all. Back to Dolby Bitstream it is. (And back to having to switch modes between Atmos and non-Atmos on Apple TV 4k too.) Sigh.

 

I know Sonos doesn’t do ETAs, but can we at least get an official acknowledgement of this problem?


can you make the PS4 output lpcm 5.? 

 

Unfortunately not. The only options on the PS4 Pro are Linear PCM, Bitstream (Dolby), and Bitstream (DTS). It’s cool you can choose 5.1 or 7.1 on the Switch, and cool that there’s a PS5 option to make it send the right thing too.

For the AppleTV, changing the CX to output Auto instead of Passthrough sends “Dolby Multichannel PCM 5.1”, which is subtly different from “Multichannel PCM 5.1”, in that it’s somewhat compressed. I don’t know that I would personally be able to tell the difference between those, but as others have said, if you want uncompressed best-quality sound from Blurays, you need the CX to use Passthrough.

Regardless, Sonos will tell you if it’s receiving a signal it can’t process, like DTS. Seeing as it’s receiving a Multichannel 7.1 signal, and not telling me it can’t process it, I would consider sending sound out of the wrong speakers a bug 😂

 

 

 

 

Userlevel 4
Badge +6

 

Ive also got a PC and Nintendo Switch. The Switch asked me if I'd like 5.1 or 7.1 so I selected 5.1. The PC was a little tricky, on the PC I can output Lpcm or Atmos but it was defaulting to 7.1.2 or 7.1 for both - I found an option in Windows that let me disabled the SR and LR channel so now the PC outputs 5.1.2 or 5.1 only 

I’ve seen you mention this, but no-one else (Myself included) has been able to do it. The Nintendo Switch only gives an option for TV Sound Output of Surround, Auto or Stereo. You cannot choose 5.1 or 7.1 on the Switch.

If you somehow know a way, please teach the rest of us.

Userlevel 2
Badge

LG CX and PS5 with Sonos Arc here. I’m using the settings below and getting some pretty solid sound with Dolby Multichannel PCM 5.1. So far any other setting results in Stereo PCM 2.0 and sounds worse. I know it’s not LPCM, but so far I can’t get anything else to work.

 

LG CX:

HDMI Input Audio Format: Bitstream

Digital Sound Out: Auto

PS5: 

Audio Format (Priority): Bitstream (Dolby)

HDMI Device Type: AV Ampoifier

Number of Channels: 5.1ch

 

 

Userlevel 4
Badge +6

LG CX and PS5 with Sonos Arc here. I’m using the settings below and getting some pretty solid sound with Dolby Multichannel PCM 5.1. So far any other setting results in Stereo PCM 2.0 and sounds worse. I know it’s not LPCM, but so far I can’t get anything else to work.

 

LG CX:

HDMI Input Audio Format: Bitstream

Digital Sound Out: Auto

PS5: 

Audio Format (Priority): Bitstream (Dolby)

HDMI Device Type: AV Ampoifier

Number of Channels: 5.1ch

 

 

The thing is Sonos clearly needs to fix a few bugs here. First of all there is no such thing as Dolby Multichannel PCM 5.1, so they need to work out why the Sonos Arc reports it as this.

It’s also clear that there is some kind of handshaking issue between LG TV’s and the Sonos Arc where it’s telling the TV it can process LPCM 7.1 but then not downmixing it properly to 5.1.

Userlevel 2
Badge

Update from Sonos’ CEO on Twitter that they’re working on it:

 

https://twitter.com/Patrick_Spence/status/1334844832871682049?s=20

Userlevel 4
Badge +10

Update from Sonos’ CEO on Twitter that they’re working on it:

 

https://twitter.com/Patrick_Spence/status/1334844832871682049?s=20

Brilliant, this fixed along with the drop outs fixed will be all I want for Christmas:wink:

I have a different “issue” I’m not sure it’s an issue I never had the LPCM 7.1 but mine always reports 5.1 multichannel on the PS4 and when I turn a character around like in resident evil 2 remake and there’s water dropping it’s coming out from all channels, BUT on the settings on the TV the LG C9 I have the output to Bitstream, if I put to PCM I only get PCM 2.0 on the PS4….it’s weird if my TV is set to bitstream I can set everything to hdmi and PCM on the PS4 and get 5.1 audio I never got any option for 7.1, which is correct, but it changes it to 2.0 if I select PCM on the TV settings no matter if I set it to auto or passthrough I have the same thing

Userlevel 4
Badge +6

I have a different “issue” I’m not sure it’s an issue I never had the LPCM 7.1 but mine always reports 5.1 multichannel on the PS4 and when I turn a character around like in resident evil 2 remake and there’s water dropping it’s coming out from all channels, BUT on the settings on the TV the LG C9 I have the output to Bitstream, if I put to PCM I only get PCM 2.0 on the PS4….it’s weird if my TV is set to bitstream I can set everything to hdmi and PCM on the PS4 and get 5.1 audio I never got any option for 7.1, which is correct, but it changes it to 2.0 if I select PCM on the TV settings no matter if I set it to auto or passthrough I have the same thing


do you have any other games to test? With water the sound can sometimes come out all around you if that's what the developer intended, especially if the source of water is from a roof/fixture/waterfall that's above your characters head in the game. For example when it's a waterfall like in uncharted 4 you'll notice the sound everywhere if you stand close to the waterfall but if you stand far a enough away you only hear the sound based on your direction to the waterfall 

 

as for bitstream and pcm, use bitstream - as confusing as the names are, pcm is for 2.0 sound and bitstream is for higher quality surround audio 

I thought Multichannel PCM or LPCM was the better audio quality and that’s the new codec Sonos supports or maybe LPCM is different….as for the water it was coming specifically from a window and would only play on the channel I was facing that’s how I tested it, and yeah I tested it with horizon zero dawn and the last of us 2 to name a few

Userlevel 1
Badge +1

Still no LPCM improvement on my CX with the latest 03.21.09 fw gents

Userlevel 4
Badge +10

Still no LPCM improvement on my CX with the latest 03.21.09 fw gents

Isn't Sonos working on the fix?

 

A few posts above mentions this.

 

*I see you tweeted the CEO for an update.:thumbsup:

Userlevel 4
Badge +10

Any updates on this, they said they were aware of it at the beginning of December.

Userlevel 1

How long can it take to correct this bug?

In my believe it should be enough to correct the channel mapping in the ARC, which is obviously wrong at the moment. Shouldn’t that only be a matter of days??

Reply