Answered

Playbar stopped working with IR remotes

  • 24 September 2015
  • 9 replies
  • 4035 views

I've had a Playbar for the past 18 months, with the volume controlled by my Virgin Media Tivo remote. On Sunday the remote control stopped controlling the volume on the playbar, but works fine with the Tivo box. I changed the batteries and got no improvement.

I tried to re-pair the remote, and am unable to finish the process. The first stage of the pairing process where it asks me to press Vol+ will often say 'no input detected' after a split second, and I've not even done anything. Other times it will move forward to the 2nd stage after me hammering the Vol+ from 2 inches away. On the 2nd stage, it's hit and miss whether I can press the Vol+ button 3 times and get the white IR light to respond. HOWEVER, when I have successfully done that (and the light has flashed with each of the 3 presses), the next screen says "No input detected", even though it has to have detected something to switch to that screen!?!?

I have tried my Panasonic TV remote as well to no effect. Turning the TV off whilst trying this process results in a higher success rate of the white light, but still it doesn't pair. I've also noticed that sometimes opening the 'Setup IR remote' screen will just give me a blank screen, or it will not proceed to the next screen. I've also turned off/on the playbar and still get the same issue.

Nothing has changed in my room environment to suggest any sort of interference.

Can anyone suggest a fix? Feels to me that either the Playbar or the Sonos:Controller has developed a fault.
icon

Best answer by ratty 24 September 2015, 19:01

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Do you have any other Sonos units or is the PLAYBAR the only one?
Yes I have two Play1's in different rooms.
Are any of the units wired to your network?
The playbar is connected via ethernet, whilst the Play1's are connected wirelessly.
So the PLAYBAR's wired.

Okay, having had this IR issue before I found the only solution was to factory reset the PLAYBAR. However we're going to need to be careful about this, to avoid breaking your system in two.

Wire one of the PLAY:1s to your network (either as well as, or instead of, the PLAYBAR).
Power off the PLAYBAR and make sure a Sonos controller app can see and control the temporarily wired PLAY:1.
Power up the PLAYBAR whilst pressing the Mute button, and keep pressing until the LED starts to flash amber.
Release Mute and wait for the LED to flash green.
Using the Sonos controller app, add the PLAYBAR back to the system and go through set up. Hopefully the IR will now work.

(The "Mute" button is now "Play/Pause" so it may be labelled accordingly.)

You can then unwire the PLAY:1 and put it back where it belongs. If you unwired the PLAYBAR be sure to wire it again.
This worked! It didn't actually work with the Virgin Tivo remote, but it did with my Panasonic TV and Samsung from another room.

With the Tivo remote, it did register every Vol+, but then didn't succeed at the end. I programmed the tivo remote to control the samsung tv, and then I was easily able to pair with the Playbar.

I'm now thinking that the Tivo remote programming somehow got corrupted, or the Playbar did it. Anyway - all sorted.

Thanks for the help Ratty.🆒
I have a very similar problem. Been using a Playbar for over a year, and earlier this week, IR remote stopped working suddenly. Here is the remote I have https://support.sonos.com/s/article/3444?language=en_US

I did a reset of the Playbar and re-added it (it is the only Sonos device I own). When at the Add a Remote step, the volume up button is never registered and the app doesn't move past that step. I tried everything the OP attempted, with no success.

I am assuming my Playbar had a software update of some kind, and something broke? Really not sure where to go from here.
Have you replaced the batteries in the remote? If so, then I'd recommend that you contact Sonos to discuss it.
Yep, replaced the batteries. Remote works with the TV just fine. Thanks tho!

Anyone have any other ideas?