Answered

Pairing Bar with TCL Roku TV - Can't control sound

  • 18 September 2018
  • 9 replies
  • 8813 views

I connect my Sonos sound bar using optical cable to a TCL Roku TV. I can't get the tv remote to control the sound on the bar. I was able to do it with my previous Samsung TV. I tried the remote control settings in the sonos app but its not recognizing the remote when I asked to hit the volume + button. I also tried using an optical to HDMI (ARC) adapter that came with my beam (in the other room) and then adjusted the CEC settings on the tv, but it doesn't recognize the bar that way. Any suggestions?
icon

Best answer by AjTrek1 18 September 2018, 22:11

If you still have the Samsung remote try controlling the Playbar with it. If it does that means that the Playbar isn't learning the Roku remote and is still looking for the Samsung remote.

In any case I suggest you make sure you are using the latest Sonos App v9.1 If you are already using v9.1 then remove the Playbar from the room (as well as surrounds and sub) and add everything back as a new setup starting with the Playbar. Go thru the steps to program a remote.

If none of the above works...call the TCL support team (picture) an explain your situation. Do not attempt a factory reset unless you are told to do so by contacting Sonos Tech Support after you submit a diagnostic and post the Reference ID in this forum. Good Luck!

Cheers!

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Userlevel 7
There are two types of TCL Roku TV remotes:

1. IR
2. Enhanced (Connects over WiFi to to the Roku TV)

The latter most likely will not work with Sonos. Read more in the link > https://support.tclusa.com/20269-roku/259100-my-tcl-roku-tv-remote-control-is-not-working

Cheers!
Its def not #2. Any solutions with #1?
Userlevel 7
If you still have the Samsung remote try controlling the Playbar with it. If it does that means that the Playbar isn't learning the Roku remote and is still looking for the Samsung remote.

In any case I suggest you make sure you are using the latest Sonos App v9.1 If you are already using v9.1 then remove the Playbar from the room (as well as surrounds and sub) and add everything back as a new setup starting with the Playbar. Go thru the steps to program a remote.

If none of the above works...call the TCL support team (picture) an explain your situation. Do not attempt a factory reset unless you are told to do so by contacting Sonos Tech Support after you submit a diagnostic and post the Reference ID in this forum. Good Luck!

Cheers!

Buying a new remote is totally unnecessary. Simple fix. Make sure you have the latest software for the sonos app. Then open the app, and go to settings/room settings/select sonos sound bar/remote/remote control set up. Follow the prompts. I forget if I had to delete the existing remote first or just calibrate with the prompts. Either way it works fine now. BTW the TCL tech support people have no clue and said I needed an HDMI cable going into the sound bar. There isn’t even an audio out port using HDMI on their TV so that was bad information. The sonos tech support helped me in less than five minutes.
Buying a new remote is totally unnecessary. Simple fix. Make sure you have the latest software for the sonos app. Then open the app, and go to settings/room settings/select sonos sound bar/remote/remote control set up. Follow the prompts. I forget if I had to delete the existing remote first or just calibrate with the prompts. Either way it works fine now. BTW the TCL tech support people have no clue and said I needed an HDMI cable going into the sound bar. There isn’t even an audio out port using HDMI on their TV so that was bad information. The sonos tech support helped me in less than five minutes.
That doesn't work on my TCL Enhanced remote control
Thanks Nice Guy! Perfect answer (give him the credit please)

Make sure you have the latest software for the sonos app. Then open the app, and go to Settings/Room settings/select Sonos sound bar/remote/remote control set up. Follow the prompts.



Thanks, easy, just fixed this this morning without having to interrupt anyone’s viewing.

My TCL/Roku remote works great controlling the TV and Playbar volume with IR.

As expected, neither the Roku or Sonos app will do that job, controlling both, over WiFi.

TCL , roku and sonos are completely useless and tcl down right lied. The roku remote may start out as IR but will switch to wifi.  You cannot set up the remote in this mode as it will not sen out IR for sonos to read.  You may get it to set up once before it automatically switches to wifi but then it will stop sending IR and sonos wont read out any longer.  None of the companies know how to force the roku remote to just send IR.  You either by a cheap IR only remote or another brand that has roku built im


The TCL/ROKU remote continues to work controlling the TV & Playbar with the remote.   I can see it working on both when I press volume up or down and the volume number on the tv is shown and changes.   I also see the white light on the PlayBar blink with each press.   To get them to sync to zero, I press The down button until the TV reads 0 and then I continue Pressing down until the PlayBar is muted.

The remote controls both.

 

caveats:

the Sonos App will not control the TCL/Roku TV

the Roku App will not control the Sonos PlayBar