Answered

LG Magic Remote fails to register in SONOS app

  • 27 March 2018
  • 7 replies
  • 1530 views

Hello!

I recently upgraded my television to a newer model and so far everything has been pretty good!

I did unfortunately learn that the PLAYBAR does not support DTS which is unfortunate, but it still sounds great!

What isn't so great, is despite following the instructions in the LG magic remote setup page, I am unable to register the magic remote with the SONOS app on my iPhone!

I register a new remote, and press the volume + button, which is registered within the app.
Then it asks me to press the volume + button 3 times, which is registered within the app.
Then it asks me to press the volume - button 3 times, which is registered within the app.
Then it asks me to press the mute button 3 times, which the SONOS PLAYBAR will not recognize no matter what I do.

I believe the LG Magic Remote may have been updated and the SONOS speaker has not been configured to reflect that. The remote that came with my television is slightly different than the one pictured in the tutorial I linked above, and it's also worth noting that pressing the mute button three times on this remote calls up a "quick access" menu on the television. I believe the way the button has been encoded over bluetooth may have changed?

Regardless, there is no way to skip registering the mute button, and thus I am incapable of having the SONOS finalize registration of this remote and I am forced to use my phone to alter the volume, which is a pretty big frustration.

Is this a common problem or have I missed something here?
Thanks for your help!
icon

Best answer by AjTrek1 27 March 2018, 20:45

OK..Seal...

I've seen the solution below posted twice in the community by different individuals_seems to work: :?

Part 1:
1) click the home button on your magic remote and scroll along the bottom (where Netflix, etc is) until you get to a purple icon "device connector"
2) select soundbar and pick the Phillips brand and select remote type 4
3) Select done


Part 2:
1) Open the Sonos app on your iPad or phone
2) select the gear icon "settings"
3) select the room your system is in
4) select TV setup and control
5) select remote control set up and follow the prompts using your "Phillips" magic remote


Good Luck...Cheers!
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7
Badge +22
Hi Seal

Have you tired this:



Cheers!
Hello AjTrek1!
I did indeed disable that option and attempted the registration process again, and the exact same steps as above took place.
It may be best for you to call Sonos to discuss it. They can probably give you more support in realtime than we can in "forum time".
Userlevel 7
Badge +22
OK..Seal...

I've seen the solution below posted twice in the community by different individuals_seems to work: :?

Part 1:
1) click the home button on your magic remote and scroll along the bottom (where Netflix, etc is) until you get to a purple icon "device connector"
2) select soundbar and pick the Phillips brand and select remote type 4
3) Select done


Part 2:
1) Open the Sonos app on your iPad or phone
2) select the gear icon "settings"
3) select the room your system is in
4) select TV setup and control
5) select remote control set up and follow the prompts using your "Phillips" magic remote


Good Luck...Cheers!
This last solution worked!
The volume shift is a little bit slow but it's functional and comes through the remote!
Thank you for your help!
Worked for me too. Thanks very much. I was on the verge of sending the sounbase back for a refund...
this youtube video is consistent with most of the above answers and easy to follow -- https://www.youtube.com/watch?v=0qLeA5ShPFI