Issues with getting SURROUND SOUND TO PLAY DOLBY ATMOS. I keeping getting PCM 2.0

  • 10 January 2022
  • 32 replies
  • 1393 views

Badge

I currently have a surround set up with the Sonos Arc and two SL ones and gen. 3 subwoofer. When I’m playing a movie with Dolby Atmos it is not showing in the sonos app that its  coming through as Dolby Atmos. Instead it is showing pcm 2.0.. I have my system playing through a Samsung QLED Tv model Q80 . This is driving me nuts!!! Any suggestions would ge appreciated! 


32 replies

Userlevel 7

What specific content have you tested and from what apps? Are you using the TV’s native apps or an external media device? Can you post photos of the TV’s current audio settings?

On some services Atmos is only available when using the most premium service tier.

And with very limited content, as well. 

Badge

The content I’ve been trying is Disney + , Netflix , amazon prime. 

Badge

I will post some pics of my sound settings on my tv. 

Badge

Here are pics of my settings and options in my sound menu on the TV . 

 

I’m not familiar with this specific TV. Many TV’s need eARC enabled before high bandwidth audio (Atmos and others) will be sent.

Badge

I’ve tried enabling eArc on my Samsung Q80 (Qled) but ot still does not transmit Dolby Atmos. They recommend that you turn off the eArc which makes no sense to me. 

Userlevel 6
Badge +9

If you are streaming most of your content it is in dd+ lossy atmos 

You do not need earc for dd+ arc will work ok for all streaming content 

Badge

So I’m assuming that I will only get pcm 2.0 when I’m streaming a movie that has Dolby Atmos capabilities? 

Userlevel 6
Badge +9

I do not use Samsung but my lgb8 tv plays dolby atmos (dd+) from Amazon Netflix and Disney +

I do not have earc just arc I am streaming from all sources on an apple tv 

As i said before it is not dolby atmos lossless as streaming services do not stream in full atmos just dd+

Userlevel 6
Badge +9

 

Userlevel 6
Badge +9

A screenshot of what I get from guardians of the galaxy 

Userlevel 7

Is the Pass-Through option greyed out? If you set HDMI eARC to Auto, can you select Pass-Through? If not, try playing The Tomorrow War on Prime Video, and while it is playing, check if the Pass-Through option is available.

Are you using the HDMI cable that came with the Arc?

Badge

I am able to select the Pass through option but that has not worked. I upgraded my HDMI cable. 

Badge

Is it absolutely necessary to use the HDMI cable that with Sonos ARC? 

Userlevel 7

I am able to select the Pass through option but that has not worked. I upgraded my HDMI cable. 

Use the cable that came with the Arc.

Userlevel 7
Badge +22

Is it absolutely necessary to use the HDMI cable that with Sonos ARC? 

To verify it works? Yes. Using another cable just adds another possible problem to the mix. Of which there are many with getting Atmos playback to work. Once it works with their cable, THEN you can try a random 3rd party cable

Yes, you must use an HDMI cable for Atmos.

Badge

Alright I tried using the HDMI cable that came with the Sonos ARC and still nothing. I tried playing The Tomorrow War movie from Amazon Prime and still showing PCM 2.0 on my sonos app. I even tried switching the sound setting to pass-through and nothing. I’m running out of ideas any more thoughts? 

Userlevel 7

Alright I tried using the HDMI cable that came with the Sonos ARC and still nothing. I tried playing The Tomorrow War movie from Amazon Prime and still showing PCM 2.0 on my sonos app. I even tried switching the sound setting to pass-through and nothing. I’m running out of ideas any more thoughts? 

Very odd. At the very least you should be getting Dolby Digital Plus audio.

Try this:

First, make sure the TV has the latest firmware installed. Then disconnect everything from the TV including the Arc. Unplug the TV and Arc from power for a couple of minutes. Plug them both back in but keep everything disconnected. Make sure Anynet+ (CEC) is enabled on your TV. Then run TV Setup in the Sonos app. When the app instructs you to, connect the Arc to the TV’s HDMI ARC (HDMI 3) port using the Sonos-supplied HDMI cable. When the Arc has been successfully connected, connect any other device you have to the TV. Set eARC to Auto and Digital Output Audio to Pass-Through (or Auto) and test again.

Badge

Thank you! I’ll try that tonight. 

Userlevel 7
Badge +22

rtings.com says “ The Samsung Q80A supports Dolby audio formats, including Dolby Atmos via TrueHD through eARC. For it to work, enable HDMI-eARC Mode and set Digital Output Audio to 'Pass-Through'.

Userlevel 7

The content I’ve been trying is Disney + , Netflix , amazon prime. 

Are these the Samsung native tv apps or are you using an external media device (Apple TV, Fire TV Stick/Cube etc)

The picture setting above states Pass-Through is only supported when the source is HDMI, so has no impact if you’re using the Q80 in-built apps.

Badge

I use my apps through Roku system not the apps directly on the TV. 

Reply