How to fix Apple 4K TV remote not controlling Sonos soundbar

  • 9 November 2022
  • 27 replies
  • 49022 views

Userlevel 3

This issue has been driving me INSANE for weeks and finally I found the answer on YouTube:

 


Simply hold the input and volume down button on your Apple TV 4K remote for about 5 seconds and 🪄🧙‍♂️ …issue fixed!!!! Your Apple Remote will now control your Sonos sound bar volume again. 

Ken_Griffiths 1 year ago

Perhaps see this Sonos support link too:

https://support.sonos.com/s/article/3403

View original

27 replies

Userlevel 3

Eugh this forum is blocking the YouTube video I attached to me post above. Hopefully this link will take you to the video that finally helped me solve the issue. Hope it helps resolve your Apple TV remote and sound bar issues!

The forum software tends not to like links to outside places, especially for low count posting, it seems.

For me, I had to turn on CEC on my TV set, which was set to ARC only, and wasn’t recognizing CEC commands from my Apple TV. 

Userlevel 7
Badge +23

The forum software tends not to like links to outside places, especially for low count posting, it seems.

For me, I had to turn on CEC on my TV set, which was set to ARC only, and wasn’t recognizing CEC commands from my Apple TV. 

The OP didn’t specify which “soundbar” but I am guessing it is connected via optical, so CEC wont help. After Apple TV updated to OS 16, some people (on reddit) needed to reboot their remotes to get IR to work again. Yes, the Apple TV remote sometimes needs a reboot. Welcome to the future.

Perhaps see this Sonos support link too:

https://support.sonos.com/s/article/3403

This worked for me.  Apple TV 4K, Sonos soundbar.

Userlevel 1

This is how it worked for me:

I have an Apple TV 4K that I previously controlled my TV Sound through HDMI. Now when I would use it with the Ray Soundbar I had to set “Control TV’s and Receivers” to OFF(!) in the Apple TV.

After that I set the “Volume Control” to “Receiver via IR”. This is the correct choice instead of TV as it removes any annoying messages from the TV when you change the volume (mine displayed “optical” every time i touched the remote)

Go to the Sonos app and re-learn the remote control. 

 

Hope this works!

 

Userlevel 2

This issue has been driving me INSANE for weeks and finally I found the answer on YouTube:

 


Simply hold the input and volume down button on your Apple TV 4K remote for about 5 seconds and 🪄🧙‍♂️ …issue fixed!!!! Your Apple Remote will now control your Sonos sound bar volume again. 


this works for me, thank you!!

Yes this solved my problem amazing !!!

Supposedly, the new AppleTV OS update fixes this problem as well. See my post here

It worked! Thank you!

Apple TV 4K and Soundbar.

Thank you!!🤙🏻

Thank you! Was driving me 🍌 

Worked for me - thank you, was driving me nuts too!

This is how it worked for me:

I have an Apple TV 4K that I previously controlled my TV Sound through HDMI. Now when I would use it with the Ray Soundbar I had to set “Control TV’s and Receivers” to OFF(!) in the Apple TV.

After that I set the “Volume Control” to “Receiver via IR”. This is the correct choice instead of TV as it removes any annoying messages from the TV when you change the volume (mine displayed “optical” every time i touched the remote)

Go to the Sonos app and re-learn the remote control. 

 

Hope this works!

 

This worked for me, thanks!!

Worked for me! Thanks. I have had so many issues with my Sonos speakers that I doubt I’ll buy them again. 

Such an easy fix for a problem that has been driving me insane for weeks!!

Badge

The solution worked great! Thanks!

This is how it worked for me:

I have an Apple TV 4K that I previously controlled my TV Sound through HDMI. Now when I would use it with the Ray Soundbar I had to set “Control TV’s and Receivers” to OFF(!) in the Apple TV.

After that I set the “Volume Control” to “Receiver via IR”. This is the correct choice instead of TV as it removes any annoying messages from the TV when you change the volume (mine displayed “optical” every time i touched the remote)

Go to the Sonos app and re-learn the remote control. 

 

Hope this works!

 

This worked for me, thank you. Not sure why my settings updated but oh well :)

This issue has been driving me INSANE for weeks and finally I found the answer on YouTube:

 


Simply hold the input and volume down button on your Apple TV 4K remote for about 5 seconds and 🪄🧙‍♂️ …issue fixed!!!! Your Apple Remote will now control your Sonos sound bar volume again. 



Worked a charm for me - great tip!

It fixed it! Thanks so much!

Awesome. Many thanks!  That has been the most annoying thing.  Apple you’re awesome but, come on. Sonos you’re awesome, but better integration with Apple would be nice.  

After months of trying to problem solve I finally found someone from Sonos customer support that was extremely helpful and solved the remote issue that happens when updating AppleTV OS 17 and higher.   

Note: This is for those that are using the older optical connection and IR remote settings. When updating the Remotes and Devices > Control TVs and Receivers default settings change.  

Below are the steps to getting your remote working again.   

Apple TV 📺 Remote Fix
1. Go to Settings > Remotes and Devices > Control TVs and Receivers.

2. Set this to Off.

3.  Next, go to Settings > Remotes and Devices > Volume Control.

4. Select TV via IR.

5. Select Learn New Device.

6. Follow the on-screen steps to program your Apple TV

7.  Now you will need to teach the Apple TV remote to the home theater speaker:
a. Open the Sonos app for iOS or Android. From the Settings tab, tap System.

8. Select the home theater room and tap Remote Control Setup.

9. Follow the in-app steps using your Apple TV remote. You will be prompted to program the Volume and Mute buttons on the remote. Some Apple TV remote models do not have a mute button. If it doesn't, just wait a minute for this to timeout and continue. After completing these steps, this remote will be the only remote that controls your home theater speaker volume.

Userlevel 2
Badge +2

Yes... 🤗

Can't thank you enough, was going crazy as I was convinced it once worked but couldn't get it to work and ended up choosing HDMI control on my Apple TV to be able to control the TV sound but not my playbar when I just listened to music..

THANKS 🙏🏻

This issue has been driving me INSANE for weeks and finally I found the answer on YouTube:

 


Simply hold the input and volume down button on your Apple TV 4K remote for about 5 seconds and 🪄🧙‍♂️ …issue fixed!!!! Your Apple Remote will now control your Sonos sound bar volume again. 

Awesome, thanks!

Yep, that works.

 

Reply