How to connect Sonos Playbar with LG OLED 55C8PLA and LG MAGIC remote AN-MR18BA?


Badge
I have purchased an LG OLED tv but I cannot manage to connect the SONOS PLAYBAR with the remote control. I went to the Audio settings and I also used the app on my phone to try to connect but it doesn't work.

Does anyone have an idea?

thanks !

22 replies

I'm having problems too, the "Setup Universal Remote" option in the inputs->all inputs screen is missing on my TV of the same model:

https://lgcommunity.us.com/discussion/1836/set-up-universal-control-option-missing-oled55c8-with-magic-remote
Badge
Hey, I got the LG Magic Remote to connect (alongside my DirecTV remote working already) with a little configuration. Here's the step-by-step as of today:

- Press the Home icon
- Navigate to the right to "Device Connector"
- Choose "Sound Bar"
- Select the "Optical" radio button and hit next (in the top right)
- Select "Philips" as the manufacturer
- Select "Remote Type 4" (note, the buttons they prompt you to try didn't work at the time but do after it's setup.

And you're done. I now see the volume going up and down on the screen as I use the Magic Remote. Thanks for everyone else's answers that helped me smash this one together.
Badge
Unfortunately, it worked with the previous model but with the new one, there is no possibility to choose the manufacturer.
I just purchased a LG 55C8AUA and playbar. Contacted LG tech support......zero help, canned answers, basically SOL. After searching several community blogs, I used mbbroberg pattern above and it worked! Have your Sonos app downloaded and ready to go. Enjoy.
Badge
dralaskula wrote:

I just purchased a LG 55C8AUA and playbar. Contacted LG tech support......zero help, canned answers, basically SOL. After searching several community blogs, I used mbbroberg pattern above and it worked! Have your Sonos app downloaded and ready to go. Enjoy.



Except that you are talking about a different model, with the new one, there is not possibility to choose a manufacturer. Sonos Support have not helped in fact, I was supposed to be contacted and still waiting for it...
After a struggle I've suceeded in enabling the volume keys on my AN-MR18BA remote to control my Sonos Playbar connected to my LG OLED55C8PLA TV.

After setting the manufacturer to Philips/remote type 4 (other manufacturers like Bose also work but don't always enable the Mute button) I then used the Sonos app functionality on my android phone to 'replace the current remote' in menu Settings/TV & Remote/Remote/Remote Control Setup and enabled all the check boxes to use infra-red (IR) in menu Settings/TV & Remote/Remote.

Ensure the TV is set to Optical. The remote indicator light will flash on the Playbar when any of the remote's volume related keys are pressed (up, down and mute).
Badge
Thanks but I don't see where you selected the manufacturer...
Jools23 wrote:

Thanks but I don't see where you selected the manufacturer...



- Press Home icon on LG Magic Remote
- Scroll to the right to the Device Connector app on the TV
- Select Sound Bar
- Select the Optical option and select Next
- Select Philips as the manufacturer (Sonos not available)
- Select Remote Type 4

For total clarity please note that in my instructions above the menu path should read Settings/Room//TV & Remote/Remote/Remote Control.
Badge
But i do not have any choice...
Jools23 wrote:

But i do not have any choice...



I've attached a screen shot of my TV at the same stage. It looks like the only difference is that I have the option to select Next whilst you have Done and the focus of the cursor is unclear in your pic whereas on my TV it's on Next.



My TV software version is 04.10.05 and LG service country is UK.
Badge
Correct, the location is the problem, when I switch to France or UK then I have the same as you but once I reach the manufacturer and I select PHILIPS, it tells me that an error occured while connecting to the server...
Badge
I finally found ! So Location is UK but the place of service must also be on UK, then your directions are all correct and it works perfectly well now !

Thanks a lot ! :D
Jools23 wrote:

I finally found ! So Location is UK but the place of service must also be on UK, then your directions are all correct and it works perfectly well now !

Thanks a lot ! :D



Good news. As previously indicated, it's the service country that matters, not the location, so I dont think you need to change both settings. Best regards.
Badge
mbbroberg wrote:

Hey, I got the LG Magic Remote to connect (alongside my DirecTV remote working already) with a little configuration. Here's the step-by-step as of today:

- Press the Home icon
- Navigate to the right to "Device Connector"
- Choose "Sound Bar"
- Select the "Optical" radio button and hit next (in the top right)
- Select "Philips" as the manufacturer
- Select "Remote Type 4" (note, the buttons they prompt you to try didn't work at the time but do after it's setup.

And you're done. I now see the volume going up and down on the screen as I use the Magic Remote. Thanks for everyone else's answers that helped me smash this one together.



Well done...this was making me crazy.
Hi,
I am from israel and I can’t see the manufacturer..

Where you change the place of service??

Thank..
Badge
shayamorag wrote:

Hi,
I am from israel and I can’t see the manufacturer..

Where you change the place of service??

Thank..



Hi Shayamorag, first, you need probably to change the location. Maybe in Israel it is not taken into account so you need to change to UK for example and then you also need to change the support country, choose UK too and then you can follow the whole procedure, it should then work.
Badge
Good news. As previously indicated, it's the service country that matters, not the location, so I dont think you need to change both settings. Best regards.[/quote]

I had to change both otherwise it was not working, I had to change the location to find the place of service because then the way it is presented is very different regarding manufacturers for example.
I had the same problem with my new LGC8 55" connecting to my Sonos Playbar that I have had over one year (purchased 2017). I followed the above per mbbroberg and nothing was working. I then opened the Sonos app on my phone and entered into the Remote Control Setup, while on the LG setup "Remote 4" option. With both screens open, and when I clicked the Vol Up on my LG remote, it all started "magically" working. Yep, very frustrating. You think they would try to make things easier for Sonos consumers. I live in Texas. Hope this helps.
Userlevel 1
Does that really work although the SONOS support page (https://support.sonos.com/s/article/3479?language=de) stated that it won't work with 2018 models (because of the missing IR capabilities of the "new" Magic Remote)? I just want to make sure before buying the OLED.
Thanks,
Oliver
That is what it “says” and I was upset to see that too after purchasing the TV. I found no help on You Tube, which I will post a video for, but after trolling the Sonos community I figured it out. That is why I posted my comment above. I have an OLED C8 TV with the magic remote and my older Sonos play, which has no HDMI input and it works flawlessly!! The above steps somehow trick the playbar into reading IR?? I was really happy that it worked; another reason I posted my comment. Hope this helps with your decision. I’ll try to get the video on You Tube by Tuesday?
Userlevel 1
Thanks for that explanation.
Just one remark: Problem ist not the Playbar as this device reads IR very good. THe problem was supposed to be the Magic Remote that no longer uses IR but bluetooth only.
But again: Good to hear that it's working.
Thanks,
Oliver
The player is Infrared (IR) capable, the magic remote if Radio Frequency (RF), NOT bluetooth.
Here is the You Tube video I promised. Hope this helps! https://www.youtube.com/watch?v=0qLeA5ShPFI

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings