Answered

How can I configure LG Magic remote with Sonos playbar. TV Model LG 55" 4K UHD OLED Smart-TV OLED55B7V

  • 13 November 2017
  • 31 replies
  • 40307 views

How can I configure LG Magic remote with Sonos playbar. TV Model LG 55" 4K UHD OLED Smart-TV OLED55B7V
icon

Best answer by Ryan S 23 January 2018, 20:58

Hi everyone, for the LG Magic Remote there are some extra steps before you can pair it with your player. There's an article here that'll help. Go to Universal Remote Control for your LG TV and then choose Soundbar > Manufacturer > Philips. If it gives you a prompt about a power test or a setting number, just hit yes or select the first option and move on. Once that's done, go to the Sonos app and go to More > Settings > Room Settings > Choose the room for your PLAYBAR/PLAYBASE > TV Control and Setup > Replace this remote when prompted. This should do the trick and get that LG Magic Remote paired without any problems.

You may need to set the remote to Phillips remote type 3.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

31 replies

Badge
Hello.

Try this - worked for me

https://support.sonos.com/s/article/3479
These instructions aren't quite correct - you must select Phillips as the manufacturer and make sure your sound on the tv is set to the audio out (optical/HDMI ARC) with the simplink turned off
The magic remote I have doesn't look like the one with the instructions. There is no choice on brands etc. When I click home, there also is nothing showing the symbol in the instructions.. In the settings and sound area there are choices of the optical audio, optical audio sync with tv, or use both optical and tv speakers.
Not sure which is best or even correct. When I only choose the optical I cannot control it with the remote.
I would also greatly appreciate a workaround. Loving my playbase So far but a remote would be handy.
I have the same problem, but get it to work.....but its extremly slow to change volyme.
Same problem here. lg oled C7P 65" How about an update sonos?
Userlevel 7
Badge +26
Hi everyone, for the LG Magic Remote there are some extra steps before you can pair it with your player. There's an article here that'll help. Go to Universal Remote Control for your LG TV and then choose Soundbar > Manufacturer > Philips. If it gives you a prompt about a power test or a setting number, just hit yes or select the first option and move on. Once that's done, go to the Sonos app and go to More > Settings > Room Settings > Choose the room for your PLAYBAR/PLAYBASE > TV Control and Setup > Replace this remote when prompted. This should do the trick and get that LG Magic Remote paired without any problems.

You may need to set the remote to Phillips remote type 3.
I have the same problem, but get it to work.....but its extremly slow to change volyme.

Hey Barrolsson, Ryan S, with your extra steps recommendation above. is the volume change at normal speed? Or isthis still the case thatit is slow?

thanks in advance guys!
Hi
I also have lg 4k 55" on an optical connection. Seeing conflicting articles on rf unit wont operate ir playbar. Tried various manufacturers and remote types under sound bar device connector but to no avail. When clicking on buttons on screen for device actions for remote type as instructed nothing happens. Tried with simlink off and on and still no joy.
Highly disappointing that a wifi operated sound system doesnt account for different remotes for the high price paid for them.
Any other suggestions or is there firmware update to correct soon as seems to be a major issue for many people?
Thanks
Badge
Dear All!
Was this solved for everyone? I followed the instruction but was not successful.
Own a 55C7V with the newest LG OS (as Feb 2017) - European version if that applies in any way

I cannot change the manufacturer to "Phillips" - cannot select any manufactuerer, because the setting is not in the LG menu.
And how should this work anyways? The remote does NOT send any IR signals - so please shed some light on that for me.

It's a pitty that there is no easy way to join Sonos and LG

Kind regards

Albert
nope it did nothing for me on multiple manufacturers etc. ended up using a second remote as universal.
Hey guys,
I have the LG oled55b7v TV as well and was wondering if I’d be able to hook it up to a Sonos Playbar wirelessly.
Does anyone know if that’ll work?
Much appreciated. Thanks!
No. The Sonos PLAYBAR and PLAYBASE require a optical connection to play any TV sound.
Thanks for reaching out. It looks like the LG Magic Remote has some extra steps before you can pair it with your player. https://t.co/M5FCWtIyvG Go to Universal Remote Control for your LG TV and then choose Soundbar > Manufacturer > Philips. If it gives you a prompt about a power test or a setting number, just hit yes or select the first option and move on. Once that's done, go to the Sonos app and go to More > Settings > Room Settings > Choose the room for your PLAYBAR/PLAYBASE > TV Control and Setup > Replace this remote when prompted. This should do the trick and get that LG Magic Remote paired without any problems.
Hi everyone, for the LG Magic Remote there are some extra steps before you can pair it with your player. There's an article here that'll help. Go to Universal Remote Control for your LG TV and then choose Soundbar > Manufacturer > Philips. If it gives you a prompt about a power test or a setting number, just hit yes or select the first option and move on. Once that's done, go to the Sonos app and go to More > Settings > Room Settings > Choose the room for your PLAYBAR/PLAYBASE > TV Control and Setup > Replace this remote when prompted. This should do the trick and get that LG Magic Remote paired without any problems.

You may need to set the remote to Phillips remote type 3.


Just followed your directions to pair my LG Magic Remote (new LG OLED c7) with my new Sonos Playbar. Did not need to select Remote Type 3. Instead selected Remote Type 1. Then went to my Sonos app to complete the setup. The Sonos app recognized the remote without any problems. I can depress the + or - buttons on the LG remote and hold either down to increase or decrease the volume without having to do so incrementally. Thanks for the clarification. Please revise the directions on the website to include these step-by-step directions. The directions the website are incomplete, contributing to the frustration of Sonos/LG owners.
Thanks Ryan S and CubanMama

I can confirm setting up ''soundbar'' using philips and remote type 1, removing stmlink in sound output works for me.

My setup
2017 LG C7
Optical out to Sonos playbar
TV is connect to my network via ethernet cable, while soundbar via sonos MESH network

What I did:
1.Press the top right button with STB PWR
2.Select set up soundbar
3.Select Philips as manufacturer
4.Select type 1 remote
5.exit to main menu, then select setup (the cogwheel under CH down), select all settings
6.under sound, select sound out, select "optical/HDMI'', turn off SIMPLINK. You will need to reselect optical/HDMI (not LG) again as it default to TV out
7.goto your desktop Sonos app, under home theatre (in rooms), right click and select home theatre setting, select TV settings, then remote setting. Remove and set up new remote
8.follow the instruction, basically wanting you to press volume up, then down x3 then mute
9.enjoy!

I do not have the problem some reported (slow volume change) but could be possibly due to slow Wifi environment? I think the LG magic remote maybe a wifi/BT only device.....
Hi,

I am trying to go through these instructions. I have WebOS 4.70.65 and trying to connect the the tv to the Sonos Playbar. When I am going through the steps in Device Connector however there is no option to select a manufacturer? Is this because of an update to the WebOs or am I doing something wrong?

Best regards
Thanks Ryan S and CubanMama

I can confirm setting up ''soundbar'' using philips and remote type 1, removing stmlink in sound output works for me.

My setup
2017 LG C7
Optical out to Sonos playbar
TV is connect to my network via ethernet cable, while soundbar via sonos MESH network

What I did:
1.Press the top right button with STB PWR
2.Select set up soundbar
3.Select Philips as manufacturer
4.Select type 1 remote
5.exit to main menu, then select setup (the cogwheel under CH down), select all settings
6.under sound, select sound out, select "optical/HDMI'', turn off SIMPLINK. You will need to reselect optical/HDMI (not LG) again as it default to TV out
7.goto your desktop Sonos app, under home theatre (in rooms), right click and select home theatre setting, select TV settings, then remote setting. Remove and set up new remote
8.follow the instruction, basically wanting you to press volume up, then down x3 then mute
9.enjoy!

I do not have the problem some reported (slow volume change) but could be possibly due to slow Wifi environment? I think the LG magic remote maybe a wifi/BT only device.....


Perfecto. Thx.
Edit: thought I had it working, but not there yet.
Thanks Ryan S and CubanMama

I can confirm setting up ''soundbar'' using philips and remote type 1, removing stmlink in sound output works for me.

My setup
2017 LG C7
Optical out to Sonos playbar
TV is connect to my network via ethernet cable, while soundbar via sonos MESH network

What I did:
1.Press the top right button with STB PWR
2.Select set up soundbar
3.Select Philips as manufacturer
4.Select type 1 remote
5.exit to main menu, then select setup (the cogwheel under CH down), select all settings
6.under sound, select sound out, select "optical/HDMI'', turn off SIMPLINK. You will need to reselect optical/HDMI (not LG) again as it default to TV out
7.goto your desktop Sonos app, under home theatre (in rooms), right click and select home theatre setting, select TV settings, then remote setting. Remove and set up new remote
8.follow the instruction, basically wanting you to press volume up, then down x3 then mute
9.enjoy!

I do not have the problem some reported (slow volume change) but could be possibly due to slow Wifi environment? I think the LG magic remote maybe a wifi/BT only device.....
Thanks for this post, works perfectly with my oled55c7 too
The magic remote I have doesn't look like the one with the instructions. There is no choice on brands etc. When I click home, there also is nothing showing the symbol in the instructions.. In the settings and sound area there are choices of the optical audio, optical audio sync with tv, or use both optical and tv speakers.
Not sure which is best or even correct. When I only choose the optical I cannot control it with the remote.


Hi, did you found out how to fix this problem?
Hi,

I am trying to go through these instructions. I have WebOS 4.70.65 and trying to connect the the tv to the Sonos Playbar. When I am going through the steps in Device Connector however there is no option to select a manufacturer? Is this because of an update to the WebOs or am I doing something wrong?

Best regards


Hi, did you found out how to fix this problem?
Hi everyone, for the LG Magic Remote there are some extra steps before you can pair it with your player. There's an article here that'll help. Go to Universal Remote Control for your LG TV and then choose Soundbar > Manufacturer > Philips. If it gives you a prompt about a power test or a setting number, just hit yes or select the first option and move on. Once that's done, go to the Sonos app and go to More > Settings > Room Settings > Choose the room for your PLAYBAR/PLAYBASE > TV Control and Setup > Replace this remote when prompted. This should do the trick and get that LG Magic Remote paired without any problems.

You may need to set the remote to Phillips remote type 3.


Got Magic Remote to work with Philips and remote type 3. Thanks!
Userlevel 4
Badge +2
Thanks Ryan S and CubanMama

I can confirm setting up ''soundbar'' using philips and remote type 1, removing stmlink in sound output works for me.

My setup
2017 LG C7
Optical out to Sonos playbar
TV is connect to my network via ethernet cable, while soundbar via sonos MESH network

What I did:
1.Press the top right button with STB PWR
2.Select set up soundbar
3.Select Philips as manufacturer
4.Select type 1 remote
5.exit to main menu, then select setup (the cogwheel under CH down), select all settings
6.under sound, select sound out, select "optical/HDMI'', turn off SIMPLINK. You will need to reselect optical/HDMI (not LG) again as it default to TV out
7.goto your desktop Sonos app, under home theatre (in rooms), right click and select home theatre setting, select TV settings, then remote setting. Remove and set up new remote
8.follow the instruction, basically wanting you to press volume up, then down x3 then mute
9.enjoy!

I do not have the problem some reported (slow volume change) but could be possibly due to slow Wifi environment? I think the LG magic remote maybe a wifi/BT only device.....


Perfecto. Thx.


I have an LG 49SJ800V. What is the difference under sound out between Audio Out (Optical/HDMI ARC) and LG Sound Sync (Optical)? Both output sound.