Help with Apple and Dolby


Badge
Hello, this subject may already be covered elsewhere in a post, but let me explain what I am trying to do first. I recently cut the cord from U-Verse, they sucked, done. I signed up with DirecTV Now, loving it. I am currently using the Apple TV 3rd Gen I believe that does not have the optical out, therefore I am running an HDMI Audio extractor, which optical is going directly to Sonos Playbar, which I have 2 Play:1’s as surrounds and the Sub. In my Apple menu under sound I have 5.1 Surround option on. It sounds good, I could live with, but am I getting true Surround this way? Is there a test I could perform to determine that all 5 channels are working?

I performed an experiment where I redirected an optical cable from TV through a TOSLINK switcher, and when I jump between the extractor and the TV optical out, the extractor sound is much better. On TV sound settings I have HDMI Audio Format set to Bitstream and Audio Format to PCM. For now sticking with the audio extractor as the sound is better, but again, how in the heck do I configure to get true surround? Thank you

6 replies

Badge
To check if the set up is working, you can use the app and go into About My Sonos System, and under one of the devices, check the Audio In to see if it is reading stereo, or DD 5.1

You want to make sure the source is 5.1 as well... which you can do by viewing sample dolby surround videos on youtube (yes youtube supports multichannel audio), or you can download some files offline and play that through appletv as well

So you should be able to hear the effect, as well as verify it through the app
Badge
Thank you for that tip, I totally forgot about that!!! So it’s showing stereo regardless of settings on the Apple TV, watched numerous clips with 5.1, how can I get 5.1? I am using a J-Tech 5.1 extractor, shouldn’t this do the trick? Also have the audio option on Apple TV set to 5.1 as well, baffled at this point, thanks again for help.
Badge
If your TV does not support surround sound passthrough via optical, it is only sending stereo to the sound bar (whereas the extractor is sending surround sound to the soundbar)

If that is the case with the TV, theres nothing you can do

If the TV does support surround sound passthrough via optical, you want to make sure the settings on TV arent such youre capping the audio to stereo. The audio settings should be Bitstream and Dolby Digital. Bitstream and PCM is stereo.

(On my Samsung, if the TV is not receiving a surround sound source, the dolby digital option will be grayed out.)
Badge
Ok, found issue, apparently there is a little switch on the extractor that was not enabling 5.1 from 2ch, and also have to close the Sonos app out completely and relaunch it before it will show you that’s it’s outputting 5.1 to Playbar, so all is back to normal, and I won’t lose anymore sleep lol, thank you!!!
Userlevel 1
Badge +2
Seems like a complicated setup. I have ATV 4K Aldo lacking optical out. I run an HDMI cable to my tv and optical out from there. Works flawlessly with my Playbar / One surrounds / Sub always delivering DD 5.1 without extractors and other stuff.
Badge
Not that complicated really. Which TV model do you have that has passthrough for Dolby? I have a Samsung JU6500 75”, see nothing in speaker options that allows me to change to Dolby for passthrough. Kinda stupid that a 4K TV of any brand does not offer as an option, especially for the price paid. Therefore I’m using a J-Tech 4K UltraHD extractor with 2.0 HDMI cables, then from extractor optical cable to Playbar now. Did away with the TOSLINK switch now I have no more cable box, and if using the Nintendo Switch will just use TV speakers. Ohhhhh technology, gotta love it

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings