Dolby Digital 5.1 / uncompressed 5.1 output as multichannel pcm 7.1


Userlevel 4
Badge +10

Hi

Trying to work out where the issue lies, with my LG oled or the Sonos ARC.

 

Those that have an LG OLED and Sonos ARC and use passthrough / eARC settings on the TV when you play any Dolby digital 5.1 content via a device like the ATV4K does your Sonos app report multichannel pcm 7.1 ?

 

If you have your xbox audio set to uncompressed 5.1 does the sonos app report multichannel pcm 7.1?

 

Those that don’t have an LG OLED does your sonos arc output as multichannel pcm 5.1 for the above configurations?

 

I’m just trying to work out where this issue lies once and for all, so I can report it.

 

Thanks

 

 


10 replies

Userlevel 7

I have an old Panasonic plasma hooked up to an HDFury Arcana and Apple TV 4K. If I have the Apple TV’s audio setting set to output Dolby Digital 5.1, the Sonos app reports “Dolby Digital 5.1”. But if I have Change Format turned off and Immersive Audio turned on on the Apple TV, when I watch Dolby Digital Plus 5.1 content, the Sonos app reports “Multichannel PCM 5.1” and Dolby Atmos content via Dolby Digital Plus reports as “Dolby Atmos”.

FYI… the Apple TV 4K uses Dolby MAT which is a form of PCM audio. That’s why you will often see “Multichannel PCM” rather than “Dolby Digital Plus” reported in the Sonos app.

Userlevel 2
Badge

hello,

My set-up:

LG OLED 55GX + ATV 4K Gen2 + Arc plugged with eARC

TV settings: 

  • Output: HDMI ARC
  • output: audio: passtrhough
  • eARC enabled

ATV settings:

  • Audio output by default: Receiver speakers
  • Audio format: Auto, Atmos available/ change format: no, Immersive Sound: Dolby Atmos Yes
  • Audio mode: Auto

With Netflix app on ATV, I launched Jurassic World Camp Cretaceous, which is HD 5.A, the Sonos App says I have PCM 7.1 on my Arc.

The same when I play the Dolby Test Tone 5.1.2 from Plex.

 

Userlevel 4
Badge +10

I have an old Panasonic plasma hooked up to an HDFury Arcana and Apple TV 4K. If I have the Apple TV’s audio setting set to output Dolby Digital 5.1, the Sonos app reports “Dolby Digital 5.1”. But if I have Change Format turned off and Immersive Audio turned on on the Apple TV, when I watch Dolby Digital Plus 5.1 content, the Sonos app reports “Multichannel PCM 5.1” and Dolby Atmos content via Dolby Digital Plus reports as “Dolby Atmos”.

FYI… the Apple TV 4K uses Dolby MAT which is a form of PCM audio. That’s why you will often see “Multichannel PCM” rather than “Dolby Digital Plus” reported in the Sonos app.

hello,

My set-up:

LG OLED 55GX + ATV 4K Gen2 + Arc plugged with eARC

TV settings: 

  • Output: HDMI ARC
  • output: audio: passtrhough
  • eARC enabled

ATV settings:

  • Audio output by default: Receiver speakers
  • Audio format: Auto, Atmos available/ change format: no, Immersive Sound: Dolby Atmos Yes
  • Audio mode: Auto

With Netflix app on ATV, I launched Jurassic World Camp Cretaceous, which is HD 5.A, the Sonos App says I have PCM 7.1 on my Arc.

The same when I play the Dolby Test Tone 5.1.2 from Plex.

 

 

I realise why I only get multichannel pcm or atmos from the ATV4K, going by both your comments, it does seem to be an LG issue then, thank you both.

I have contacted LG in the past but they always seem to think its a problem with only my tv and give the same old rubbish about try this and that. Be great if Sonos could contact them, perhaps then LG might act and release a fix.

 

Had the same issue, with the LG CX and specifically Amazon on the ATV4K. (Outputting to 7.1 when I want 5.1 and I got lip sync issues.) I also noticed that my Xbox Series X when set to output 5.1 uncompressed was outputting multichannel 7.1.

I changed the LG from Passthrough to Auto, and that has resolved my ATV issues. Getting 5.1 and Atmos. (But sadly can’t output the Xbox to 5.1 now.)

Userlevel 4
Badge +10

Had the same issue, with the LG CX and specifically Amazon on the ATV4K. (Outputting to 7.1 when I want 5.1 and I got lip sync issues.) I also noticed that my Xbox Series X when set to output 5.1 uncompressed was outputting multichannel 7.1.

I changed the LG from Passthrough to Auto, and that has resolved my ATV issues. Getting 5.1 and Atmos. (But sadly can’t output the Xbox to 5.1 now.)

 

Yeah AUTO solves it for the most part, but those that use passthrough gives the results you mention.

It seems its an LG oled issue with LPCM passthrough, I wish Sonos could press LG to try and fix it. 

It’s like going through hoops when you contact LG yourself.

Userlevel 2
Badge

Hello,

I have changed my TV settings from Passthrough to AUto.

Now, when I play Dolby Atmos content, the Sonos App is displaying PCM Multicanal 5.A

Should I see something different?

 

My setup: 

  1. Sony A80J 77” OLED (eARC with auto pass through enabled)
  2. Sonos ARC + 2x Sonos ONE SL surrounds + Sub
  3. Apple TV 4K 2021 32gb

7.1 Dolby Atmos audio out of Apple TV passed to the ARC via eARC on my tv is fine - shows as “Dolby Atmos” on the system status in Sonos app.

Issue occurs when playing 5.1 audio out of Apple TV - it shows up as •”Multichannel PCM 5.1” . The audio itself seems to play and no sync or stutter issues. The problem is the the center/voice channel is playing on one of the rear surround speaker. Seems like either Apple TV or Sonos cannot correctly distinguish between 7.1 and 5.1. 
 

For context - playing 5.1 or 7.1 Atmos audio through native apps on Sony or my Amazon Fire TV vibe gives no problems and just seems to do the right thing so is the problem in Apple TV or how Sony is passing through the sound? Please help - this is driving me nuts. 

My setup: 

  1. Sony A80J 77” OLED (eARC with auto pass through enabled)
  2. Sonos ARC + 2x Sonos ONE SL surrounds + Sub
  3. Apple TV 4K 2021 32gb

7.1 Dolby Atmos audio out of Apple TV passed to the ARC via eARC on my tv is fine - shows as “Dolby Atmos” on the system status in Sonos app.

Issue occurs when playing 5.1 audio out of Apple TV - it shows up as •”Multichannel PCM 5.1” . The audio itself seems to play and no sync or stutter issues. The problem is the the center/voice channel is playing on one of the rear surround speaker. Seems like either Apple TV or Sonos cannot correctly distinguish between 7.1 and 5.1. 
 

For context - playing 5.1 or 7.1 Atmos audio through native apps on Sony or my Amazon Fire TV vibe gives no problems and just seems to do the right thing so is the problem in Apple TV or how Sony is passing through the sound? Please help - this is driving me nuts. 


did you ever figure this out? I’ve got a Sony a9g and an Apple TV 4K with a Sonos Arc and two One SL’s. I’m having big issues with hearing voices on some content and volume between Dolby digital plus content and LPCM content (like between commercials and ads on streaming apps). It requires me jumping for the remote to turn down the volume during commercials and turning it back up to hear people talk during shows. It’s really annoying!

My setup: 

  1. Sony A80J 77” OLED (eARC with auto pass through enabled)
  2. Sonos ARC + 2x Sonos ONE SL surrounds + Sub
  3. Apple TV 4K 2021 32gb

7.1 Dolby Atmos audio out of Apple TV passed to the ARC via eARC on my tv is fine - shows as “Dolby Atmos” on the system status in Sonos app.

Issue occurs when playing 5.1 audio out of Apple TV - it shows up as •”Multichannel PCM 5.1” . The audio itself seems to play and no sync or stutter issues. The problem is the the center/voice channel is playing on one of the rear surround speaker. Seems like either Apple TV or Sonos cannot correctly distinguish between 7.1 and 5.1. 
 

For context - playing 5.1 or 7.1 Atmos audio through native apps on Sony or my Amazon Fire TV vibe gives no problems and just seems to do the right thing so is the problem in Apple TV or how Sony is passing through the sound? Please help - this is driving me nuts. 


did you ever figure this out? I’ve got a Sony a9g and an Apple TV 4K with a Sonos Arc and two One SL’s. I’m having big issues with hearing voices on some content and volume between Dolby digital plus content and LPCM content (like between commercials and ads on streaming apps). It requires me jumping for the remote to turn down the volume during commercials and turning it back up to hear people talk during shows. It’s really annoying!

My setup: 

  1. Sony A80J 77” OLED (eARC with auto pass through enabled)
  2. Sonos ARC + 2x Sonos ONE SL surrounds + Sub
  3. Apple TV 4K 2021 32gb

7.1 Dolby Atmos audio out of Apple TV passed to the ARC via eARC on my tv is fine - shows as “Dolby Atmos” on the system status in Sonos app.

Issue occurs when playing 5.1 audio out of Apple TV - it shows up as •”Multichannel PCM 5.1” . The audio itself seems to play and no sync or stutter issues. The problem is the the center/voice channel is playing on one of the rear surround speaker. Seems like either Apple TV or Sonos cannot correctly distinguish between 7.1 and 5.1. 
 

For context - playing 5.1 or 7.1 Atmos audio through native apps on Sony or my Amazon Fire TV vibe gives no problems and just seems to do the right thing so is the problem in Apple TV or how Sony is passing through the sound? Please help - this is driving me nuts. 


did you ever figure this out? I’ve got a Sony a9g and an Apple TV 4K with a Sonos Arc and two One SL’s. I’m having big issues with hearing voices on some content and volume between Dolby digital plus content and LPCM content (like between commercials and ads on streaming apps). It requires me jumping for the remote to turn down the volume during commercials and turning it back up to hear people talk during shows. It’s really annoying!

I have a very similar setup with an Sony A80J, Arc and a Sub along with a Apple TV 4K not the newest model. I happen to jump back and forth when it comes to audio. I have retuned using Trueplay multiple times and no matter what the dialogue is just not good. It is infuriating knowing that sound effects will be extremely loud but then dialogue is too low and having to guess when a scene is going to be too loud. I pretty much have ran out of options on what to do at this point. Loudness is not on either. Speech Enhancement does not really work that well. So yeah another person with the same problem.

I noticed the same thing.  I also have Apple TV —→ LG CX——> Sonos Arc. Noticed when set to pass through was coming as 7.1 because it was so much quieter.  I leave the TV set to auto to make sure I get Atmos when available.  If I leave on Passthroigh I get 7.1 instead of 5.1 on HBO Max app and atmos doesn’t trigger properly.  

Reply