Answered

Dolby Atmos not working LG OLED55B6P w/Sonos Beam surround sound

  • 22 January 2023
  • 6 replies
  • 580 views

Hi all,

I have a SONOS surround system for my living room that works great and recently purchased a surround sound system for the basement (Beam Gen 2, two One SL’s and Sub Mini), but I’m not able to get Dolby Atmos working via my PS5 on my LG OLED55B6P.

I know there’s some tricks to get Dolby Atmos working on the PS5 and I’ve followed those settings.

This are the setting I’m using on the TV while having HDMI connected to the HDMI 2/Arc port to my Sonos Beam.

Sound Out → Audio Out (Optical/HDMI Arc)

All Settings → Sound → Sound Out → Audio Out (checked)

In a sub bullet of the Audio Out I have Digital Sound Out set to Auto and SIMPLINK set to On.

Any help is appreciated.  Thanks.

icon

Best answer by GuitarSuperstar 23 January 2023, 00:27

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

On the TV, set the Digital Sound out on the TV to pass-through and ‘bitstream’ on the HDMI port that the PS5 is connected to. 
 

PS5 settings (I believe) should be:

  • Output Device: HDMI Device (AV Amplifier)
  • HDMI Device Type: AV Amplifier
  • Number of Channels: 5.1ch
  • Audio Format (Priority): Dolby
  • When watching Blu-ray discs, there is another audio setting that must be adjusted when you start the disc. Tap the Options button on the controller, select the “…” and change the Audio Format setting to Bitstream for Dolby-encoded discs. Change this setting to Linear PCM for DTS-encoded discs.
Userlevel 7

The PS5 doesn’t support Dolby Atmos audio from any of the streaming apps or when gaming. It is only supported when playing a Dolby Atmos Blu-ray disc. And your TV must be equipped with HDMI eARC to play Dolby Atmos audio from Blu-rays.

The PS5 doesn’t support Dolby Atmos audio from any of the streaming apps or when gaming. It is only supported when playing a Dolby Atmos Blu-ray disc. And your TV must be equipped with HDMI eARC to play Dolby Atmos audio from Blu-rays.

 

Thank you for the response.

I guess I’m confused because I have the same tv and same Sonos system upstairs and the Dolby Atmos works with my Blue Ray player.  I’ve now brought my Blue Ray player to the basement to see if that works instead of the PS5 and I’m still not getting Dolby Atmos, just Dolby Digital  Plus 5.1.

Yes, I’m using Blue Ray discs on it, like I was on the PS5.

Can’t Dolby Atmos also play via ARC instead of eARC? These older model LG OLED’s only have ARC and like I said, I’m able to get it to work in my upstairs setup.

Update...just seen this on the Sonos website.  Seems like Dolby Digital Plus 5.1 is the same as Dolby Atmos, but not as good as Dolby Atmos TrueHD?

https://support.sonos.com/en-us/article/listen-to-dolby-atmos-on-sonos

Sorry for the rambling post, but I can’t understand why I have the exact same setup upstairs and it says Dolby Atmos yet says Dolby Digital Plus 5.1 in the basement.

On the TV, set the Digital Sound out on the TV to pass-through and ‘bitstream’ on the HDMI port that the PS5 is connected to. 
 

PS5 settings (I believe) should be:

  • Output Device: HDMI Device (AV Amplifier)
  • HDMI Device Type: AV Amplifier
  • Number of Channels: 5.1ch
  • Audio Format (Priority): Dolby
  • When watching Blu-ray discs, there is another audio setting that must be adjusted when you start the disc. Tap the Options button on the controller, select the “…” and change the Audio Format setting to Bitstream for Dolby-encoded discs. Change this setting to Linear PCM for DTS-encoded discs.

 

Thank you for the response as well.  I’ve seen different settings online that didn’t work for me, but I also tried yours.  Unfortunately it’s not working for me either.

This is when I tried bringing my 4k blue ray player downstairs and unfortunately that doesn’t work either.

These are the other settings I saw online.

 

My Connections:

  • PS5 --> (HDMI 2.1) --> TV --> (HDMI 2.1 eARC) --> Sonos Beam Gen 2

TV (LG C1 OLED):

  • Enable eARC Support

  • Sound settings --> Digital Sound Output>>> change to Pass Through

PLAYSTATION 5:

  • Settings --> Sound --> Audio Output --> HDMI Device Type>>> change to Sound Bar

  • Settings --> Sound --> Audio Output --> Audio Format (Priority)>>> change to Linear PCM (or Dolby, if your speaker is connected directly to PS5)

BLU-RAY DISC (while playing):

  • Enable Dolby Atmos in the disc audio menu/settings

  • Press "Options" button on PS5 controller --> 3-dots menu --> Settings -->Audio Format>>> change to Bitstream

Userlevel 7

C1 settings should be set to this:

HDMI Input Audio Format: Bitstream

Digital Sound Output: Pass Through

eARC Support: On
 

PS5 settings should be set to this:

Output Device: HDMI Device (AV amplifier)

HDMI Device Type: AV amplifier

Number of Channels: 5.1 ch

Audio Format (Priority): Dolby

 

After starting the Blu-ray disc, tap the Options button on the controller, select the “…” and change the Audio Format setting to Bitstream.

I don’t see why it wouldn’t work if set to ‘Dolby’ audio format - but it might be the HDMI cable, perhaps try a different HDMI cable between the PS5 and the TV… I’m assuming you’re currently using the HDMI 1.4+ cable with HEAC support that came with your Sonos Beam.