Dolby Atmos causing audio on Arc to "pop" then cuts out

  • 8 November 2021
  • 82 replies
  • 6499 views

I purchased a Sony KD85X91J in July equipped with eARC so I could listen to content from my Apple TV 4K in Dolby Atmos. The problem I have is whenever I play Atmos content (and ONLY Atmos content). Every so often the Arc has a quick popping sound followed by the Arc losing audio until I back out of the Atmos content I was watching. When I back out I can start the content again in Atmos and it will work for a while until the pop and audio cut out happens again. 

I have a 5.1 setup with the Arc, 2 One SL’s and a Gen 3 sub. The bass and surrounds still play audio after the cut out. Only the Arc is affected. 

The HDMI cables i am using are both rated to handle Atmos content. Link to the cables being used is below. 

https://www.amazon.com/gp/product/B07S1CGQ9Z/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

 

Is there a fix for this issue? It’s very frustrating investing into a system that cannot deliver what it advertises and I’m hoping theres something I’m missing that will easily solve the issue. 

 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

82 replies

Sounds like the XBox is generating this scary pop for some reason….Sonos is just playing what is sent down the wire. 

Userlevel 1
Badge +1

Maybe, but before my arc, I have a Beam, and never this issue with my Xbox.

The Beam, assuming it was Gen 1, wouldn’t have been receiving an Atmos signal. 

Userlevel 1
Badge +1

Yes, my BEAM was gen1

Userlevel 4
Badge +3

Posted on the other thread but will share my insights here as well.  I too am experiencing the issue on both XSX and ATV4K, more often on the series x opposed to the ATV4K but it aligns with everybody is saying

 

i just finished a RMA process because I caught the pop on video and the support rep processed it as a hardware failure, and the new arc and hdmi cable behaved well for the first three weeks until tonight.  Always happens in the same spot on the series X, when I’m going back to the Home Screen after playing a Dolby Atmos (MAT) title.  
 

So far I have tried 2 ARCs, 3 Certified HDMI 2.1 cables, two different devices (Xbox and ATV) and two different TVs (Sony x900h, LG C1) and with the pop happening on all combinations, the common theme is the Dolby Atmos MAT format.  I too have not seen the issue on any other audio format or TV smart app

Also opened a ticket with Microsoft, to see if there is something on their end they aren’t doing correctly

As for Sonos, there are literally a 100 users over this thread and the one I’ve posted to “Sonos arc pop then Audio Loss” describing the same issue.  I find it hard to believe Sonos can’t reproduce this issue when it’s so very common 

 

And yes, I am aware that I can use a downgraded audio format and not have this issue, but when spending $2,000 on a speaker system that does Dolby atmos.  I certainly want to take full advantage 

 

I’ve been having the same issue but with the Beam gen 2 playing Atmos content from Apple TV 4K.  Apple even replaced my Apple TV unit with a new one, but issue didn’t resolve.  I had seen that TV OS 16 had fixed similar issues in beta, but after finally getting the OS 16 problem still occurs.  Any fixes lately?  Where is Sonos support in all this? 

I’m just here to add my voice to the crowd.  Sony KD-43X85J. Apple TV 4K. Sonos Arc.  Loud pop in first 5-10 minutes of Atmos content.  If I unplug the arc and plug it back in sound comes back and no more pops for the rest of the evening.  TV Apps play atmos content fine.  Serious first world problems here… but I’ve spent first world prices on these products.

Userlevel 4
Badge +2

One thing I read on another blog post which I’ve been able to confirm, is this only occurs when playing Dolby Vision and Dolby Atmos at the same time on an Apple TV.

When I disable Dolby Vision, and use HDR 60Hz on Apple TV with Dolby Atmos enabled, the popping noise loss does not occur. When I turn Dolby vision back on, pop and noise loss within 10 min. Note only happens with Dolby Vision and Dolby Atmos content. 
 

Sony X900H

What started the issue was Xbox Series X. I never had this issue using Sonos with my Apple TV 4K with Dolby Vision and Dolby Atmos both on for almost a year. Then once I got an Xbox Series X last week, it popped with Dolby Vision and Dolby Atmos on the Xbox Series X enabled.

After this occurred with the Xbox Series X, Apple TV 4K started having issues immediately. Prior to Xbox Series X, zero issues with Apple TV 4K at any setting.

I tried changing out HDMI 2.1 cables, 8K 60Hz and 4K 120Hz. Not a cable issue. It only occurs when Dolby Vision and Dolby Atmos is enabled. After the error occurs.

I sincerely hope Sonos addresses this. As it’s been a year now from all the complaints and still no resolution much less recent responses that provide an actual fix.

 

 

Wanted to post an update here since it’s been a while. I’ve been “pop free” for over a month now.  All I had to do was disable eArc on my Sony television.  I have the Arc, with 2 One SLs, and a sub.  Television is Sony X900H.  I can confirm that once I disabled eArc I was able to run Dolby Vision and Atmos content through the Apple TV with no popping.

Userlevel 2
Badge

Please go to the post “Sonos Arc loud pop then audio loss” and add you story/experince there. So we have everything at one place. Sonos needs to fix this.,

Userlevel 2
Badge

Go to post “Sonos Arc loud pop then audio loss” and add your story. Sonos need to fix this.

Userlevel 6
Badge +5

Wanted to post an update here since it’s been a while. I’ve been “pop free” for over a month now.  All I had to do was disable eArc on my Sony television.  I have the Arc, with 2 One SLs, and a sub.  Television is Sony X900H.  I can confirm that once I disabled eArc I was able to run Dolby Vision and Atmos content through the Apple TV with no popping.

I also own an Apple TV, 900H, and Arc. As far as I know, you cannot play Atmos with eARC off from the Apple TV with our television. 
 

Please play Atmos content in the Apple TV and confirm that you are getting the Atmos logo in the Sonos app. And if you do, tell me how to pull that off!

I suspect you “fixed” the problem by disabling Atmos. Which is Sonos’ official recommendation for Apple TV and Xbox. 

Wanted to post an update here since it’s been a while. I’ve been “pop free” for over a month now.  All I had to do was disable eArc on my Sony television.  I have the Arc, with 2 One SLs, and a sub.  Television is Sony X900H.  I can confirm that once I disabled eArc I was able to run Dolby Vision and Atmos content through the Apple TV with no popping.

I also own an Apple TV, 900H, and Arc. As far as I know, you cannot play Atmos with eARC off from the Apple TV with our television. 
 

Please play Atmos content in the Apple TV and confirm that you are getting the Atmos logo in the Sonos app. And if you do, tell me how to pull that off!

I suspect you “fixed” the problem by disabling Atmos. Which is Sonos’ official recommendation for Apple TV and Xbox. 

With eARC disabled, playing atmos content on Netflix and Amazon the Sonos app is stating it is currently playing Atmos content. Conversely, when I disable Atmos on Apple TV with eARC enabled the sound displays as Dolby 5.1 on the Sonos app.

Userlevel 6
Badge +5

With eARC disabled, playing atmos content on Netflix and Amazon the Sonos app is stating it is currently playing Atmos content. Conversely, when I disable Atmos on Apple TV with eARC enabled the sound displays as Dolby 5.1 on the Sonos app.

Same for me. It used to be that turning off eARC meant DD5.1 from the Apple TV, which doesn’t do Atmos. Now the Apple TV is sending DD5.1+, which does support Atmos. Of course, you lose other features like the automatic A/V sync and lossless audio that eARC adds.

I’m looking forward to testing DD5.1+ Atmos on Arc when I have time. Maybe we can upgrade Arc support for Apple TV from broken to janky!

Userlevel 1

So from my research, this does not appear to be a SONOS issue as it’s a Dolby Atmos issue. Ive been scouring the Microsoft forums and a lot of people are having this same pop/cracking issue when running Atmos content through their XSX or HTPC, even through a proper surround system. 

Userlevel 6
Badge +5

So from my research, this does not appear to be a SONOS issue as it’s a Dolby Atmos issue. Ive been scouring the Microsoft forums and a lot of people are having this same pop/cracking issue when running Atmos content through their XSX or HTPC, even through a proper surround system. 

Could you provide links? I’d like to check this out.

Userlevel 1

So from my research, this does not appear to be a SONOS issue as it’s a Dolby Atmos issue. Ive been scouring the Microsoft forums and a lot of people are having this same pop/cracking issue when running Atmos content through their XSX or HTPC, even through a proper surround system. 

Could you provide links? I’d like to check this out.

 

Sure. See below:

 

https://answers.microsoft.com/en-us/xbox/forum/all/xbox-series-x-sound-popping-and-crackling/118d461f-2df3-40b0-80ab-1c8b67a70eaf

 

https://answers.microsoft.com/en-us/windows/forum/all/fixed-dolby-atmos-poppingcrackling-sound/6093c568-fc95-4c84-bd2b-b4c072c01b2a

 

https://answers.microsoft.com/en-us/windows/forum/all/clicking-sound-while-using-dolby-atmos-surround-in/9594e16c-75f1-4b80-99c1-b48393714701

 

https://answers.microsoft.com/en-us/xbox/forum/all/netflix-dolby-atmos-popping-and-crackling/75ac3701-9986-4a58-9fda-89bae2a52e04

 

https://www.reddit.com/r/xboxinsiders/comments/pow2a6/atmos_causing_pop_loss_of_sound/

 

https://www.reddit.com/r/Soundbars/comments/jmblvo/solved_intermittent_popping_sound_from_samsung/

 

This link here seems to be the most confident in identifying it as an Atmos issue through Apple TV4k (although, again, Im not convinced it’s ONLY an ATV issue) but has good discussion.

 

https://www.reddit.com/r/appletv/comments/pe1uks/atmos_content_on_apple_tv_is_crackling/

 

 

There’s a ton more links but that’s just an initial smattering for reference. Based on everything Im seeing, I really dont think this is a SONOS specific issue but rather a codec/processing issue brought on by Atmos content. XBOX S and Apple TV4k seem to be largest drivers of consistent complaints but Im not sure it’s limited to just those two as Ive seen a few comments from PS5, HTPC, and PC users as well. 

Userlevel 1

One guy on reddit (from last link I posted above) touted the below as a fix FWIW. Some users don’t seem to agree but Im trying it now to see if there’s any improvement. His text copied below:

 

Finally solved!!!

I was having crackling all the time when ATMOS was supposed to play (Disney Plus, Apple Tv shows).

The solution is to go to Settings > Video and Audio > Match content >

There: Match Frame Rate: On

Solved!

Note: It doesn’t hurt to also activate Match Dynamic Range.

If not. Try Changing video from 4K 60 Hz to 50Hz.

All ATMOS content sounds spectacular now 🙂

Userlevel 6
Badge +5

Thanks for sharing the links. I’m afraid none of these match what’s going on with Sonos Arc. Our pop is a loud one-time bang (like furniture falling over) followed by sound cutting out on the Arc but continuing to play on the surrounds. It happens with various sources including Apple TV, Xbox, and built-in TV apps. The common feature appears to be Atmos encoded in Dolby MAT.

The users in your links have rythmic popping and/or crackling sound that does not disable the audio itself, or brief cutouts of sound. The cutouts were a problem with old Xbox software a year+ ago but seem to have been resolved. Rythmic pops and crackles appear on various soundbars and can have a whole multitude of reasons, but again, nothing comparable to the Sonos Arc pop.

The only pop like we have is described by your first Reddit link, which uses a Sonos Arc. I have match framerate and march dynamic range on on my Apple TV (of course I do, who wouldn’t?) and it does not solve the problem.

Userlevel 1

Thanks for sharing the links. I’m afraid none of these match what’s going on with Sonos Arc. Our pop is a loud one-time bang (like furniture falling over) followed by sound cutting out on the Arc but continuing to play on the surrounds. It happens with various sources including Apple TV, Xbox, and built-in TV apps. The common feature appears to be Atmos encoded in Dolby MAT.

The users in your links have rythmic popping and/or crackling sound that does not disable the audio itself, or brief cutouts of sound. The cutouts were a problem with old Xbox software a year+ ago but seem to have been resolved. Rythmic pops and crackles appear on various soundbars and can have a whole multitude of reasons, but again, nothing comparable to the Sonos Arc pop.

The only pop like we have is described by your first Reddit link, which uses a Sonos Arc. I have match framerate and march dynamic range on on my Apple TV (of course I do, who wouldn’t?) and it does not solve the problem.

Ahh good feedback. And yes, my experience with the “pop” is exactly what you described. Regardless, I did NOT have frame-rate match turned on (unsure why) so Im trying that to see if there’s any difference but, based off your reply, Im not expecting there to be. I did also read about the Atmos MAT codec which very well could be the guilty party. 

Im curious, do you also experience issues with other inputs or just AppleTV? I do have a Panasonic UBP420 player so maybe I need to run a few movies through that to see if it also reproduces the issue. 

Userlevel 6
Badge +5

I experience the issue, reproducibly, with Apple TV and Xbox. Sonos recommends to turn Atmos off when using those devices. In the main thread on this problem, we had a few others report the pop with Dolby MAT outputting TVs. Apple TV and Xbox users are the bulk however, presumably owing to the devices’ large install bases.

If you have a Blu-ray player that outputs Dolby MAT Atmos, it would be a great test case. We do not have anybody reporting the issue with a Blu-ray source yet. 

Userlevel 1

I experience the issue, reproducibly, with Apple TV and Xbox. Sonos recommends to turn Atmos off when using those devices. In the main thread on this problem, we had a few others report the pop with Dolby MAT outputting TVs. Apple TV and Xbox users are the bulk however, presumably owing to the devices’ large install bases.

If you have a Blu-ray player that outputs Dolby MAT Atmos, it would be a great test case. We do not have anybody reporting the issue with a Blu-ray source yet. 

How can I tell if my Panasonic UBP420 outputs MAT Atmos? Im currently giving TG Maverick a run through. So far so good with no pops.

Userlevel 6
Badge +5

I don’t know my way around Blu-ray players that much, but here is how I think it works. While playing the content, go into the Sonos App → About My System → Audio In:

If it shows Dolby Atmos (DD+) it’s Dolby Digital Plus.

If it shows Dolby Atmos (TrueHD) it’s Dolby TrueHD.

If it shows just Dolby Atmos it’s Dolby MAT.

 

After reading this thread, I’m now uncertain about purchasing a Sonos Arc!

I was planning on using it with my Apple TV 4K, but it appears this setup may be glitchy at best.

Is this still an issue with most Apple TV 4K users?  I’ve seen some “solutions” that involve turning off Dolby Atmos, but that kinda defeats a huge reason for purchasing the Sonos Arc.

Userlevel 6
Badge +5

The issue persists. We do not know what percentage of the Apple TV userbase is affected. For now, Sonos recommends turning Atmos off if you use Apple TV or Xbox. Everything works fine without Atmos.

The best I can tell you is to check out the main thread and then decide for yourself.