Question

Controlling Sonos Playbar Volume with LG 55EF950V (webOS 2.2) remote

  • 27 December 2015
  • 13 replies
  • 4265 views

Userlevel 1
Badge +1
I have a LG 55EF950V TV with wand remote (the TV is running webOS 2.2.0-1317). I would like to control the Sonos Playbar's volumne using the TV's "wand" remote (this runs over RF rather than IR).

Has anyone managed to do this successfully on webOS 2.2?

(I have seen some others post about this before with LG's wand but following others suggestions does not work).

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

13 replies

Hi
Just bought the exact same tv and have come across same problem 😞 very annoying! Havent found à solution yet so would hè great of someone can help out...
Userlevel 1
Badge +1
@Nicky2016 - Glad to hear someone else out there is having the same problem 😉... Let me know if you ever find a solution (likewise of course :-)).

If I dont find a solution to this then I'm thinking just to get a cheap TV remote and just use it for the volume control (like I used to on my old Samsung TV). Shame if I have to though as I wanted to have just one remote 😉
There are solutions if you search the forum. Use device connector in webos to add sound bar. Select optical, brand Phillips, remote type 4 and complete the setup on the TV. Now using your Sonos app, go to settings, room settings, select room with your playbar, tv setup & control, remote control setup, replace current remote and when prompted to press volume, do so from your magic remote while pointing at the soundbar.
Userlevel 1
Badge +1
@HighriseATX - Thanks for the reply, but I have already tried this (from searching on here before) and this does not work with my 55EF950V.

I setup with Phillips remote type 4 on the TV but when trying to setup the Sonos playbar pressing the magic remote volume buttons is not recognised by the Sonos system.

"do so from your magic remote while pointing at the soundbar" - the wand remote I have does not have IR so I'm guessing the only way it can possibly communicate is Remote -> TV -> Sonos Playbar (unlike IR which is directly from Remote -> Sonos Playbar).
@Nashwan, I actually did manage To fix it!! 🙂 pretty much same as u described but Some small differences. Simple step plan:
1. Click top right button on remote To chose For "all exits"
2. Opt For "component" on left bar on tv menu
3. Opt For "set up universal remote"
4. Opt For "soundbar"
5. Opt for Philips soundbar
6. Now comes the difference With what u wrote before. Use Sonos app to set up remote but don't use the volume + button on the remote itself but the button appearing on the tv screen (by Mouse on ur remote pointed at tv screen)
7. Finish the rest of the steps in menu on ur tv screen and after finish it should work
@Nashwan, I actually did manage To fix it!! 🙂 pretty much same as u described but Some small differences. Simple step plan:
1. Click top right button on remote To chose For "all exits"
2. Opt For "component" on left bar on tv menu
3. Opt For "set up universal remote"
4. Opt For "soundbar"
5. Opt for Philips soundbar
6. Now comes the difference With what u wrote before. Use Sonos app to set up remote but don't use the volume + button on the remote itself but the button appearing on the tv screen (by Mouse on ur remote pointed at tv screen)
7. Finish the rest of the steps in menu on ur tv screen and after finish it should work
Userlevel 1
Badge +1
@Nicky2016 - mate your a star! That worked! ... I'm liking the + / - / mute icons that appear on screen when you click vol up / down / mute as well 🙂
Nashwan, glad it worked for u 2! Congrats and enjoy 😉
Userlevel 2
Badge
I looked superlong for this and there is a simple way to get it to work (or atleast for me)
I post here as this seem to be the highest post if you google the problem.

Im on a LG 70UH700V with webOS 3 and sonos Playbar and some Play:1 mainly

Part 1:
1) click the home button on your magic remote and scroll along the bottom (where Netflix, etc is) until you get to a purple icon "device connector"
2) select soundbar and pick the Phillips brand and select remote type 4
3) Select done

Part 2:
1) Open the Sonos app on your iPad or phone
2) select the gear icon "settings"
3) select the room your system is in
4) select TV setup and control
5) select remote control set up and follow the prompts using your "Phillips" magic remote

You are done!

Hope it works!

Ps. all props to https://en.community.sonos.com/home-theater-228993/how-can-i-configure-lg-magic-remote-with-sonos-playbar-tv-model-55lm7600-6487430/index1.html#post16025454
For me it does still not work. When I go to the Device Connector and select the "Soundbar", I can just click next and then it's done. I cannot select a manufacturer or anything else.
Does the remote even has IR by default? Or are there different models?

Any help is appreciated :-)

LG 55EG910V, AN-MR600, webOS 2.0, Switzerland
Sonos Playbar is connected via Optical
For me it does still not work. When I go to the Device Connector and select the "Soundbar", I can just click next and then it's done. I cannot select a manufacturer or anything else.
Does the remote even has IR by default? Or are there different models?

Any help is appreciated :-)

LG 55EG910V, AN-MR600, webOS 2.0, Switzerland
Sonos Playbar is connected via Optical


i do have the same issue... there is no option to choose any hardware manufacturer...
any idea whats wrong on the TV, or what has to be changed???
using a LG 65UF852 with webOS 4
For me it does still not work. When I go to the Device Connector and select the "Soundbar", I can just click next and then it's done. I cannot select a manufacturer or anything else.
Does the remote even has IR by default? Or are there different models?

Any help is appreciated :-)

I have a LG65UH770 with webOS 3.0 and I'm also having the same problem. Help please

LG 55EG910V, AN-MR600, webOS 2.0, Switzerland
Sonos Playbar is connected via Optical


i do have the same issue... there is no option to choose any hardware manufacturer...
any idea whats wrong on the TV, or what has to be changed???
using a LG 65UF852 with webOS 4
This is an excellent fix. Thank you so much. However, it seems like this must be a fairly common problem, so what does Sonos not specifically include these steps in the manual itself. Thank you again.