Can’t play Dolby atmos in my ARC

  • 25 November 2022
  • 8 replies

Hi there, 


I have just got the Sonos ARC and the audio format I get is Dolby Multichannel PCM 5.1 but no Dolby atmos. My tv Philip 58PUS8556/12 support Dolby Atmos, the hdmi is connected in the e-arc and enable it. I have tried several times with different films without success, Can anyone assist me? 



Best answer by GuitarSuperstar 25 November 2022, 23:38

View original

8 replies

Userlevel 7

Make sure the Digital Out Format setting on the TV is set to Multichannel (bypass). And set eARC mode to Automatic.

Yes, both are Ok 😓

Userlevel 7

What are some of the specific Dolby Atmos sources you are testing? From what app? From what device?

I have tried for example watching the Irishman through Netflix with my Philip 58PUS8556/12. I just receive Dolby Multichannel pcm 5.1

Userlevel 7

Do you have a Netflix premium subscription? This is required for Dolby Atmos audio.

The fact that you are getting Dolby Multichannel PCM audio tells me that your TV settings still aren’t correct. Make sure the Digital Out Format setting on the TV is set to Multichannel (BYPASS) not just Multichannel

Netflix is premium. 

see below the multichannel options


Userlevel 7

Select Multicanal (derivacion). Also be sure to play the ORIGINAL language audio track.


It was the audio, I was not playing the original one. You rock mate


thanks very much