Bitstream vs PCM, TV Dialog Sync and Audio Quality

  • 29 November 2022
  • 6 replies
  • 297 views

I have two configurations, one LG TV (2018 model 55SK9000PUA) connected to a Sonos Beam (Gen 2) using HDMI ARC and another LG TV (2019 model 43UM7300PUA) connected to a Sonos Ray using optical. When the TVs Digital Sound Out is set to Auto (Bitstream) it struggles with dialog sync; the severity varies between programming. If I set the Digital Sound Out to PCM there is no problem. The sync issue is more difficult with the Beam connected by HDMI ARC than the Ray connected by optical (why?). In the former case, setting the AV Sync Adjustment (on the TV) to 3 seems to provide pretty good correction. 

The audio quality of PCM vs Bitstream in the Ray configuration does not seem to make any difference. Even when set to PCM the Ray (with Sonos One surround speakers) produces surround sound for relevant content. This seems to conflict with reports on the internet that PCM is only two channel; can someone clarity that in this context?

Bitstream in the Beam configuration produces a fuller sound than PCM. Unfortunately that is also the configuration that seems to struggle more with the dialog sync. As noted above, the TV’s AV Sync Adjustment at about 3 seems to provide good correction, although it isn’t perfectly consistent across all source content. Would the dialog sync be less of any issue on a newer model TV? Note I have tried the TV Dialog Sync setting for the Beam but it doesn’t seem to make as much difference as the setting on the TV.


6 replies

Userlevel 7

Use the Pass Through setting for Digital Sound Out rather than Auto. This should help with the lip sync issue.

When using the PCM setting on the TV, you will only get Stereo PCM audio.

When playing stereo content, the Sonos sound bar will perform an audio up-mix of the stereo signal to create a simulated surround sound. This means you’ll still hear most audio out of the front channels, but the surround speakers will play what is determined to be ambient audio.

Thank you for the explanation of why PCM is producing surround output; I thought that might be what was happening.

Regarding Pass Through with Auto/Bitstream, in the configuration with the Beam, on the TV I can turn off AV Sync Adjustment or select Bypass in the AV Sync Adjustment setting. Not sure what the difference in those options is, but both still leave the dialog out of sync. … In the configuration with the Ray I do have dialog sync off and it seems okay.

 

Userlevel 7

Is there not a Pass Through option under the Digital Sound Out setting on the TV?

Yes and No…. “pass through” is only an option with Optical, not HDMI ARC. I don’t seem to have a dialog sync problem with the Ray using optical, just the Beam using HDMI ARC.

The options are:
Sound > Sound Out > [TV Speaker, Optical, ***HDMI ARC***, etc] > [Auto or PCM]
Sound > Sound Out > [TV Speaker, ***Optical***, HDMI ARC, etc] > Digital Sound Out [Auto, Pass Through, PCM]
Sound > AV Sync Adjustment > [*On* or Off] > if On, [HDMI ARC 1-10 *3*] or Bypass

Hi @twrva ,

Were you every able to resolve this issue with the beam using HDMI Arc? I’m having the same issue with my LG HDTV. Lip sync issues vary depending on content when using the “Auto” sound setting. PCM is the only way to fix the lip sync issue that I’ve found, however this is not ideal for a 5.1 setup.

Thanks!
Mark

After much research, the short (expensive) answer is that I think replacing the TV with a newer model that supports HDMI eARC should “automatically” solve the lipsync problem with Dolby Digital between the TV and Soundbar. I will be interested to see how well this works for different content sources. I have ordered a new TV and will follow up with the results.

Reply