Answered

Beam - TCL (roku) TV sync issues


Hello, I have a beam connected to the following TV via HDMI (ARC):

TCL - 49" Class - LED - 4 Series - 2160p - Smart - 4K UHD TV with HDR Roku TV

I can NOT get the visuals to synch with the audio (ie lip synch issues).

I have (obviously) tried adjusting the delay under the settings for the Beam on the app, but that only makes it worse.

It renders watching tv/movies unwatchable.

Anyone else experiencing this/any ideas?

Thank you.

George
icon

Best answer by Ken_Griffiths 2 September 2018, 09:19

I'm having the exact same with a TCL 49S405 49-Inch 4K Ultra TV and Sonos Beam connected via ARC HDMI. Have tried changing all the settings in audio for the TV: stereo, Dolby, Dolby + etc etc. Absolutely frustrating that I just purchased both of these products new and the ARC cross-talk is not working. Have tried router reset, unplugging, changing settings. All to no avail - the sound is already playing after the relevant video. When is this going to get fixed?
Rpc12,

The thing is that the Beam TV audio-out is working just fine with so many other brands of TV already.

Quite obviously it's the actual TV that processes the audio and sends it out through the HDMI-ARC port. So it's really whether the TV is doing that in a timely manner for the Beam to then play the audio it receives.

It's perhaps notable that the Beam is already working well with plenty of other TV brands, so this might perhaps be an issue with some TCL TV models and that a firmware/software update maybe required.

I don't think anyone can yet jump to any conclusions, as these things sound like some further investigation maybe required here by both TCL and Sonos.

I doubt anyone can yet say what's causing the lip-sync delay, never mind answering your question of "when is this going to get fixed?' ...simply because these matters are only just now being reported and investigated here.

Presumably some enquiries need to be made with TCL too as it seems other people are reporting similar issues with their TV's and other peripherals... as shown in these few 'example' links below:

https://forums.roku.com/viewtopic.php?t=104465

https://www.oddrealities.com/solving-the-tcl-tv-and-sound-bar-problem/

https://www.oddrealities.com/solving-the-tcl-tv-and-sound-bar-problem/

This one mentions problems with a HDMI control board in the TV...
https://www.bestbuy.com/site/reviews/tcl-49-class-led-4-series-2160p-smart-4k-uhd-tv-with-hdr-roku-tv/5878701

And there appears to be quite a few hits when you search google for 'TCL Roku TV and HDMI-ARC problem'.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

25 replies

Userlevel 7
Badge +21
One of the solutions I've seen passed around is to look at the TV's audio settings and make sure that it's not doing any processing of the audio signal in anyway. A lot of TVs have different sound modes and such that can add delay to the signal.
@danny - that’s a really great tip. Will try it. Appreciate it.
Yeah - that didn’t do it. Unfortunately. I’m surprised this isn’t happening to more people. Those TVs are pretty popular. Anyone from @Sonos have any ideas?
Userlevel 7
Badge +26
Hi George, what sources of video do you notice with this problem? Do you only use apps built into the Roku functions of the TV or do you have any HDMI sources connected that have the same problem?

If possible, have you tried changing the TVs audio output settings to stereo instead of Dolby Digital?
gah650,

You haven’t mentioned what other devices you have connected to the TV. Anyhow perhaps try this...

Power off the TV and Beam completely and then reboot your router.

Also remove/reconnect the HDMI cable between the TV and Beam... more importantly remove any other devices connected to the TV HDMI ports.

Once router has rebooted, power on the TV, then power on the Beam, but don’t connect any of your other devices to the TV and then try the audio output again and see if it is now in sync.

Let’s see if that works...

Note: Make sure you have put the Beams lip-sync slider-bar back to its default (left side) setting too.

If this fails, then try changing the TV audio output to PCM.
Sorry Ryan, didn’t mean to interject here, you just beat me to it.
Userlevel 7
Badge +26
Sorry Ryan, didn’t mean to interject here, you just beat me to it.

It's cool, you're asking the right questions 🙂
I'm having the exact same with a TCL 49S405 49-Inch 4K Ultra TV and Sonos Beam connected via ARC HDMI. Have tried changing all the settings in audio for the TV: stereo, Dolby, Dolby + etc etc. Absolutely frustrating that I just purchased both of these products new and the ARC cross-talk is not working. Have tried router reset, unplugging, changing settings. All to no avail - the sound is already playing after the relevant video. When is this going to get fixed?
I'm having the exact same with a TCL 49S405 49-Inch 4K Ultra TV and Sonos Beam connected via ARC HDMI. Have tried changing all the settings in audio for the TV: stereo, Dolby, Dolby + etc etc. Absolutely frustrating that I just purchased both of these products new and the ARC cross-talk is not working. Have tried router reset, unplugging, changing settings. All to no avail - the sound is already playing after the relevant video. When is this going to get fixed?
Rpc12,

The thing is that the Beam TV audio-out is working just fine with so many other brands of TV already.

Quite obviously it's the actual TV that processes the audio and sends it out through the HDMI-ARC port. So it's really whether the TV is doing that in a timely manner for the Beam to then play the audio it receives.

It's perhaps notable that the Beam is already working well with plenty of other TV brands, so this might perhaps be an issue with some TCL TV models and that a firmware/software update maybe required.

I don't think anyone can yet jump to any conclusions, as these things sound like some further investigation maybe required here by both TCL and Sonos.

I doubt anyone can yet say what's causing the lip-sync delay, never mind answering your question of "when is this going to get fixed?' ...simply because these matters are only just now being reported and investigated here.

Presumably some enquiries need to be made with TCL too as it seems other people are reporting similar issues with their TV's and other peripherals... as shown in these few 'example' links below:

https://forums.roku.com/viewtopic.php?t=104465

https://www.oddrealities.com/solving-the-tcl-tv-and-sound-bar-problem/

https://www.oddrealities.com/solving-the-tcl-tv-and-sound-bar-problem/

This one mentions problems with a HDMI control board in the TV...
https://www.bestbuy.com/site/reviews/tcl-49-class-led-4-series-2160p-smart-4k-uhd-tv-with-hdr-roku-tv/5878701

And there appears to be quite a few hits when you search google for 'TCL Roku TV and HDMI-ARC problem'.
Ken,

Thanks for the wonderful response - I will be forwarding this thread along to TCL - as I have already started discussions with them about the issue. I think this is a nice summary of the problem and helps narrow down the issue at-hand.

Ryan
Thanks all - MUCH appreciated. I will try all of these things. In the meantime, i did swap out the hdmi chord that came bundled with the Beam for a high-speed HDMI (I always thought that (high-speed HDMI) was just a marketing ploy). It has improved the situation dramatically. Not completely, but it’s at least watchable now. Again, thank you all for the amazing input. What a great community and great company. George
@Ken - I’d be very interested with what response you get from TCL. If you hear anything would you mind passing it along here - or private messaging me? Thank you.
Actually, upon re-reading, i guess I should have directed my request for an update on what TCL says to @rc12 not to Ken. My apologies. @rc12 - if you happen to see this, and get a response/learn anything from TCL - please dm me here. Thanks. George
I have the exact same issue with my new TCL/ROKU 55” 4K (somehow mine is now syncing fine watching Directv via HDMI thru Beam)
I have the exact same issue with my new TCL/ROKU 55” 4K (somehow mine is now syncing fine watching Directv via HDMI thru Beam) - only w DirectTV - not syncing with other services?
I am having the same issue with my newly purchased TCL Series 6 55" Roku TV. The Beam is connected via the Arc HDMI. There is absolutely no issue with sound from any of the app based sources (Netflix, HBO GO etc). However, when I switch to Cable TV there is a considerable video/audio sync issue. The cable is connected via a DVR box connected to the TV using one of the other HDMI inputs. It is so bad I am debating what to do with my Beam and/or TCL TV.

If anyone has any thoughts on how to fix this I would appreciate it.
Badge
I am having the same issue with my newly purchased TCL Series 6 55" Roku TV.

I've got the same model, so same problem. What did you end up doing?
Userlevel 2
Badge +2
Can anyone turn on their TCL with Alexa? I can turn it off but not on.
Userlevel 7
Badge +26
Hi everyone, if you're still having trouble, we're happy to take a closer look. Could you please post the make and model of the TV or other device that seems to be acting up?
Badge
I have the issue with: TCL 49S405 49 inch TV

I see the issue on both the internal Roku software as well as when i'ms streaming from a fire-stick that i've put in to the tv. There was a suggestion to disable "automatic audio" settings so I've tried both limiting the audio to Stero and Dolby D - neither seems to have fixed the issue.

I'm lucky enough that I purchased the TV recently so its still under the return window.

I'm pretty sure its a TCL/Roku issue not a sonos issue - but maybe if you guys take a look you'll find something useful.
Just purchased a beam and tried connecting it to my tcl 55 p605 and got a noticeable delay when connected via arc. I was running Xbox one x into hdmi1 and an Apple TV 4K into hdmi2. My frontier fios box ran into my Xbox. HUGE delay in my cable box.

Resorted to changing beam to optical and putting cable box on hdmi3. Seems as if my Xbox apps(movies and tv/amazon prime) stream with no noticeable delay. Apple TV also appears to have no delay. Cable box on the other hand is super noticeable.

Anyone else with tcl 6 series seeing lip sync issues?
Just purchased a beam and tried connecting it to my tcl 55 p605 and got a noticeable delay when connected via arc. I was running Xbox one x into hdmi1 and an Apple TV 4K into hdmi2. My frontier fios box ran into my Xbox. HUGE delay in my cable box.

Resorted to changing beam to optical and putting cable box on hdmi3. Seems as if my Xbox apps(movies and tv/amazon prime) stream with no noticeable delay. Apple TV also appears to have no delay. Cable box on the other hand is super noticeable.

Anyone else with tcl 6 series seeing lip sync issues?


quick update on this. I found the manual online for my STB from Frontier Fios (https://www.manualslib.com/manual/1201839/Arris-Vms1100.html). There is a way to get into the system settings and configure the hdmi port. After trying a bunch of different settings I ended up only outputting stereo sound from cable box in order to fix the lip sync. What is still strange to me is I never had this issue when connecting everything to an old Sony receiver. Not sure why swapping out one piece of audio equipment for a Beam could create such an issue with lip sync.
did anyone contact TCL? it's clearly something that lies with them, if the audio output is delayed from the incoming HDMI input they should delay the playback of the video to match the audio out. this needs to be configurable though in case people are using the optical input.

i have solved this issue by taking the optical output from my source (STB in this case) and NOT using the ARC. this works but isn't ideal as now i'm using S/PDIF i have no control of the audio from my STB remote OR the TV remote and need an additional remote (smartphone app), or, use Alexa which i find disruptive in the middle of a movie.
FYI, i have contacted TCL australia support - be interesting to see if the a) even reply b) acknowledge the issue c) offer a workaround d) make a statement they will fix it.

over to you TCL.
Badge
The fix for me was to completely power off the TCL TV, then power it back on. Do this from the TCL TV's menu > Settings > System > Power > System Restart. Before powering off the TV, I had also set TCL TV Settings > Audio > S/PDIF and ARC to Dolby D. For me, this solution worked when connecting the Beam using either the optical or HDMI ARC connection. I prefer HDMI ARC because the TCL TV displays the Beam's volume level on screen while changing volume using the remote control (which does not happen with the optical connection).