Answered

Beam: Keeps switching back to Arc from Bluetooth - how to stop?


Userlevel 2
Badge +3
Hi. I have an LG C8 OLED TV and a Beam, connected Via HDMI Arc. I also have some Sony Bluetooth headphones. Whenever I try and play the TV audio via Bluetooth after 2 seconds it switches back to Arc. Is there anyway to prevent this? I have to pull the HDMI lead out of the Beam, but can it be disabled via the app or some other way? Thanks.
icon

Best answer by chucky999 12 August 2019, 04:10

View original

151 replies

@RBM1505 
As Danny mentions, whatever system you go with next, ensure it doesn’t use HDMI-ARC/eARC with CEC as you’ll certainly just end up with the same issue.

I also agree that powering off the Arc is not the answer - but I would certainly get in touch with the TV Support desk to make them aware that CEC is auto-enabling itself on the TV as ‘that’ is clearly a TV fault with the TV firmware.

I use an LG C9 TV and to switch from the HDMI-ARC/eARC output  to use Bluetooth output, I just toggle off ‘CEC’ (calked ‘Simplink’ on an LG TV) and it automatically disables auto-power-sync (used to power devices on/off) and clearly in the case of your TV that is not working as it should be. I would certainly make the TV manufacturer aware that has caused you an issue here and that it may arise in the future too if you have other CEC enable devices connected to the TV that ‘may’ go onto occasionally steal the output port focus when listening to the audio over a Bluetooth connected headset.

If you disable CEC on the TV - it should stay disabled.

Do you have eARC enabled? 

I have an LG C1. I can get CEC to remain off, I just have to turn off eARC in audio settings first. 

From looking around this doesn’t seem to be an issue with the q950a for example, nor the Bose systems. I will find out soon enough once this return is processed. 

 

The Q950a has HDMI inputs(source) and outputs to the TV.  It does have eARC, but I doubt many users are turning this on, as it would only be needed for TV internal apps.  And it would be a smaller subset of people who use eARC and bluetooth headphones...and the TV CEC doesn’t stay off.

@RBM1505,
Yes of course eARC and CEC are both initially enabled when using the Sonos HT products and CEC (Simplink, or it’s equivalent) must be ‘disabled’ by the user on any/every brand of TV to then use the Bluetooth or any other type of audio output that the TV has.

That’s how the LG TV works with CEC (Simplink) - but once CEC is toggled ‘off’, it should switch off auto-power-sync too (automatically) so that there is then no way the Sonos device can then take back control of the TV (and vice versa) and use the HDMI-2 (ARC/eARC) port. 

CEC should not (ever) auto-enable and switch back ‘on’. If that’s what is happening on the C1, then it’s a firmware fault IMHO - CEC should stay switched ‘off’ allowing you to use your Bluetooth headset.

This will happen with any HT device that uses the TV’s ‘audio return channel features’ with CEC control - but once you switch CEC ‘off’ to use the Bluetooth headset - the TV should not switch back to outputting to the Sonos Arc until you re-enable Simplink (CEC).

It should be a simple case of toggling CEC (Simplink) ‘off/on’ to use your Bluetooth headset and HT system and if that’s not the case, then it is the TV firmware that’s likely at fault.

Even if we were to ask Sonos to ‘fix this’ by switching off CEC at their end - you would find yourself going into the Sonos App settings instead to switch off CEC on the Arc - it’s just as easy, if not far easier, to switch off CEC (Simplink) in the TV settings, plus it’s a toggle feature/option that every TV has already - so it’s not something that Sonos needs to fix anyway IMHO. 

Userlevel 1

@RBM1505 
As Danny mentions, whatever system you go with next, ensure it doesn’t use HDMI-ARC/eARC with CEC as you’ll certainly just end up with the same issue.

I also agree that powering off the Arc is not the answer - but I would certainly get in touch with the TV Support desk to make them aware that CEC is auto-enabling itself on the TV as ‘that’ is clearly a TV fault with the TV firmware.

I use an LG C9 TV and to switch from the HDMI-ARC/eARC output  to use Bluetooth output, I just toggle off ‘CEC’ (calked ‘Simplink’ on an LG TV) and it automatically disables auto-power-sync (used to power devices on/off) and clearly in the case of your TV that is not working as it should be. I would certainly make the TV manufacturer aware that has caused you an issue here and that it may arise in the future too if you have other CEC enable devices connected to the TV that ‘may’ go onto occasionally steal the output port focus when listening to the audio over a Bluetooth connected headset.

If you disable CEC on the TV - it should stay disabled.

Do you have eARC enabled? 

I have an LG C1. I can get CEC to remain off, I just have to turn off eARC in audio settings first. 

From looking around this doesn’t seem to be an issue with the q950a for example, nor the Bose systems. I will find out soon enough once this return is processed. 

 

The Q950a has HDMI inputs(source) and outputs to the TV.  It does have eARC, but I doubt many users are turning this on, as it would only be needed for TV internal apps.  And it would be a smaller subset of people who use eARC and bluetooth headphones...and the TV CEC doesn’t stay off.

 

I could use something like the Q950A + an Nvidia Shield and that would be cost neutral to the Sonos return. Plus I have a bit more functionality with the Shield. 

I tried to turn off auto power sync on the TV and it just re-enables itself - same issue as Simplink. The only option to get this current setup to work would be to either unplug the HDMI (PITA to faff about behind the TV daily) or smart plug which as you say is bad for the speakers. Due to lack of HDMI pass through on the Arc I am limited in work arounds. 

Figuring out if this a fault with the LG or Sonos doesn’t really help me - this issue seems to have been going on for >2 years so I think a software update from either side is unlikely. The Sonos is within it’s return period but the LG is not, so the Sonos system has to go back. 

Same issue , sonos amp. Please sonos fix this problem.

@RBM1505 
As Danny mentions, whatever system you go with next, ensure it doesn’t use HDMI-ARC/eARC with CEC as you’ll certainly just end up with the same issue.

I also agree that powering off the Arc is not the answer - but I would certainly get in touch with the TV Support desk to make them aware that CEC is auto-enabling itself on the TV as ‘that’ is clearly a TV fault with the TV firmware.

I use an LG C9 TV and to switch from the HDMI-ARC/eARC output  to use Bluetooth output, I just toggle off ‘CEC’ (calked ‘Simplink’ on an LG TV) and it automatically disables auto-power-sync (used to power devices on/off) and clearly in the case of your TV that is not working as it should be. I would certainly make the TV manufacturer aware that has caused you an issue here and that it may arise in the future too if you have other CEC enable devices connected to the TV that ‘may’ go onto occasionally steal the output port focus when listening to the audio over a Bluetooth connected headset.

If you disable CEC on the TV - it should stay disabled.

Do you have eARC enabled? 

I have an LG C1. I can get CEC to remain off, I just have to turn off eARC in audio settings first. 

From looking around this doesn’t seem to be an issue with the q950a for example, nor the Bose systems. I will find out soon enough once this return is processed. 

 

The Q950a has HDMI inputs(source) and outputs to the TV.  It does have eARC, but I doubt many users are turning this on, as it would only be needed for TV internal apps.  And it would be a smaller subset of people who use eARC and bluetooth headphones...and the TV CEC doesn’t stay off.

 

I could use something like the Q950A + an Nvidia Shield and that would be cost neutral to the Sonos return. Plus I have a bit more functionality with the Shield. 

I tried to turn off auto power sync on the TV and it just re-enables itself - same issue as Simplink. The only option to get this current setup to work would be to either unplug the HDMI (PITA to faff about behind the TV daily) or smart plug which as you say is bad for the speakers. Due to lack of HDMI pass through on the Arc I am limited in work arounds. 

 

 

One other potential solution is to use an HD Fury Arcana, as that would bypass using the TVs eARC and CEC.  Arcana isn’t cheap though, and you would need an external source like a Shield.  So  I would understand if you just want to go with the Q950A for budget reason. 

Figuring out if this a fault with the LG or Sonos doesn’t really help me - this issue seems to have been going on for >2 years so I think a software update from either side is unlikely. The Sonos is within it’s return period but the LG is not, so the Sonos system has to go back. 

 

It clearly sounds like an LG issue, but LG has little motivation to fix audio related issues on their TVs.  And your return period does matter.

One other potential solution is to use an HD Fury Arcana, as that would bypass using the TVs eARC and CEC.  Arcana isn’t cheap though, and you would need an external source like a Shield.  So  I would understand if you just want to go with the Q950A for budget reason. 

It clearly sounds like an LG issue, but LG has little motivation to fix audio related issues on their TVs.  And your return period does matter.

It must surely be an LG issue, because it all works fine on their C9 OLED TV and it works on an older 2015 LG TV we have in our Home too. We just disable Simplink to use the other TV outputs, like Bluetooth.

There is one other solution I can think of …and that is to purchase a Sonos Port/Connect (gen2), add a Bluetooth transmitter to its line-out and group it with the HT room - I have the Port and can confirm it works okay too and is fine (for me) for lip-sync purposes (unless I just happen to be lucky in that regard)… I just quickly tested it with this cheap transmitter: 

https://www.amazon.co.uk/dp/B07J58KY3X

Userlevel 1

I did consider the Arcana but with the shield it would be nearly 25% of the system cost again for slight convenience. If there were no alternatives, I would settle for disabling eARC, CEC, using headphones & then changing it all back again rather than cover that additional cost. I just have a get out of jail free card given Sonos’ excellent returns period. I was happy to accept enabling/disabling CEC from the quick menu but any more than that is asking too much.

I’m not sure adding a port & grouping it would be an effective solution. It’s the same headset I use with my PC and it’s not unusual my other half is watching TV & I’ll be using my headphones through the PC. I’m not 100% sure but I imagine it will involve more messing about to swap to and fro.

For what it’s worth I’ve emailed LG support today to ask about it. I’ll update with their response. 

I have the same issue as the OP with a Samsung TV.

Seems like the Beam must be sending a constant signal over CEC to force the TV to switch back to it. I thought that CEC would only change the input when a device was first turned on.

Annoyingly this even happens when the Beam is set to output something other than TV. This makes for a poor user experience 😔

Might be worth reading the Wikipedia entry for CEC . Sonos doesn’t really control that system, they just implement the API as it is agreed upon/written by others. 

Sure, but switching inputs is a single CEC command right? So Sonos must keep sending that command. Either that or Samsung is switching input based on some other CEC feature. 

It’s been a while since I read the full CEC spec, but I think, if I remember correctly, its not a turn on/off signal, it’s a “is a client present” or “is a client not present”, matching what you initially suggested in your post.

Which is why, if you read a bunch of the threads about this, folks suggest turning off CEC on the TV set, so it’s no longer looking for the client’s existence, particularly for folks who are trying to add a set of headphones. But it’s the CEC controller, i.e. the TV set, in charge, as opposed to any particular client, such as Sonos.

 

Interesting, thanks for the response!

I did find this page (https://www.samsung.com/us/support/troubleshooting/TSG01111222/#turn-off-automatic-hdmi-switching-with-smart-remote) which suggests it's possible to turn off the automatic switching without turning off CEC, but it had no effect on my TV. 

Yea, to be honest, it’s been seemingly hundreds of years since I did any actual electrical engineering, and much of that was before the existence of CEC, so my understanding of the spec is probably rudimentary at best. 

The joy of the whole thing is that there doesn’t appear to be any “enforcement” function in the spec, so each manufacturer has modified it slightly (in my most humble opinion) to match their own needs….giving priority to their own hardware over someone else’s. So it wouldn’t particularly surprise me that a feature that works on one line of TVs may or may not function on a previous year’s, or different line of TVs. 

It’d be nice if we all played well together, but that doesn’t work for many companies, who want to maximize their own profit over being easy to use with a bunch of random other hardware. Yea, I’m cynical that way :)

Always happy to share my (tainted) views. Having previously worked for Sony (albeit in a games division), I’m always fascinated by the frisson between “we need to work with everyone” and “we need to have/own Betamax/DAT/MiniDisc/ATRAC/MemoryStick/UMD formats that are under our control, and no, you can’t use them without our express consent”. From a corporate perspective, I get the “our company needs to own the market place”, but from a user perspective, I much prefer the “I can use X from company Y, and Z from company AA, and they’ll work well together”. 

Shoot, look at how none of the various networked speaker companies, including Sonos, allow you to mix and match in their home theater products :)

 

This is a pretty disappointing issue to have encountered with my Sonos system.

This was not an issue when using my old cheap Yamaha sound bar.

Temporarily disabling HDMI-CEC does work, and I have found that you can add this toggle to the “quick settings” in WebOS (appear when you single click the gear icon⚙).

I read with interest that Samsung might let you disable automatic HDMI switching and I hope that LG implements this. I personally would prefer to select an input rather that have it automatically selected.

If this issue is a “feature of the CEC spec” then there something is really broken I the spec.

Userlevel 7

Hi @alephsmith 

If you read @Airgetlam’s post closely (just above yours) you’ll come to realize there is “no spec for CEC implementation”. What that means is unlike Bluetooth or  WiFi (802.11 a/b/g/n/ac/ax) there is no governing body that sets the standard.

Long story short the implementation CEC is not broken as there is no spec to break. It’s an open technology (and may be taking a few liberties with the aforementioned wording) that TV manufacturers incorporate into their products in a manner that best suites their needs.

So a fix as you stated would take a gathering similar to the United Nations for TV manufacturers. LOL 😂 

That said… one can only hope 🤔

I switched a few days ago from a Bose SoundTouch 300 and Acoustimass to the Arc with the Sub. Way back when I bought the Bose setup I had the same issues that I do have now with the Arc.

Back then Bose added a button within the Bose App “HDMI-CEC” or something similar to toggle on and off. By toggling it off the issues were GONE. I was able to watch TV and listen to Audio via Bluetooth on the headphones while the Bose was doing something else (e.g. playing music / doing nothing at all), without the bar switching between inputs.

So there is no doubt that this is purely a Sonos issue. TV: LGB7D by the way. Hasn't changed. 

This is super annoying. 

Please get a fix going Sonos!

Hi. I have an LG C8 OLED TV and a Beam, connected Via HDMI Arc. I also have some Sony Bluetooth headphones. Whenever I try and play the TV audio via Bluetooth after 2 seconds it switches back to Arc. Is there anyway to prevent this? I have to pull the HDMI lead out of the Beam, but can it be disabled via the app or some other way? Thanks.

Just researched the same problem….best solution I found was to add the optical adapter to the HDMI cable and plug into the optical port on my TV (Samsung 7000) instead of the HDMI-CEC (ARC) port.  This is good and bad….good in that the TV will recognize when I put my bluetooth headset on (Bose Quietcomfort ear buds) and start playing through them automatically (and it fixes the problem you mention above)….bad because it requires a manual step to put it back to using the Beam...when I turn off my bluetooth headset, the sound begins to play through both my TV speakers and the Beam...have to use the settings in the TV and select the Optical source again to get it to just play through the Beam.  Oh and if you do this, not sure it would matter but be sure to turn off your HDMI-CED selection.

My C1 will not allow me to manually switch off HDMI CEC so this does not work for me. If i unplug the Arc power lead, i need to reinstall it in the app when reconnected. However, unplugging the HDMI lead from the back of my Arc (which is eay to access in front of my tv) allows me to use ear buds, which auto connect as soon as i open the case. When movie time is over, i simply  plug the HDMI back in and the arc becomes the default sound output again. Annoying problem , simple workaround

Found a fairly simple fix to this issue on my Samsung QN50Q80AAF with the Sonos Arc. Basically a Samsung 50 inch QLED purchased in 2022. 

after hooking up and setting up the Sonos Arc, I too could not successfully switch to my Bluetooth receiver setup, which is how I listen with headphones. Turns out you can just got to Settings—>External Device Manager—>Anynet+ (HDMI-CEC). You turn this feature off and it will no longer automatically switch to Sonos Arc constantly, but you also don’t have to turn off or disconnect Arc. Can connect to Bluetooth as usual.

when you want to turn Arc on again, you go back to the Anynet+ setting and turn it back on. Sonos Arc hooks back up.

I have Sonos connected to the HDMI 2 eArc output.

Perhaps would work on other Samsungs?

Userlevel 7
Badge +17

Thank you. Anynet+ is Samsung speak for HDMI-CEC. The solution you found has been mentioned before.

I disabled HDMI-CEC function, or Anynet+ on my Samsung QLED settings so that my Sonos Arc is no longer the default speaker, and I could use my BT headphones. But in doing this, is there a way to use BT headphones AND get sound from the tv speakers at the same time? I want 2 people to be able to watch tv, with 1 getting sound from headphones, and the other from tv speakers. Or, is the answer, as some have indicated on this forum, to purchase a Sonos optical adapter and plug my Sonos Arc into the Optical port? Will that enable 1 to listen to BT headphones and the other to listen to Sonos simultaneously? Is there any downside to using the Optical for the Sonos speaker?

Stumbled across this thread when trying to do the same as everyone else - use some bluetooth speakers so as not to disturb the wife.    And now I understand what is happening, and noting that this has been around for several years, wondered why no-one has suggested another solution that I have been pleading for Sonos to do for even more years - have some wireless headphones that are another Sonos node?    Using a Connect /Port to provide that functionality is completely expensive overkill and still not seamless.   Since most of my Music is played now via Sonos (although I do play my Vinyl direct) everytime I want to use headphones its a faff, and now it seems also if I want to watch someting on TV via Headphones.   wake up someone at Sonos, there have been rumours but nothing yet….

Userlevel 2

Same issue here (some 2+ YEARS later) with Sonos Arc on Samsung Q80R’s ARC HDMI connection. Change sound output to Bluetooth device and the Sonos Arc steals the sound back in a few seconds, if not immediately. VERY frustrating.

Come on Sonos, you can do better than this. There are lots of your customers who need to listen to their TV audio from more than just the Sonos device connected via HDMI cable. This is a game changer for me and I’m heavily invested in the Sonos ecosystem, yet this gives me pause.

Same issue here (some 2+ YEARS later) with Sonos Arc on Samsung Q80R’s ARC HDMI connection. Change sound output to Bluetooth device and the Sonos Arc steals the sound back in a few seconds, if not immediately. VERY frustrating.

Come on Sonos, you can do better than this. There are lots of your customers who need to listen to their TV audio from more than just the Sonos device connected via HDMI cable. This is a game changer for me and I’m heavily invested in the Sonos ecosystem, yet this gives me pause.

Maybe try first toggling off CEC (AnyNet+) on the TV, that usually allows a user to then switch inputs.

Same issue here (some 2+ YEARS later) with Sonos Arc on Samsung Q80R’s ARC HDMI connection. Change sound output to Bluetooth device and the Sonos Arc steals the sound back in a few seconds, if not immediately. VERY frustrating.

Come on Sonos, you can do better than this. There are lots of your customers who need to listen to their TV audio from more than just the Sonos device connected via HDMI cable. This is a game changer for me and I’m heavily invested in the Sonos ecosystem, yet this gives me pause.

 

It’s not Sonos, it’s Samsung.  I have a Samsung TV which will do this all the time, whereas my Toshiba will stay on Bluetooth as long as I want it to. 

Reply